[Stable Update] 2017-09-16 - Kernels, Mesa, VirtualBox, Pamac, KDE, GCC, Removal of OpenRC

update
stable

#21

can’t update because of gcc and gcc-libs, gcc-libs-multilib


#22

yes same here, this is fixed in next version of pamac


#23

#24
warning: manjaro-system: local (20170915-1) is newer than core (20170406-5)
 there is nothing to do

how to solve with this problem…


#25

Nothing, it’s the problem on their side. I have a bunch of packages that are newer than core


#26

the question is I can’t update now… I don’t know what happened


#27

I can’t update now… I don’t know what happened

If you could at least describe your problem… What’s the output after entering the “sudo pacman -Syyu” command in console?

At first let’s begin with recreating your pacman mirrorlist. paste this in terminal:

sudo pacman-mirrors -c all && sudo pacman-mirrors -g && sudo pacman -Syy


#28

Hi @philm.

I use Manjaro OpenRC and this update breaks my system:

  • inittab was deleted
  • don’t start in graphic mode, only console
  • don’t accept my password because i have special characters and don’t start es_es.UTF8

… trying to solve this issues but i don’t know how: what files need to check that exist and where they are.


#29

Thank you, for letting the rest of us know, v. Might save some grief out here in the short term. (I haven’t seen the update pop yet.)


#30

@philm With the last update, I stopped running the 4.13 kernel, I throw this error.


I thought it was version 1.4.0.2 of amdgpu and I downgrade, but that’s not the problem. If any of you do the same. With the other kernels it works fine. regards


#31

Please install the multilib equivalents first.

Check your pulseaudio settings in your home-dir and maybe remove/rename ~/.config/pulse. See also for troubleshooting.

Does running locale-gen help?

Try to call sudo pacman-mirrors -f3 to regenerate a current mirrorlist.

We dropped OpenRC support. Please use Artix or switch to systemd

Try to git-bisect the regression or use a kernel like linux412, which is known to run just fine with amdgpu driver.


#32

@philm,
If drop support, why there are updates for OpenRC that breaks the system?

Now i must reinstall my system. Guau. Yuppy. ■■■■.

eudev 3.2.2-2
libeudev 3.2.2-2
openrc 0.26.3-1
syslog-ng-nosystemd 3.9.1-2
cups-nosystemd 2.2.3-1

More files disappeared:

  • rename this files to .pacsave
    hostname
    hwclock
    keymaps
    modules

Dissapeared files in /etc/conf.d

-rw-r–r-- 1 root root 161 may 30 23:33 agetty
-rw-r–r-- 1 root root 475 may 30 23:33 bootmisc
-rw-r–r-- 1 root root 876 may 30 23:33 consolefont
-rw-r–r-- 1 root root 348 may 30 23:33 devfs
-rw-r–r-- 1 root root 117 may 30 23:33 dmesg
-rw-r–r-- 1 root root 1593 may 30 23:33 fsck
-rw-r–r-- 1 root root 105 may 30 23:33 killprocs
-rw-r–r-- 1 root root 388 may 30 23:33 localmount
-rw-r–r-- 1 root root 270 may 30 23:33 mtab
-rw-r–r-- 1 root root 672 may 30 23:33 net-online
-rw-r–r-- 1 root root 1600 may 30 23:33 netmount
-rw-r–r-- 1 root root 490 may 30 23:33 swap
-rw-r–r-- 1 root root 282 may 30 23:33 urandom


#33

Seems you’re on an outdated mirror:

phil@manjaro ~ $ pacman -Ss eudev
phil@manjaro ~ $ pacman -Ss openrc
core/manjaro-system 20170915-1
    Manjaro Linux System - Update script
community/cronjobs 20160402-1 (openrc-base)
    System cron jobs
community/i3exit 20170616-1 (i3-manjaro)
    Systemd/OpenRC-compatible exit-script for i3, including 'blurlock'
community/oblogout-manjaro 20160929-1
    Systemd/OpenRC-compatible logout script for Openbox, Fluxbox and others.
    Including blurlock
phil@manjaro ~ $ pacman -Ss nosystemd


#34
sudo locale-gen
[sudo] Passwort für lucy: 
Generating locales...
  de_AT.UTF-8... done
Generation complete.

[lucy@otaku-lucy ~]$ locale
LANG=de_AT.UTF-8
LC_CTYPE="de_AT.UTF-8"
LC_NUMERIC=de_AT.UTF-8
LC_TIME=de_AT.UTF-8
LC_COLLATE="de_AT.UTF-8"
LC_MONETARY=de_AT.UTF-8
LC_MESSAGES="de_AT.UTF-8"
LC_PAPER=de_AT.UTF-8
LC_NAME=de_AT.UTF-8
LC_ADDRESS=de_AT.UTF-8
LC_TELEPHONE=de_AT.UTF-8
LC_MEASUREMENT=de_AT.UTF-8
LC_IDENTIFICATION=de_AT.UTF-8
LC_ALL=

what must be in LC-ALL?


#35

On my end there is also nothing. What happens now when executing perl -e exit? Is the error still present?


#36

no error anymore

[lucy@otaku-lucy ~]$ perl -e exit
[lucy@otaku-lucy ~]$

#37


#38

That’s AUR.

Dude! C’mon… :roll_eyes:


#39

@philm

The log:

[2017-09-16 17:39] [ALPM] installed openrc-sysvinit (2.88-10)
[2017-09-16 17:39] [ALPM-SCRIPTLET] To boot using OpenRC append init=/usr/bin/init-openrc to your kernel bootline.
[2017-09-16 17:39] [ALPM] transaction completed
[2017-09-16 17:40] [ALPM] transaction started
[2017-09-16 17:40] [ALPM] warning: /etc/rc.conf saved as /etc/rc.conf.pacsave
[2017-09-16 17:40] [ALPM] warning: /etc/conf.d/modules saved as /etc/conf.d/modules.pacsave
[2017-09-16 17:40] [ALPM] warning: /etc/conf.d/keymaps saved as /etc/conf.d/keymaps.pacsave
[2017-09-16 17:40] [ALPM] warning: /etc/conf.d/hwclock saved as /etc/conf.d/hwclock.pacsave
[2017-09-16 17:40] [ALPM] warning: /etc/conf.d/hostname saved as /etc/conf.d/hostname.pacsave
[2017-09-16 17:40] [ALPM] upgraded openrc (0.26.3-1 -> 0.27.2-1)
[2017-09-16 17:40] [ALPM] transaction completed
[2017-09-16 17:42] [ALPM] transaction started
[2017-09-16 17:42] [ALPM] upgraded libeudev (3.2.2-2 -> 3.2.2-3)
[2017-09-16 17:42] [ALPM] upgraded eudev (3.2.2-2 -> 3.2.2-3)
[2017-09-16 17:42] [ALPM] transaction completed

[2017-09-16 17:42] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-16 17:42] [ALPM] running ‘udev-hwdb.hook’…
[2017-09-16 17:44] [ALPM] transaction started
[2017-09-16 17:44] [ALPM] reinstalled libeudev (3.2.2-3)
[2017-09-16 17:44] [ALPM] reinstalled eudev (3.2.2-3)
[2017-09-16 17:44] [ALPM] transaction completed
[2017-09-16 17:44] [ALPM] running ‘90-linux44.hook’…
[2017-09-16 17:44] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux44.preset: ‘default’

[2017-09-16 17:45] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-16 17:45] [ALPM] running ‘udev-hwdb.hook’…
[2017-09-16 17:48] [ALPM] transaction started
[2017-09-16 17:48] [ALPM] upgraded cups-nosystemd (2.2.3-1 -> 2.2.4-2)
[2017-09-16 17:48] [ALPM] transaction completed
[2017-09-16 17:48] [ALPM] running ‘gtk-update-icon-cache.hook’…
[2017-09-16 17:48] [ALPM] running ‘update-desktop-database.hook’…
[2017-09-16 17:51] [ALPM] transaction started
[2017-09-16 17:51] [ALPM] warning: directory permissions differ on /var/lib/syslog-ng/
filesystem: 700 package: 755
[2017-09-16 17:51] [ALPM] upgraded syslog-ng-nosystemd (3.9.1-2 -> 3.10.1-1)
[2017-09-16 17:51] [ALPM] transaction completed


#40

We can’t control AUR. Those packages are designed for Archlinux. Please convert to systemd or switch to Artix. Also it was discussed for ages.