[Stable Update] 2017-09-16 - Kernels, Mesa, VirtualBox, Pamac, KDE, GCC, Removal of OpenRC

update
stable

#1

Hi community,

with just over one week we have a new update for you. We updated Mesa to v17.2 series, which includes new drivers and other goodies, updated some of our kernels, added latest KDE Frameworks v5.38 plus having GCC v7.2 as our latest compiler. If you have difficulties to update, please install additional multilib packages of gcc first, so a full upgrade is possible.

Additionally we have the latest VirtualBox and Bluez packages plus Python and CertBot renewed. KDE locales got prepared to support Plasma v5.11 series. Last but not least we fixed some BTRFS and LOCALES issues we had within Calamares, when installed for example with German locales.

Guillaume released Pamac v6.0. Read also the release announcement. It now supports appstream.

With this update, however, we also removed the support of OpenRC. For all users who had used that init-system we recommend to either convert back to systemd or try the new project Artix Linux, which is focused on OpenRC only and is also based on Arch Linux. They already have great migration documentations.

Also we decided to ditch linux312 and linux48 series. Please move to another kernel series, if you still use those. No extramodule updates will be provided for these series.

Please report back and give us feedback for given changes made to our repositories.

Best, Philip
Manjaro Project Lead


Current supported Kernels

  • linux310 3.10.107
  • linux316 3.16.48
  • linux318 3.18.71 [EOL]
  • linux41 4.1.43
  • linux44 4.4.88
  • linux49 4.9.50
  • linux410 4.10.17 [EOL]
  • linux411 4.11.12 [EOL]
  • linux412 4.12.13
  • linux413 4.13.2
  • linux-RT-LTS 4.9.40_rt30 (x86_64)
  • linux-RT 4.11.12_rt12 (x86_64)

Package Updates (Sat Sep 16 11:06:16 CEST 2017)

  • stable community i686: 336 new and 470 removed package(s)
  • stable community x86_64: 353 new and 479 removed package(s)
  • stable core i686: 36 new and 40 removed package(s)
  • stable core x86_64: 38 new and 42 removed package(s)
  • stable extra i686: 337 new and 381 removed package(s)
  • stable extra x86_64: 350 new and 397 removed package(s)
  • stable multilib x86_64: 28 new and 31 removed package(s)

A detailed list of package changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


Kernel panic after today's update
Failed to execute init (error -2) kernel panic after latest update
A better App Center
#2

Boots and works. Of course I didn’t test everything (which would be impossible) but saw some errors were fixed which make me happy.
Thanks Phil.

[EDIT] Also updated the second computer and also that one runs great.


#3

Removal of OpenRC

I know we just had 17.0.4 recently. Which in turn also happened shortly after 17.0.3. But the significance of the above in terms of repository changes can’t be overestimated. One just needs to take a look at the list linked on the OP.

So shouldn’t it warrant a new Manjaro release? In particular because it is removing packages that are feature of the current version?


#4

OpenRC was always optional and never announced to be a specific feature of any official released ISO. The version is for the installer only. Since we had fixed some issues we found in our previews ISO spins, we decided to bump again. You can always check our milestones.


#5

Doh! Of course. Nevermind me.


#6

Smooth update.

A few .pacnew’s to plough through but one less (false) error on boot. Manjaro is best. :hugs:


#7

I’ve watched the video and decided to buy a Macbook ,thanks!


#8

Thanks for Blender 2.79 :heart_eyes:


#9

I can not upgrade due to the following error:

5# pacman -Syyu
:: Synchronizing package databases...
 core                                           139.4 KiB  1234K/s 00:00 [########################################] 100%
 extra                                         1780.2 KiB  1471K/s 00:01 [########################################] 100%
 community                                        4.3 MiB  1485K/s 00:03 [########################################] 100%
 multilib                                       178.9 KiB  1491K/s 00:00 [########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
warning: removing 'gcc-libs' from target list because it conflicts with 'gcc-libs-multilib'
warning: removing 'gcc' from target list because it conflicts with 'gcc-multilib'
error: failed to prepare transaction (could not satisfy dependencies)
:: gcc-ada: requires gcc=7.2.0-2
:: gcc-fortran: requires gcc=7.2.0-2
:: gcc-go: requires gcc=7.2.0-2
:: gcc-objc: requires gcc=7.2.0-2

Trying it with pacman-manager gives:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Warning: Entferne 'gcc-libs' aus der Ziel-Liste, da es mit 'gcc-libs-multilib' in Konflikt steht
Warning: Entferne 'gcc' aus der Ziel-Liste, da es mit 'gcc-multilib' in Konflikt steht

Vorgang konnte nicht erfolgreich vorbereitet werden:
Kann Abhängigkeiten nicht erfüllen:
unable to satisfy dependency 'gcc=7.2.0-2' required by gcc-ada
unable to satisfy dependency 'gcc=7.2.0-2' required by gcc-fortran
unable to satisfy dependency 'gcc=7.2.0-2' required by gcc-go
unable to satisfy dependency 'gcc=7.2.0-2' required by gcc-objc

What shall I do?
Matthias


#10

Solved: I had to remove gcc-ada, gcc-fortran, gcc-go and gcc-objc from AUR.

Update went well!!


#11

got these errors:

( 67/157) Aktualisiere mkinitcpio                                                                                 [####################################################################] 100%
Fehler: Konnte Datenbank-Eintrag flatpak-0.9.8-1 nicht entfernen
Fehler: Konnte Eintrag 'flatpak' nicht aus dem Puffer entfernen
( 68/157) Aktualisiere flatpak                                                                                    [####################################################################] 100%

i’ve never used flatpak, so i think i should be fine?

also, 2 pacnews:
/etc/drirc - seems to be profiles for mesa, threaded GL etc. so i replaced the old drirc
/etc/locale.gen - replaced it too as it seems to be just added locales?
is it the recommended way to look and decide yourself if you want to replace/merge pacnews or are there any “official” advices that i missed? ^^

besides that, smooth update on KDE with CLI, thanks team! :smiley:

edit: on reboot, i got the issue that 4.13.2 hard-freezes when loading sddm - the mousecursor gets visible, but the background is still the “shell” with boot-messages and that’s it. No TTY, no reaction, only hard reset.
Luckily 4.12 still works, another proof that it’s always a good idea to keep more than one kernel :sweat_smile:

edit2:
last lines of journalctl for the failed 4.13 start are:

Sep 16 14:42:36 Manjaro-ZZ systemd-journald[252]: Journal started
Sep 16 14:42:36 Manjaro-ZZ systemd-journald[252]: Runtime journal (/run/log/journal/cdd03c52ca2a4a1fb12b48b5747f7808) is 8.0M, max 803.5M, 795.5M free.
Sep 16 14:42:36 Manjaro-ZZ systemd-modules-load[253]: Inserted module 'sg'
Sep 16 14:42:36 Manjaro-ZZ systemd-modules-load[253]: Inserted module 'uinput'
Sep 16 14:42:36 Manjaro-ZZ systemd[1]: Starting Flush Journal to Persistent Storage...
Sep 16 14:42:36 Manjaro-ZZ systemd-journald[252]: Time spent on flushing to /var is 54.370ms for 789 entries.

when looking at the (i hope) according place in the 4.12 journalctl, after the flushing this happens:

Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Started Flush Journal to Persistent Storage.
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Starting Create Volatile Files and Directories...
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Started Create Volatile Files and Directories.
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Starting Update UTMP about System Boot/Shutdown...
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Started Update UTMP about System Boot/Shutdown.
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Started udev Kernel Device Manager.
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Started Rebuild Dynamic Linker Cache.
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Started Rebuild Hardware Database.
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Starting Update is Completed...
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Starting udev Coldplug all Devices...
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Started Update is Completed.
Jun 27 18:59:53 Manjaro-ZZ systemd[1]: Started udev Coldplug all Devices.

maybe someone has an idea on what to try?


#12

Kde edition upgraded well in yakuake shell. Thanks Manjaro Team. Great works!


#13

I have no more sound after the update, just a ‘dummy output’ but managed to fix it


#14

No issue updating on 2 machines, KDE, CLI command.


#15

All OK on Manjaro MATE Laptop…


#16

Folks, please! :unamused:
Do not say that everything went ok. Just vote.

Leave the thread clean for users that do need to report problems updating.
I think @philm et all need to make this clearer on their announcement posts.


#17

sound output lost: it was a bit troublesome but i managed to have it back with alsamixer and pulseaudio settings
soundwise it is all good now!


#18

with xfce: double click on the pamac-tray opens pamac-manager but does not return any result in pamac-manager / single click works fine. This is probably a ‘feature’ and not a bug. I understand I should not double click. I will report it to pamac developpers. fine for me otherwise.


#19
error: could not remove database entry flatpak-0.9.8-1
error: could not remove entry 'flatpak' from cache
( 64/152) upgrading flatpak

(  2/152) upgrading glibc                                                                                                                      [#######################################################################################] 100%
warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
Generating locales...
  de_AT.UTF-8... done
Generation complete.


( 16/152) upgrading mesa                                                                                                                       [#######################################################################################] 100%
warning: /etc/drirc installed as /etc/drirc.pacnew
( 17/152) upgrading p11-kit                      

perl: warning: Please check that your locale settings:
    LANGUAGE = "de",
    LC_ALL = (unset),
    LC_MEASUREMENT = "de_AT.UTF-8",
    LC_PAPER = "de_AT.UTF-8",
    LC_MONETARY = "de_AT.UTF-8",
    LC_NAME = "de_AT.UTF-8",
    LC_ADDRESS = "de_AT.UTF-8",
    LC_NUMERIC = "de_AT.UTF-8",
    LC_MESSAGES = "de_DE.UTF-8",
    LC_TELEPHONE = "de_AT.UTF-8",
    LC_IDENTIFICATION = "de_AT.UTF-8",
    LC_TIME = "de_AT.UTF-8",
    LANG = "de_DE.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

#20

Think so, and I have noticed that Pamac won’t move over my screen any more, it seems to be fixed in 1 corner, a feature?