[Stable Update] 2017-09-08 - Mesa, Kernels, PulseAudio, LibreOffice, KDE Apps, Cinnamon

update
stable

#61

Plasma fails to start after the update, complains about the compositor. I’ve fixed this a few times before, no biggie, by launching kde systemsettings5 from the command line and switching to openGL or whatever the option it doesn’t complain about is. However, now systemsettings5 crashes when clicking on ‘display’ :blush:

systemsettings5
org.kde.kcoreaddons: Error loading plugin "kcm_lookandfeel" "The shared library was not found." 
Plugin search paths are ("/usr/lib/qt/plugins", "/usr/bin") 
The environment variable QT_PLUGIN_PATH might be not correctly set
WARNING: Cannot find style "org.kde.desktop" - fallback: "/usr/lib/qt/qml/QtQuick/Controls/Styles/Desktop"
Trying to use rootObject before initialization is completed, whilst using setInitializationDelayed. Forcing completion
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, profile  QSurfaceFormat::OpenGLContextProfile(NoProfile)) 
fish: “systemsettings5” terminated by signal SIGABRT (Abort)

This is the error:

Plasma is unable to start as it could not correctly use OpenGL 2.
 Please check that your graphic drivers are set up correctly.

$ mhwd -li 
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2017.03.12               false            PCI

SOLVED by uninstalling nvidia drivers and running sudo mhwd -a pci free 0300

Now I don’t have a compositor enabled :slight_smile: but at least plasma runs


#62

Is already in manjaro’s unstable branch. :slight_smile:


#63

Hello, I’m experiencing some issues since last update (Plasma desktop). First, pulseaudio stopped working and I had to disable module echo cancel to get it up again, but I really need this module to work (posted about it here too).

Module error: module echo-cancel: Can’t cancel echo between a sink and its monitor

Then, I noticed kmix is cancelling my session logoff, so I can’t restart my system or just log out of my session.
I appreciate your help.
Regards.


#64

Problem with Qemu 2.10:
1.) Guest (Manjaro) writes the message:
“ACPI Error: Could not disable RealTimeClock events (20160831 / evxfevnt-267
starting version 234
ACPI: No IRQ available for PCI Interrupt Link [LNKS]. Try pci = noacpi or acpi = off”.

When shutting down, it ends with “reboot: Power down” and hangs.

2.) Guest (Win 7 - vfio) ends with the message “Starting Windows”.

Solution:
1.) Downgrade qemu 2.10 > 2.9
or
2.) It would probably help to install the ovmf-git or edk2-ovmf from AUR. Discussion here: https://bugs.launchpad.net/qemu/+bug/1714331 . Unfortunately, it can not be installed from AUR (reports errors).


#65

I had some issues because I waited too between updates (stable). This update appeared to worked, but reboot hung (something like unable to sync init) for all 3 installed kernels (standard Manjaro kernels.) So after playing with manjaro-chroot, searching the forum, trying some things, etc., I decided to re-install. But my cinnamon ISO was too old (17.0), so I wound up with dependency problems trying to update… Moral of the story, the updates are mandatory (don’t procrastinate too long) and a separate home partition is still very useful, even with dedicated data partitions.

So I downloaded the newest Cinnamon ISO (17.03-rc) which installed Manjaro-Cinnamon, which booted fine. FWIW, Calamares ran very smoothly. Then I tried to do the update from the GUI updater. It downloaded the updates but then did nothing. The details screen had two messages, downloading and starting system upgrade. It didn’t hang, it just didn’t install the updates. Anyway, I dropped to a terminal and did the update with pacman. It asked one minor question and then updated successfully.


#66

Is it safe for me to update with all these ‘newer than core’ warnings ?

:: Synchronising package databases...

core 138.9 KiB 1157K/s 00:00 [----------------------] 100%
extra 1820.4 KiB 2.16M/s 00:01 [----------------------] 100%
community 4.3 MiB 2.13M/s 00:02 [---------------------------------------------] 100%
multilib 178.8 KiB 2.10M/s 00:00 [---------------------------------------------] 100%
:: Starting full system upgrade…
warning: acl: local (2.2.52-4) is newer than core (2.2.52-3)
warning: archlinux-keyring: local (20170823-1) is newer than core (20170611-1)
warning: attr: local (2.4.47-3) is newer than core (2.4.47-2)
warning: automake: local (1.15.1-1) is newer than core (1.15-2)
warning: binutils: local (2.28.0-4) is newer than core (2.28.0-3)
warning: bison: local (3.0.4-3) is newer than core (3.0.4-2)
warning: btrfs-progs: local (4.12-1) is newer than core (4.11-1)
warning: ca-certificates-mozilla: local (3.32-1) is newer than core (3.31-3)
warning: curl: local (7.55.1-2) is newer than core (7.54.1-1)
warning: dbus: local (1.10.22-1) is newer than core (1.10.18-1)
warning: device-mapper: local (2.02.173-1) is newer than core (2.02.171-1)
warning: dnssec-anchors: local (20170711-1) is newer than core (20170228-1)
warning: e2fsprogs: local (1.43.5-1) is newer than core (1.43.4-1)
warning: expat: local (2.2.3-1) is newer than core (2.2.1-1)
warning: glib2: local (2.52.3-1) is newer than core (2.52.2+9+g3245eba16-1)
warning: glibc: local (2.25-7) is newer than core (2.25-5)
warning: gnupg: local (2.1.23-1) is newer than core (2.1.21-3)
warning: gnutls: local (3.5.15-1) is newer than core (3.5.13-1)
warning: grep: local (3.1-1) is newer than core (3.0-1)
warning: hwids: local (20170715-1) is newer than core (20170328-1)
warning: icu: local (59.1-2) is newer than core (59.1-1)
warning: iproute2: local (4.12.0-2) is newer than core (4.11.0-1)
warning: libarchive: local (3.3.2-1) is newer than core (3.3.1-5)
warning: libelf: local (0.169-2) is newer than core (0.169-1)
warning: libgcrypt: local (1.8.0-1) is newer than core (1.7.8-1)
warning: libidn: local (1.33-2) is newer than core (1.33-1)
warning: libpipeline: local (1.4.2-1) is newer than core (1.4.1-1)
warning: libpsl: local (0.18.0-1) is newer than core (0.17.0-2)
warning: libsystemd: local (234.11-8) is newer than core (232-8.1)
warning: libtasn1: local (4.12-2) is newer than core (4.12-1)
warning: libtirpc: local (1.0.2-1) is newer than core (1.0.1-3)
warning: libutil-linux: local (2.30-2) is newer than core (2.29.2-2)
warning: linux-firmware: local (20170622.7d2c913-1) is newer than core (20170422.ade8332-1)
warning: linux49: local (4.9.44-1) is newer than core (4.9.35-1)
warning: logrotate: local (3.12.3-1) is newer than core (3.12.2-1)
warning: lvm2: local (2.02.173-1) is newer than core (2.02.171-1)
warning: lz4: local (1:1.8.0-1) is newer than core (1:1.7.5-1)
warning: man-pages: local (4.12-1) is newer than core (4.11-1)
warning: mhwd-nvidia: local (1:375.82-1) is newer than core (1:375.66-1)
warning: nano: local (2.8.6-1) is newer than core (2.8.5-1)
warning: nspr: local (4.16-1) is newer than core (4.15-1)
warning: nss: local (3.32-1) is newer than core (3.31-3)
warning: openvpn: local (2.4.3-3) is newer than core (2.4.3-1)
warning: pacman: local (5.0.2-2) is newer than core (5.0.2-1)
warning: pacman-mirrors: local (4.2.1-1) is newer than core (4.2.0-4)
warning: pcre: local (8.41-1) is newer than core (8.40-1)
warning: popt: local (1.16-9) is newer than core (1.16-8)
warning: psmisc: local (23.1-1) is newer than core (22.21-3)
warning: s-nail: local (14.9.3-1) is newer than core (14.8.16-2)
warning: shadow: local (4.5-2) is newer than core (4.4-3)
warning: sqlite: local (3.20.0-1) is newer than core (3.19.3-1)
warning: systemd: local (234.11-8) is newer than core (232-8.1)
warning: systemd-sysvcompat: local (234.11-8) is newer than core (232-8.1)
warning: util-linux: local (2.30-2) is newer than core (2.29.2-2)
warning: wpa_supplicant: local (1:2.6-8) is newer than core (1:2.6-7)
warning: xfsprogs: local (4.12.0-1) is newer than core (4.11.0-1)
warning: zlib: local (1:1.2.11-2) is newer than core (1:1.2.11-1)


#67

This is a bug in pamac that has since been addressed. :slight_smile:


#68

This shows that your system is trying to use an outdated mirror. You should update your mirrorlist to use an up-to-date one.


#69

A bit of a minor nasty with the new Perl package.

Previously, /usr/lib/perl5/vendor_perl was included in @INC but that’s been replaced with /usr/lib/perl5/5.26/vendor_perl but unfortunately there are still many modules (such as Linux::Inotify2) which are installed in /usr/lib/perl5/vendor_perl so anything depending on them fails.

A workaround is to add

export PERL5LIB=/usr/lib/perl5/vendor_perl

to /etc/profile


#70

No problems with the update, thanx.
VM, KDE-Version, Kernel 4.9


#71