[Stable Update] 2017-09-08 - Mesa, Kernels, PulseAudio, LibreOffice, KDE Apps, Cinnamon



This update is again bad for me:

Probably developers pay attention to intel and do not support AMD. Regression in new kernels is connected with this.:frowning_face:

Please do not kill the kernel 4.11.12-1, I have no problems with it core! :laughing:


I look at it this way: Pamac or Octopi are for installing or removing a random package or three here and there. The command line is for the updates. But this is just my personal opinion and method of software/package management. Whatever way you like is what you should use.


All good, LXDE on old HP G62, ran it via pamac to see if I had any issues. Slick, no problems, will update my other laptop tomorrow


All fine on Mate with 4.9 series kernel.


Smooth update on KDE edition with kernel 4.4/4.9.


This update broke my sound

When i go to sound settings i got no sound devices listed and pavucontrol loads forever. alsamixer is also empty.

I got a lot of these in my log. Only for different PID’s:

Process 1153 (pulseaudio) dumped core

Process 1153 (pulseaudio) of user 1000 dumped core.

Stack trace of thread 1153:
#0 0x00007f798c9108c0 raise (libc.so.6)
#1 0x00007f798c911f72 abort (libc.so.6)
#2 0x00007f798deac5c4 n/a (libpulsecore-11.0.so)
#3 0x00007f798deac685 n/a (libpulsecore-11.0.so)
#4 0x00007f798deb3f09 pa_sink_set_volume (libpulsecore-11.0.so)
#5 0x00007f798dea098b pa_sink_input_put (libpulsecore-11.0.so)
#6 0x00007f79733e34ae module_equalizer_sink_LTX_pa__init (module-equalizer-sink.so)
#7 0x00007f798de8b867 pa_module_load (libpulsecore-11.0.so)
#8 0x00007f798de799bc n/a (libpulsecore-11.0.so)
#9 0x00007f798de8019f pa_cli_command_execute_line_stateful (libpulsecore-11.0.so)
#10 0x00007f798de80954 pa_cli_command_execute_file_stream (libpulsecore-11.0.so)
#11 0x000055ca09936082 main (pulseaudio)
#12 0x00007f798c8fd4ca __libc_start_main (libc.so.6)
#13 0x000055ca0993646a _start (pulseaudio)

Stack trace of thread 1155:
#0 0x00007f798c9c0f76 ppoll (libc.so.6)
#1 0x00007f798de94d20 pa_rtpoll_run (libpulsecore-11.0.so)
#2 0x00007f79839ee201 n/a (libalsa-util.so)
#3 0x00007f798d9de88c n/a (libpulsecommon-11.0.so)
#4 0x00007f798ce8e049 start_thread (libpthread.so.0)
#5 0x00007f798c9caf0f __clone (libc.so.6)

Stack trace of thread 1154:
#0 0x00007f798c9c0f76 ppoll (libc.so.6)
#1 0x00007f798de94d20 pa_rtpoll_run (libpulsecore-11.0.so)
#2 0x00007f79839ee201 n/a (libalsa-util.so)
#3 0x00007f798d9de88c n/a (libpulsecommon-11.0.so)
#4 0x00007f798ce8e049 start_thread (libpthread.so.0)
#5 0x00007f798c9caf0f __clone (libc.so.6)

Stack trace of thread 1156:
#0 0x00007f798c9c0f76 ppoll (libc.so.6)
#1 0x00007f798de94d20 pa_rtpoll_run (libpulsecore-11.0.so)
#2 0x00007f79839f4907 n/a (libalsa-util.so)
#3 0x00007f798d9de88c n/a (libpulsecommon-11.0.so)
#4 0x00007f798ce8e049 start_thread (libpthread.so.0)
#5 0x00007f798c9caf0f __clone (libc.so.6)

Pulseaudio seems to be crashing for some reason.

$ inxi -F

System: Host: manjaro-pc Kernel: 4.12.11-1-MANJARO x86_64 (64 bit) Desktop: Gnome 3.24.3

Distro: Manjaro Linux

Machine: Device: laptop System: Notebook product: N/A

Mobo: Notebook model: P65_67RSRP UEFI: American Megatrends v: 1.05.01 date: 07/13/2016

Battery BAT0: charge: 38.8 Wh 100.0% condition: 38.8/40.7 Wh (95%)
hidpp__0: charge: N/A condition: NA/NA Wh

CPU: Quad core Intel Core i7-6820HK (-HT-MCP-) cache: 8192 KB
clock speeds: max: 3600 MHz 1: 899 MHz 2: 899 MHz 3: 899 MHz 4: 899 MHz 5: 899 MHz 6: 899 MHz
7: 899 MHz 8: 899 MHz

Graphics: Card: NVIDIA GP104M [GeForce GTX 1070 Mobile]

Display Server: x11 (X.Org 1.19.3) driver: nvidia Resolution: 1920x1080@75.00hz

OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 version: 4.5.0 NVIDIA 375.82

Audio: Card-1 NVIDIA GP104 High Definition Audio Controller driver: snd_hda_intel
Card-2 Intel Sunrise Point-H HD Audio driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.12.11-1-MANJARO

Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8168
IF: enp109s0f1 state: down mac: 80:fa:5b:34:be:f7
Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci
IF: wlp110s0 state: up mac: 9c:b6:d0:10:86:ab
Card-3: Qualcomm Atheros
IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A

Drives: HDD Total Size: 1000.2GB (44.0% used)
ID-1: /dev/nvme0n1 model: N/A size: 512.1GB
ID-2: /dev/sda model: HGST_HTS721010A9 size: 1000.2GB

Partition: ID-1: / size: 221G used: 161G (77%) fs: ext4 dev: /dev/nvme0n1p6
ID-2: swap-1 size: 8.79GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p7

Sensors: System Temperatures: cpu: 50.5C mobo: N/A gpu: 49C
Fan Speeds (in rpm): cpu: N/A

Info: Processes: 267 Uptime: 2:19 Memory: 2799.7/15998.6MB Client: Shell (bash) inxi: 2.3.27

$ pacmd list-sinks

No PulseAudio daemon running, or not running as session daemon.

$ systemctl list-units | grep alsa

alsa-restore.service loaded active exited Save/Restore Sound Card State

Tried on both kernel 4.12 and 4.9. No sound. :frowning:


missing wine staging 2.16 and mesa 17.2!
Can we see these added this week please? :smile:


I updated 2 xfce machines without any issue - thanks for the work


Yes me too (posted yesterday) Further testing reveals that:

vlc sounds works okay, but in mpv it doesn’t
In chrome sound works okay but in firefox it doesn’t

I use KDE , which reports no audio output devices. under Audio Volume. In Audio and Video doings a test does make a sound.

Strange, continuing to investigate


Do you use openrc by any chance?


Nope. Using Systemd


I assume you already rebooted your system. What is the output of pactl list sources? Do you went thru basic troubleshooting? Please also check here.


In case anyone else is having a similar problem, I fixed this by creating a symlink to the libperl.so in the perl5 directory

ln -s /usr/lib/perl5/core_perl/CORE/libperl.so /usr/lib/libperl.so


Turned out it was a bad config. Maybe something i have changed. I don’t know. I fixed it by deleting everything in ~/.config/pulse and ~/.pulse then rebooting.

[Stable Update] 2017-09-16 - Kernels, Mesa, VirtualBox, Pamac, KDE, GCC, Removal of OpenRC

Good to know.


Update on 12 Machines without Problems, when I use Kernel 4.12.

When I will use Kernel 4.13, the Systems with AMDGPU and an AMD R7-240 is not starting.
Hangs at the Point to Switch from BootScreen to Login Manager.

Kernel 4.12 starts fine.



We are currently working also on linux414. A lot of new features got added there to amdgpu. Will upload the latest snapshot to unstable.


Mesa 17.2 is in testing arch right now.

It should go to the stable repository of arch first and then will come to manjaro. It will not be delayed. :slight_smile:


The issue with virtualbox was resolved by uninstalling all vbox components and reinstalling from pamac.


I’m also on AMDGPU-experimental and Kernel 4.13 is not working as well.