[Stable Update] 2017-09-08 - Mesa, Kernels, PulseAudio, LibreOffice, KDE Apps, Cinnamon

OK on Gnome, thanks.

1 Like

i got this:

(2/9) Warn about old perl modules
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "de",
        LC_ALL = (unset),
        LC_MEASUREMENT = "de_AT.UTF-8",
        LC_PAPER = "de_AT.UTF-8",
        LC_MONETARY = "de_AT.UTF-8",
        LC_NAME = "de_AT.UTF-8",
        LC_ADDRESS = "de_AT.UTF-8",
        LC_NUMERIC = "de_AT.UTF-8",
        LC_MESSAGES = "de_DE.UTF-8",
        LC_TELEPHONE = "de_AT.UTF-8",
        LC_IDENTIFICATION = "de_AT.UTF-8",
        LC_TIME = "de_AT.UTF-8",
        LANG = "de_DE.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Virtualbox has a problem. Running: # modprobe vboxdrv fails. Running virtualbox gives message to run # /sbin/vboxconfig as root.

Here is the entire terminal output:

# pacman -U *
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (3) linux49-virtualbox-host-modules-5.1.26-5  qt5-x11extras-5.9.1-2
             virtualbox-5.1.26-1

Total Installed Size:  99.22 MiB

:: Proceed with installation? [Y/n] y
(3/3) checking keys in keyring                     [######################] 100%
(3/3) checking package integrity                   [######################] 100%
(3/3) loading package files                        [######################] 100%
(3/3) checking for file conflicts                  [######################] 100%
(3/3) checking available disk space                [######################] 100%
:: Processing package changes...
(1/3) installing linux49-virtualbox-host-modules   [######################] 100%
===> You must load vboxdrv module before starting VirtualBox:
===> # modprobe vboxdrv
(2/3) installing qt5-x11extras                     [######################] 100%
(3/3) installing virtualbox                        [######################] 100%
Optional dependencies for virtualbox
    vde2: Virtual Distributed Ethernet support
    virtualbox-guest-iso: Guest Additions CD image
    virtualbox-ext-vnc: VNC server support
    virtualbox-sdk: Developer kit
:: Running post-transaction hooks...
(1/5) Updating icon theme caches...
(2/5) Updating system user accounts...
(3/5) Arming ConditionNeedsUpdate...
(4/5) Updating the desktop file MIME type cache...
(5/5) Updating the MIME type database...
# modprobe vboxdrv
modprobe: ERROR: could not insert 'vboxdrv': Exec format error

Running virtualbox gives message to run ‘sbin/vboxconfig’ as root:

# /sbin/vboxconfig
bash: /sbin/vboxconfig: No such file or directory

Have confirmed all users are members of vboxusers group.

VBOX was working for the previous kernel?!?

The problem was resolved as follows:

# pacman -R linux49-virtualbox-host-modules qt5-x11extras virtualbox

Then installed virtualbox via pamac. Problem solved. Everything works now! This kernel appears to have an updated linux49-virtualbox-host-modules (5.1.2.204)

is that ed sheeran? first GoT, now manjaro. when will it end? :stuck_out_tongue:

Another perfect update on my machine - no surprises there!

Big thanks to Phil & core team, plus everyone who took the time to test this one upstream.

More power to you all!

Ruziel :slight_smile:

Can you check if any of your other OS’s has /etc/lsb-release?

If there are some without, add entries in /etc/lsb-release as outlined here asd see if this helps. Let us know.

Good luck.

[edit] since there are 4 disks, try making them active (click on any partition there) before doing grub-update and see if that helps also. A spinning disk sometimes ‘sleep’ if inactive.

the other os have /etc/lsb-release

  1. Manjaro Xfce
  2. Debian
  3. Manjaro i3
  4. Manjaro KDE
  5. Manjaro Gnome

all are in EFI with each theirs own /boot/efi

the trouble came with grub2 & os-prober & mount ,
because i have debug lines in journalctl ( more than 24 000 lines )
easy to see with htop

remark : each DE Manjaro create the same boot-id , so we have 4 boot-id ( for each disk)
there are not sleeping disks , all are SSD

cat /etc/lsb-release
DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=17.0.4
DISTRIB_CODENAME=Gellivara
DISTRIB_DESCRIPTION="Manjaro Linux"

lsb_release
LSB Version:	n/a

Anyone else having a problem with VBOX, other that @aaa?

I am on a schedule and need to have VBOX running perfectly right now…

Thank you @philm and Manjaro team. Everything working fine in XFCE environment.

All the best.

Then take a snapshot before applying the update.

Worst case you restore from the snapshot, although I have had no vbox issues (running multiple).

Thanks for the suggestion, but…
host is manjaro, client is win… :wink:
I need to be able to load win right now…

Since this update I have no sound.

There is no output device, I think it is a pulseaudio problem. Seeking to rectify.

1 Like

All fine on my system!

Smooth update on XFCE on desktop and laptop. No issues as of yet.

stephane, I did my update-grub shown here and it took less than 3 minutes (3 disks), from manjaro updated to 17.0.3.

[pop@Sun ~]$ LANG=C
[pop@Sun ~]$ sudo update-grub
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found Intel Microcode image
Found linux image: /boot/vmlinuz-manjaro
Found initrd image: /boot/initramfs-manjaro.img
Found linux image: /boot/vmlinuz-4.13-x86_64
Found initrd image: /boot/initramfs-4.13-x86_64.img
Found initrd fallback image: /boot/initramfs-4.13-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.12-x86_64
Found initrd image: /boot/initramfs-4.12-x86_64.img
Found initrd fallback image: /boot/initramfs-4.12-x86_64-fallback.img
Found Ubuntu Artful Aardvark (development branch) (17.10) on /dev/sda1
Found Ubuntu Artful Aardvark (development branch) (17.10) on /dev/sda2
Found KaOS (rolling) on /dev/sda3
Found Ubuntu Aardvark (17.10) on /dev/sda4
Found Manjaro Linux (17.0.3) on /dev/sda6
Found Manjaro Linux (17.0.3) on /dev/sdb10
Found KaOS (rolling) on /dev/sdb11
Found Mageia 6 (6) on /dev/sdb2
Found Ubuntu Artful Aardvark (development branch) (17.10) on /dev/sdb3
Found Manjaro Linux (17.0.1) on /dev/sdb7
Found Manjaro Linux (17.0.3) on /dev/sdb8
Found Manjaro Linux (17.0.3) on /dev/sdb9
Found Manjaro Linux (17.0.3) on /dev/sdc11
Found Manjaro Linux (17.0.3) on /dev/sdc12
Found Ubuntu Artful Aardvark (development branch) (17.10) on /dev/sdc8
Found openSUSE Tumbleweed on /dev/sdc9
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[pop@Sun ~]$ 

And in my old laptop (bios-legacy) it took slightly more than 4 minutes (1 disk).

I’ll post here when I get to the laptop later.

[pop@Nine ~]$ sudo update-grub
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found Intel Microcode image
Found linux image: /boot/vmlinuz-manjaro
Found initrd image: /boot/initramfs-manjaro.img
Found linux image: /boot/vmlinuz-4.13-x86_64
Found initrd image: /boot/initramfs-4.13-x86_64.img
Found initrd fallback image: /boot/initramfs-4.13-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.12-x86_64
Found initrd image: /boot/initramfs-4.12-x86_64.img
Found initrd fallback image: /boot/initramfs-4.12-x86_64-fallback.img
Found Windows 7 on /dev/sda1
Found Manjaro Linux (17.0.3) on /dev/sda11
Found Linux Mint 17.2 Rafaela (17.2) on /dev/sda12
Found Manjaro Linux (17.0.3) on /dev/sda13
Found KaOS (rolling) on /dev/sda15
Found Windows 10 on /dev/sda2
Found Ubuntu Artful Aardvark (development branch) (17.10) on /dev/sda3
Found Manjaro Linux (16.10) on /dev/sda7
Found Manjaro Linux (17.0.3) on /dev/sda8
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[pop@Nine ~]$ 

I normally disable os-prober in all my OS’s (I use my own grub) so my normal update-grub is quick (15 secs in the uefi system). But I can test it out with it enabled.
Knowing you do not have grub-customizer or grub-repair installed, I don’t know what else can help improve the time for update-grub [1], but I get the feeling it is faster in Kubuntu’s ‘update-grub’. I’ll post the time from Kubuntu here when I boot up to Kubuntu.

From Kubuntu in same system for UEFI, it is slightly less than 2 minutes.

Cheers.

[1] - If the time is too long and as you say all has /etc/ls-release and no grub-customizer or grub-repair, maybe try to reinstall grub (sudo pacman -S grub); maybe it might help.

Yes, already online.

2 Likes

Try disabling secure boot in UEFI, and see if Virtualbox loads your Win client.

the iso manjaro 17.0.4 not exit ?

Thank you very much, i just upgraded and i can confirm everything works ok!!!

Great job once more!!!

Pamac wasn’t showing any updates from ‘community’, even after forcing resync and refresh from the command line.
Was forced to use pacman -Syyu this time. (The recommended method I know. I just think that the GUI updater should work as well, or why is it even there)

Update went well from command line - Cinnamon.

2 Likes

Forum kindly sponsored by Bytemark