[Stable Update] 2017-08-24 thunderbird security update

update
stable
security

#21

Just installed the vanilla Thunderbird x86_64 on Cinnamon stable and everything looks fine. Will report back if something turns out to be broken after all.


#22

Me too, however, I am unable to upgrade. I am currently on thunderbird-i18n-en-us, version 52.2.1:

warning: cannot resolve “thunderbird>=52.3.0”, a dependency of “thunderbird-i18n-en-us”
:: The following package cannot be upgraded due to unresolvable dependencies:
thunderbird-i18n-en-us

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: thunderbird-i18n-en-us: requires thunderbird>=52.3.0


#23

@steve_dude

sudo pacman -U http://repo.stdout.net/manjaro/overlay/sync/thunderbird-52.3.0-1-x86_64.pkg.tar.xz http://repo.stdout.net/manjaro/pool/sync/thunderbird-i18n-en-us-52.3.0-1-any.pkg.tar.xz

Replace x86_64 with i686 if you are on the 32-bit branch.


#24

@ben81, Thanks for the input. I am on 64 bit, but this is the error i received:

sudo pacman -U http://repo.stdout.net/manjaro/overlay/sync/thunderbird-52.3.0-1-i686.pkg.tar.xz
error: failed to prepare transaction (package architecture is not valid)
:: package thunderbird-52.3.0-1-i686 does not have a valid architecture

My syntax wrong?


#25

Yes, it should be x86_64 (64 bit) or just run this instead :

sudo pacman -U http://repo.stdout.net/manjaro/overlay/sync/thunderbird-52.3.0-1-$(uname -m).pkg.tar.xz

#26

@thefallenrat
sudo pacman -U http://repo.stdout.net/manjaro/overlay/sync/thunderbird-52.3.0-1-$(uname -m).pkg.tar.xz
[sudo] password for steve:
error: failed retrieving file ‘thunderbird-52.3.0-1-x86_64.pkg.tar.xz’ from repo.stdout.net : The requested URL returned error: 404
warning: failed to download http://repo.stdout.net/manjaro/overlay/sync/thunderbird-52.3.0-1-x86_64.pkg.tar.xz
error: ‘http://repo.stdout.net/manjaro/overlay/sync/thunderbird-52.3.0-1-x86_64.pkg.tar.xz’: unexpected error


#27

Switch /overlay/sync/ to /pool/overlay :

sudo pacman -U http://repo.stdout.net/manjaro/pool/overlay/thunderbird-52.3.0-1-$(uname -m).pkg.tar.xz

#28

Sorry, @steve_dude for the typo
@thefallenrat is right about switching /overlay/sync to /pool/overlay


#29

I’ve moved the packages to stable with today’s update.


#30

Two machines with Gnome updated without any problem, thanks Lisa.


#31

This thread is obsolete. Update is available via latest stable update pack: