[Stable Update] 2017-08-24 - Kernels, Firefox, KDE Framework & Apps, Budgie, Deepin, Wine

update
stable

#1

Hi community,

this time we have another update to Firefox, the latest Kernels, Budgie v10.4, KDE Framework v5.37, KDE Apps v17.08 and some Deepin package updates. Last but not least latest Wine got also added. Needed security updates to thunderbird will follow soon.

Please report back and give us feedback for given changes made to our repositories.

kind regards

Lisa McCoy
Manjaro Release Manager


Current supported Kernels

  • linux310 3.10.107
  • linux312 3.12.74 [EOL]
  • linux316 3.16.46
  • linux318 3.18.66 [EOL]
  • linux41 4.1.43
  • linux44 4.4.83
  • linux48 4.8.17 [EOL]
  • linux49 4.9.44
  • linux410 4.10.17 [EOL]
  • linux411 4.11.12 [EOL]
  • linux412 4.12.8
  • linux413 4.13-rc6 (x86_64)
  • linux-RT-LTS 4.9.40_rt30 (x86_64)
  • linux-RT 4.11.12_rt10 (x86_64)

Package Updates (Mon Aug 21 08:12:42 CEST 2017)

  • stable community i686: 262 new and 252 removed package(s)
  • stable community x86_64: 286 new and 274 removed package(s)
  • stable core i686: 16 new and 15 removed package(s)
  • stable core x86_64: 18 new and 17 removed package(s)
  • stable extra i686: 615 new and 616 removed package(s)
  • stable extra x86_64: 631 new and 633 removed package(s)
  • stable multilib x86_64: 2 new and 2 removed package(s)

A detailed list of package changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


KDE notification is 1px small
#2

Update went smoothly. Still getting

irq: Invalid fwnode type (2) for irqdomain

with kernel 4.12.


#3

update runs smoothly, without issue yet,
Kernel LTS (4.9)

Solved the issue with KDE notification is 1px small on multiple monitors


#4

Smooth update, no problems. Thanks Manjaro Team :smile:


#5

So far so good, update on 2 machines with Terminal (Manjaro KDE). Thanks.


#6

rebooted and no known problems with update at this time. i must add; i used graphical interface to update. i noticed not many do this. i probably should do terminal update but if there is a problem using gui, would you know? …just sayin :stuck_out_tongue:
thank you, manjaro team :slight_smile:


#7

All OK using Manjaro MATE on a Samsung Laptop


#8

Everything fine with this update, as far as I can tell.

(Bug 1) irq: Invalid fwnode type (2) for irqdomain under kernel 4.12
(Bug 2) xfce4-pulseaudio-plugin & brightness control misbehaving
are still present.


#9

All good in the land of XFCE

thank you


#10

I used to use the GUI, and switched to CLI (Terminal) around January 2017. At this time @Philm informed of some updates needed to be performed with the CLI. It occured maybe once or twice, I don’t remember exactly, but I have found this method better for me.
Anyway when a specific update does require a “Terminal update”, usually Philm (or now Lisa) would notify it in the post, so just read the update information before you update… and for extra security, I would advice to wait a few hours and read the comments of those having updated already.


#11

Manjaro KDE here, updated an hour ago. Next I used, quite intensively, a few of updated packages (firefox, etc): all is ok, thanks a lot! :smile: :white_check_mark:


#12

Smooth update as always. I’m on Xfce but I’m excited to test the new Budgie Desktop.


#13

Another smooth and medium large update (500+ Mb).


#14

Good update. :slight_smile:

Thanks Manjaro Team.


#15

Core 4.9.44 did not solve the problem: https://forum.manjaro.org/t/suspend-to-ram-fix-for-the-lts-kernel-linux49/29602/8 :frowning_face:


#16

Hi community, I have crashes with gnome shell 3.24.3 on Wayland, and it occurs so often.

Dmesg error message
traps: gnome-shell[1168] general protection ip:7f22367e7f4e sp:7ffdd0a4c918 error:0
[15171.541529]  in libgobject-2.0.so.0.5200.3[7f22367b3000+51000]

#17

Received one small update, thunderbird only…about 30MB. :confused:

Give it all of give nothing! :wink:


#18

Update: I could resolve it by replacing libqaccessibilityclient with the new version

For the first time I get errors, which I can’t resolve. Have a look at my output:

cs@christoph-pc ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken…
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung…
:: kdeaccessibility-kmag durch extra/kmag ersetzen? [J/n]
:: kdeaccessibility-kmousetool durch extra/kmousetool ersetzen? [J/n]
:: kdegames-kgoldrunner durch extra/kgoldrunner ersetzen? [J/n]
:: kdegames-kigo durch extra/kigo ersetzen? [J/n]
:: kdegames-konquest durch extra/konquest ersetzen? [J/n]
:: kdegames-kreversi durch extra/kreversi ersetzen? [J/n]
:: kdegames-ksnakeduel durch extra/ksnakeduel ersetzen? [J/n]
:: kdegames-kspaceduel durch extra/kspaceduel ersetzen? [J/n]
:: kdegames-ksudoku durch extra/ksudoku ersetzen? [J/n]
:: kdegames-kubrick durch extra/kubrick ersetzen? [J/n]
:: kdegames-lskat durch extra/lskat ersetzen? [J/n]
Löse Abhängigkeiten auf…
Suche nach in Konflikt stehenden Paketen…
:: libqaccessibilityclient und libkdeaccessibilityclient stehen miteinander in Konflikt. libkdeaccessibilityclient entfernen? [j/N]
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: libqaccessibilityclient und libkdeaccessibilityclient stehen miteinander in Konflikt
[cs@christoph-pc ~]$


#19

Did you try to remove libqaccessibilityclient and make the update, clean the pacman caches then reinstall libqaccessibilityclient ?


#20

I could resolve it by replacing libqaccessibilityclient with the new version