[Stable Update] 2017-08-18 - Kernels, Deepin, Firefox, Xorg-Server, Mesa, Pamac

update
stable

#1

Hi community,

since Philip and Bernhard are currently working on a new side project I’ll help them out as release manager for a while.

So for my second update-pack we have almost updated all our kernel series. Some might have urged for the new Firefox v55 which brings innovative functionality, improvements to core browser performance. Guillaume released Pamac v5.0 to celebrate its 5 years of existens. Also MESA got updated to its latest point-release. Additional packages for deepin, latest firefox and needed fixes for Xorg-Server. Last but not least we have the usual python and haskell updates.

Please report back and give us feedback for given changes made to our repositories.

kind regards

Lisa McCoy
Manjaro Release Manager


Current supported Kernels

  • linux310 3.10.107
  • linux312 3.12.74 [EOL]
  • linux316 3.16.46
  • linux318 3.18.65 [EOL]
  • linux41 4.1.43
  • linux44 4.4.82
  • linux48 4.8.17 [EOL]
  • linux49 4.9.43
  • linux410 4.10.17 [EOL]
  • linux411 4.11.12 [EOL]
  • linux412 4.12.7
  • linux413 4.13-rc4
  • linux-RT-LTS 4.9.40_rt30 (x86_64)
  • linux-RT 4.11.12_rt9 (x86_64)

Package Updates (Tue Aug 15 10:04:08 CEST 2017)

  • stable community i686: 514 new and 488 removed package(s)
  • stable community x86_64: 532 new and 512 removed package(s)
  • stable core i686: 31 new and 31 removed package(s)
  • stable core x86_64: 33 new and 33 removed package(s)
  • stable extra i686: 321 new and 316 removed package(s)
  • stable extra x86_64: 339 new and 334 removed package(s)
  • stable multilib x86_64: 10 new and 10 removed package(s)

A detailed list of package changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

does manjaro will stay on Xorg-Server even on KDE? or will manjaro shift to wayland?

By the way…
Thanks for the update it was really smooth and cool…


#3

Manjaro will not change to Wayland default unytil Nvidia and all open source drivers have Wayland support. So that’s gonna take a while. :slight_smile:


#4

Update went smoothly but brings new error message on boot:

irq: Invalid fwnode type (2) for irqdomain

Is this anything to worry about?

Preceding lines of log-

i801_smbus 0000:00:1f.4: enabling device (0001 -> 0003)
i801_smbus 0000:00:1f.4: SPD Write Disable is set
i801_smbus 0000:00:1f.4: SMBus using PCI interrupt

A few days ago I added another drive to the machine but this message did not appear until this update.


#5

I can confirm this.


#6

Smooth update with Terminal on 2 KDE machines. Thanks !


#7

Well, as NV is not willing to comply to standards and KDE is not willing to deal with nvidias BS, that won’t happen at all :laughing:

As for the Update - no issues on KDE via “pacman -Syyu” here, thanks! :slight_smile:


#8

A

pacman -Syu

tells me

:: Synchronisiere Paketdatenbanken…
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung…
Es gibt nichts zu tun

The same result after running

pacman-mirrors -g

What can I do to get the update?

System:    Host: manjaro64 Kernel: 4.12.4-2-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.10.4
           Distro: Manjaro Linux
Machine:   Device: desktop Mobo: MEDIONPC model: MS-7728 v: 2.0 BIOS: American Megatrends v: E7728MLN.208 date: 08/15/2011
CPU:       Quad core Intel Core i7-2600 (-HT-MCP-) cache: 8192 KB 
           clock speeds: max: 3800 MHz 1: 1601 MHz 2: 1599 MHz 3: 1599 MHz 4: 1614 MHz 5: 1599 MHz 6: 1599 MHz
           7: 1599 MHz 8: 1599 MHz
Graphics:  Card: NVIDIA GF116 [GeForce GT 545]
           Display Server: x11 (X.Org 1.19.3) driver: nvidia Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GT 545/PCIe/SSE2 version: 4.5.0 NVIDIA 375.82
Audio:     Card-1 NVIDIA GF116 High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.12.4-2-MANJARO
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8168
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (10.9% used)
           ID-1: /dev/sdb model: Samsung_SSD_850 size: 250.1GB
           ID-2: /dev/sda model: Samsung_SSD_850 size: 250.1GB
Partition: ID-1: / size: 221G used: 43G (21%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 36.0C mobo: N/A gpu: 42C
           Fan Speeds (in rpm): cpu: N/A

regards
caho

Info:      Processes: 200 Uptime: 5 min Memory: 1352.3/7969.4MB Client: Shell (bash) inxi: 2.3.27

#9

Smooth update.

No suspend problem like someone pointed out in testing.

kernel 4.12.7

Gnome.


#10

No I found the solution here:
https://wiki.manjaro.org/index.php?title=Pacman_Tips

After I run

pacman-mirrors -f 5

the update would be shown and runs without any problems.

regards
caho


#11

Wired internet connection doesnt work, bumblebee seems to be kinda broken. dunno what to do …


#12

have patience, pacman-mirrors -g just looks at which mirrors are closest to you.
check http://repo.manjaro.org/ and “cat /etc/pacman.d/mirrorlist” and you will see that your mirrors are not up do date yet.

You could run “pacman-mirrors -f 5”, that will yield up to date mirrros, but they might be slow for you.


#13

Thanks @Termy,

but I found the solution a short time before … :wink:

regards
caho


#14

irq: Invalid fwnode type (2) for irqdomain

I can also confirm this. Only under kernel 4.12.7 though.


[Stable Update] 2017-08-24 - Kernels, Firefox, KDE Framework & Apps, Budgie, Deepin, Wine
#15

well, litle weird, I have wired connection working for internet browsing for emails but can’t have weather updating on gnome-weather neither on weather gnome shell extension. I can’t sync my diferent calendars, even google ones. I tried evolution (calendars) but it can’t connect…

so, internet connection is working except for syncing weather and calendars (for now)

update 1: and AUR can’t sync neither

update 2: after investigations, problem solved using a post on the manjaro forum : [Solved] After kernel update 2017-02-17 wired connection drops, no dhcpcd, ipv6

The BIG problem in my case was the use of IPV6 with my network card (Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
see top forum link for more explanations)

update 3 : lol> forget update 2
it was just a DNS problem (yes, deleting my network profile do the trick but when I changed my default DNS with those that I have used to use then problem comes back)
So > to finish it was DNS related problem [sorry too long post for pratically nothing]


#16

Manjaro KDE: After the update pulseaudio is using a lot of CPU; see screenshot. Suggestions are welcome.


#17

@jsbach : Have you speech-dispatcher installed? If yes, remove it. This solved my case of extra CPU load, but even before todays major update.


#18

@mbod Yes, that solves the problem. Thank you.


#19

a little bit not good update.
It seems problem , Firefox with flash ( on Kongregate ).


#20

sudo pacman -Syyu update went fine, despite this single warning: could not determine fileinformation…

(81/81) Überprüfe verfügbaren Festplattenspeicher  [######################] 100%
Warnung: konnte Dateiinformationen für etc/xdg/autostart/pamac-tray.desktop nicht ermitteln
:: Verarbeite Paketänderungen...

what exactly is this warning all about?