[Stable Update] 2017-07-20 - Kernels, Architect, Deepin, KDE Apps, Toolchain

update
stable

#41

I’m having a problem

:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: llvm-ocaml: requires ocaml=4.04.1

Thanks…


#42

This update might have broken something in my Haskell environment.
stack build tells me

No compiler found, expected minor version match with ghc-8.0.2 (x86_64-ncurses6-nopie). To install the correct GHC […] try running “stack setup” or use the “–install-ghc” flag.

running stack setup however tells me it’s

Unable to find installation URLs for OS key: linux64-ncurses6-nopie

Outside of a stack project everything works normally. Atom Haskell IDE plugins (throwing masses of errors when a Haskell file from a stack project is open), normal terminal commands like hlint, ghc-mod, stylish-haskell etc.

Probably relevant lines from the update log are:

[2017-07-21 10:21] [ALPM] running 'ghc-unregister.hook'...
[2017-07-21 10:21] [ALPM-SCRIPTLET] unregistering would break the following packages: stack-1.4.0 (ignoring)
[2017-07-21 10:21] [ALPM-SCRIPTLET] unregistering would break the following packages: hoogle-5.0.12 (ignoring)
[2017-07-21 10:21] [ALPM-SCRIPTLET] unregistering would break the following packages: stylish-haskell-0.8.1.0
[...]
[2017-07-21 10:21] [ALPM] upgraded gcc-multilib (7.1.1-3 -> 7.1.1-4)
[2017-07-21 10:21] [ALPM-SCRIPTLET] ==> Unregistering cabalized packages...
[2017-07-21 10:21] [ALPM-SCRIPTLET] ==> Done.
[2017-07-21 10:21] [ALPM] upgraded ghc (8.0.2-2 -> 8.0.2-3)
[2017-07-21 10:21] [ALPM-SCRIPTLET] ==> All cabalized packages need to be reinstalled now.
[2017-07-21 10:21] [ALPM-SCRIPTLET] ==> See /usr/share/haskell/ for a tentative list of affected packages.
[2017-07-21 10:21] [ALPM] upgraded haskell-yaml (0.8.23.1-7 -> 0.8.23.3-1)
[2017-07-21 10:21] [ALPM] upgraded hlint (2.0.9-10 -> 2.0.9-11)
[2017-07-21 10:21] [ALPM] upgraded ghc-mod (5.8.0.0-22 -> 5.8.0.0-24)
[...]
[2017-07-21 10:23] [ALPM] running 'ghc-rebuild-doc-index.hook'...
[2017-07-21 10:23] [ALPM] running 'ghc-register.hook'...
[2017-07-21 10:23] [ALPM-SCRIPTLET] ghc-mod-5.8.0.0: dependency "hlint-2.0.9-7zNfOpx5K9ADHkECLmuMlV" doesn't exist (ignoring)
[2017-07-21 10:23] [ALPM-SCRIPTLET] hpack-0.17.1: dependency "yaml-0.8.23.3-8FJZhPKX9fmLLFoNaNncOM" doesn't exist (ignoring)

I don’t really know what cabalized means. I don’t think I’ve ever used cabal-install explicitly to install anything.


Probem with XMonad
#43

ghc 8.0.2 from repo is broken currently, I have built it from source and work with that.


Probem with XMonad
#44

Updated the Optiplex 980 that caused me the most troubles with the previous stable update, and all the issues I had have been solved for the time being (fingers crossed). With the Kernel 4.12 the boot process now starts sddm (it hanged in console previously), and I did a quick suspend / restore cycle (which didn’t worked on another machine), and this too works apparently fine. Happy as a clam.
Will update my other systems as soon as possible to confirm those results.

M.


#45

Ok, but wouldn’t stack setup download and install its own ghc version from another place than the Arch/Manjaro repos?
I haven’t really understood yet how exactly stack works. :smiley:
Also the whole thing with installing packages via cabal install vs stack install vs installing from Manjaro repos is pretty confusing.

Edit: Ok, seems that it’s the same problem as here https://github.com/commercialhaskell/stack/issues/3268
The workaround seems to be to install ncurses5-compat-libs from AUR … hm
Edit2: Think I’ll just wait until this ncurses6-nopie thing is fixed. I’m not doing important things with Haskell at the moment anyway. :smiley:


#46

Guys from #haskell recommended me stack to avoid ghc problems ;p
But anyway building ghc from source is easy you just need ghc-static to bootstrap it.
Cabal is haskell package manager.


#47

Smooth update on KDE. Thank you


#48

Smooth update on Manjaro KDE, but the problem involving a blank screen after resuming from suspend with kernel 4.12 remains.


#49

Smooth update.

Fixed problem I was having with vlc not terminating properly (window closed but process still running in background) with 4.12 kernel. :joy:


#50

Since the latest update I’ve found that I can’t run any VMs using Virtualbox. Virtualbox tells me that my kernel driver isn’t installed. Executing /sbin/vboxconfig isn’t possible because it isn’t actually there. I’m running 4.9.35-1 and have tried reinstalling linux49-virtualbox-host-modules, but am told that I can’t manually load vboxdrv because of the following error:

modprobe: ERROR: could not insert 'vboxdrv': Exec format error

Restarting my machine hasn’t seemed to help either. I’m sure it’s something minor, but I can’t think what it is!

Any help would be much appreciated.


#51

The vfat mounting module is disabled for some reason on my system after updating. XFCE version.


#52

Updated llvm-ocaml is on the way. Thank you.
https://lists.manjaro.org/pipermail/manjaro-packages/Week-of-Mon-20170717/012195.html


#53

Well, one can only be so much lucky… while my HP Pavilion 13 x 360 boots under kernel 4.12 and gives me the sddm login screen and KDE successfully starts, suspend / restore hangs the machine ; no login screen, no tty login although switching between vt’s does seem to work.
Going back to 4.11 for the time being.
Otherwise, the update is flawless.
Cheers,

M.


#54

no problem with update


#55

Ttransparent update on kernel 4.9, KDE, OpenRC, XFCE. Good job.


#56

All good here with XFCE, thanks.

I did get this on these messages on the upgrade. LVM problem?

[2017-07-22 09:33] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-07-22 09:33] [ALPM] running '99-grub.hook'...
[2017-07-22 09:33] [ALPM-SCRIPTLET] Generating grub configuration file ...
[2017-07-22 09:33] [ALPM-SCRIPTLET] File descriptor 6 (socket:[34762]) leaked on vgs invocation. Parent PID 13865: /usr/bin/grub-probe

The message repeats itself a few times.


#57

there is no issues with my pc
gnome edition, ryzen 7 1800x, asrock taichi x370, polaris 11 rx 460, kernel 4.9, opensource drivers


#58

Hi community,
I get following annoying message in applications like in chromium, uget:

Gtk-Message: Failed to load module “unity-gtk-module”

How do I prevent this?


#59

Thanks team!
:heart: :heart: :heart: :heart: :heart: :heart: :heart:
Melissa


#60

Everything seemed to go smoothly. But, when I rebooted after the update I discovered my network connection was no longer working. There were no connections listed. I tried to create a new connection, but I couldn’t get it to work.

So, I did the update again using chroot from my live usb (following the advice of @thefallenrat from this post )

All good now :slight_smile: