[Stable Update] 2017-07-16 - Kernels, Deepin, Palemoon, KDE-Framework, XFCE4-GTK3

update
stable

#121

From GRUB menu you go and select Advanced Options for Manjaro Linux and from there you can chose the kernel you want and was working. Something like this:


#122

Me too since 4.4.75. An usb stick helps in my case.

inxi -Fxzc0


#123

I noticed it before current update either. And I had just switched from yaourt to pacaur under octopi AUR settings. (make sure you have pacaur installed)


#124

Thanks! I’ll have to wait to see if that helps.

Edit: Nope.


#125

Updated but got a few errors, maybe some mirrors are down?

--2017-07-17 16:51:23--  http://mirror.dacentec.com/manjaro/stable/community/x86_64/community.db.sig
Resolving mirror.dacentec.com... 199.191.56.90, 2607:5600::c7bf:385a
Connecting to mirror.dacentec.com|199.191.56.90|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-07-17 16:51:24 ERROR 404: Not Found.

--2017-07-17 16:51:26--  http://mirror.dacentec.com/manjaro/stable/multilib/x86_64/multilib.db
Resolving mirror.dacentec.com... 199.191.56.90, 2607:5600::c7bf:385a
Connecting to mirror.dacentec.com|199.191.56.90|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 180825 (177K) [application/x-tar]
Saving to: ‘/var/lib/pacman/sync/multilib.db.part’

/var/lib/pacman/sync/multilib.db.part           100%[=====================================================================================================>] 176.59K  --.-KB/s    in 0.1s

#126

I am also having this issue, after updating from 4.11 to 4.12. Dell Inspiron, running KDE.

Edit: after reading arounfd the internet, it seems like the problem is widespread. Changing the options in the power saver menu from lock screen to suspend or hibernate when closing lid did the trick for me. Not a solution, but a workaround, maybe.


#127

No issues so far updating with KDE. Thanks!


#128

I did that and Octopi-notifier’s ghost has turned green without doing anything else. The option to update AUR packages didn’t appear, but it doesn’t say that there are packages to be updated anymore.


#130

Installed 4.12 kernel and no problems thus far.

Total of two extra boots if new kernel has problems. :wink:

I keep 3 kernels installed - new one (4.12), last known working kernel (4.11) and base recommended LTS (4.9). Just deleted 4.10. Yet to encounter kernel problems but I leave it until many reports of success come through. Also make it a point to change kernels separately from updates so source of potential problems seems clearer.

Part of the purpose of installing newer kernels (with stable base) is to provide philm with feedback. Less confident users may wait longer. :grin:

The notification sounds like it needs tweaking (not that I saw it). For stable branch either when philm thinks kernel is ‘stable’ or when default LTS changes?


#131

10 year old laptop got new life with Manjaro :wink:


#132

After the upgrade my system would not boot. I got a message: “loading initial ramdisk” and it was just stuck there.

This turned out to be because I’m running and encrypted system (with lvm) and the boot process wasn’t expecting an encrypted system.

I was able to boot into my system by editing the Grub 2 boot menu entries and added the special Grub commands for booting an encrypted system. https://wiki.archlinux.org/index.php/GRUB#Encrypted_GNU.2FLinux_menuentry (It seems there are at least three ways to configure an encrypted system to boot: the regular method with the encrypt hook in mkinitcpio, the systemd method, and the Grub 2 method–I have no idea if one is better than the other).

After I got into my system, I ran mkinitcpio and this configured a proper initramfs.

My question is, why did this get messed up in the update process? Shouldn’t have the updates to the kernels (I have 4.9 and 4.11 installed) run mkinitcpio and generated a proper initramfs? Neither kernel would boot after the update.

One other factor: I saw there was the new 4.12 kernel and after I ran the update I installed that kernel using the Manjaro Settings Manager. After that I rebooted and 4.12, 4.11, and 4.9 all got stuck at “loading initial ramdisk.”

I vaguely recall that I may have had this problem once before. That if after an update I rebooted my system first and then installed a new kernel with Manjaro Settings Manager, it was fine. But If I installed the new kernel before I rebooted my system I got this problem. (I’m not 100% sure of this recollection.)

Anyway, why should it matter when I install the new kernel after an update and if that’s not the issue, why would mkinitcpio not run properly during an update?


Unable to boot after latest stable update
#133

@sothis6881 @ciacnorris
in my Lxqt octopi just started to work with AUR after pacaur had been chosen. Weirdly enough that it couldn’t help you.


#134

It does not work for me. With kernel 4.12.1, after a resume from suspend I get a blank screen and Ctrl+Alt+F2 followed by Ctrl+Alt+F1 does not change that, unfortunately. I am running Manjaro KDE.


#135

I dont get a grub menu… at least it doesnt pause long enough to display one… what key stroke can I use to get to the menu? I am running this install in a VM… I dont want to blow it away as I use it on the go…

I was wondering if I could correct this by booting up a live ISO changing the already installed system from the booted ISO?


#136

So, after updating my 1st system which wouldn’t start sddm with a 4.12 kernel (everything else working fine otherwise with the 4.11 kernel), I tried to update my desktop PC. Update itself was almost smooth, but windows wasn’t detected on the 2nd disk (sda1), had to run update-grub manually to correct that. Now, this computer goes to sddm with linux412 (and KDE afterwards), but it suffers the ‘suspend’ bug many others have experienced ; once in suspend, it wakes up to a blank screen, and switching to tty2 doesn’t give a text prompt, switching back to X doesn’t reanimate it either. Graphics : Nvidia GTX750Ti 2GB, proprietary drivers. I suspect the card isn’t correctly initialised. Anyway, back to linux411 for the time being.

Next in line : the laptop. But I’ll wait a bit, I can’t have this one fail on me.
Cheers,
M.


#137

Then backup your system beforehand using a tool like Clonezilla, and steer clear of kernel 4.12 until it is stable enough to be used as a daily driver.


#139

There are 5 second by default, right after the BIOS, before it starts automatically the last boot option was used. You can use the UP and DOWN keys to select the Advanced Options and another kernel …

I’m also on KDE, testing branch and have no problem with resume from suspend, just some icons get a bit of artifacts, but that disappears right after switching activities and someone pointed out that is related with the nvidia proprietary drivers.


#140

I tried switching over to Pacaur (after ensuring it’s installed), and had the opposite effect. I can’t see aur updates unless Yaourt is selected. The notifier shows updates then, but I still don’t see it at the bottom of Octopi as it used to.


#141

There are 5 second by default, right after the BIOS, before it starts automatically the last boot option was used. You can use the UP and DOWN keys to select the Advanced Options and another kernel …

Unfortunately there isnt the 5 second timer… I had configured grub to go right into the loading. That’s why I am wondering if I can fix it by booting into a live ISO and fixing it from there. Not feeling too confident about that … OR can i modify my local grub config from the live ISO?


#142

I seem to have similar issues to you, as in my post here as my system will not boot after a recent update and I also have LVM + LUKS. However, when I run mkinitcpio I get this error: ==> ERROR: '/lib/modules/4.9.20-1-MANJARO' is not a valid kernel module directory.