[Stable Update] 2017-07-16 - Kernels, Deepin, Palemoon, KDE-Framework, XFCE4-GTK3



Installed on 2 machines (Dell desktop and Alpha laptop). Both machines are XFCE. Both now running kernel 4.12. No problems so far. No suspend issues on the laptop.

Thanks !


don’t have any issues with XFCE running at 4.12 kernel. only KDE has issue with RAM consumption (only plasmashell is eating up all ram, other apps has no issue). any help?


Everything went smooth on both Laptop and Desktop.
I had one little issue with my desktop but I don’t know if it was due to the last update.
My printer wasn’t reachable for some applications like Vivaldi. I found the solution for this issue here in the forum. I had to install gtk3-printer-backends and after that all is running like a charm…


no issues running XFCE 4.9 on my laptop
after the update it suggested to switch to a newer kernel
running 4.12 now, no issues neither
(falling in love with manjaro more and more!)


Yesterday i updated my system on stable and all was fine. Today there again some packages to update on stable, installing was fine, but after that the kernel modules can’t longer loaded on system startup. Error message in systemd: Failed to insert ‘nvidia’: Exec format error.

After resyncing the mirror list, I see the following error: On all actual mirrors, the coredb can’t be accessed and on all other mirrors the local installed packages are newer than those on the mirrors.

Now, I switched to unstable and run pacman again. Now the system is fine again and the kernel modules can be loaded again.

I think, there is something wrong with the stable tree on the mirrors. Seems, that some packages from testing or unstable went into stable, so that kernel and modules no longer suitable? Eventually the testing or unstable tree was synced to the stable tree on the mirrors?


Should be ok. Only the latest package will exist.


Thanks I’ve made a lot of suggestions


Everything OK.

sudo pacman -Syyu
Kernel 4.9

Vielen Dank!


I run Manjaro KDE and I am facing a problem after the upgrade, namely: with kernel 4.12.1 oftentimes after a resume from suspend I get a blank screen. I can only see the mouse cursor. Is there a fix for that? Thank you.


I don’t think kernel 4.12 is ready for use as a daily driver yet, lots of issues being experienced and reported.

Unless you are a power user kernel junkie probably best for normal Manjaro users to stick with 4.11 until a number of these regressions are fixed in upcoming point releases.


Same problem, Manjaro KDE.


The workaround for that is to switch tty Ctrl+Alt+F2 then back to tty1 Ctrl+Alt+F1 and you will have the login screen …


I have already tried it. Ctrl+Alt+F2, Ctrl+Alt+backspace, Ctrl+Alt+Del… none of these works. I had to use the reset button.


See message above (sorry, I can’t modify it to make it an answer to yours).


Interesting because that was working on one of my installs … I no longer have that issue. Is true that i’m on testing branch and with the 4.12.2-1 kernel i only have some icon artifacts after resume. Someone pointed out that is an NVidia driver issue


I had that on a new desktop I just setup and installed as dual boot. I quick google search from hearing about that issue before fixed it with a “sudo update-grub” from a terminal.[quote=“ciacnorris, post:93, topic:27670, full:true”]
I have done a full update, installed kernel 4.12 and rebooted.

Now I have a single 4.12 entry in the GRUB menu at boot, other kernels and operating systems are not listed any more. This is not a problem for me, but it’s not the way it should work.

The Octopi bug/regression not listing AUR packages to be updated is still there.

I have not tried suspension yet.


I have had a similar issue in the past. It was enough to type my password and press enter even if everything (but the cursor) was black. Now nothing works.


I’m agree with you. I have severe problem in 4.12 .1 kernel. After awaking from suspend, I type password, then enter, System freezes. In other kernels, there isn’t any problem related to this. I use Manjaro 17.0.2 Gnome edition.


No issues. gnome edition, stock kernel free drivers.
amd ryzen 7 1800x, asrock taich x370, sapphire rx 460 (polaris 11)


Update went well… got notified about new kernels… decided to go to 4.12… shutdown and reboot… it appears to go through the process of booting up but it does not go into XFCE… nothing but a black screen. How do I revert the kernel?