[Stable Update] 2017-07-16 - Kernels, Deepin, Palemoon, KDE-Framework, XFCE4-GTK3

update
stable

#61

I noticed that it is related to Wayland. Gnome on Xorg shows correctly.


#62

System: Host: ***-manjaro-pc Kernel: 4.12.1-1-MANJARO x86_64 (64 bit gcc: 7.1.1)
Desktop: Gnome 3.24.2 (Gtk 3.22.16) info: gnome-shell dm: gdm
Distro: Manjaro Linux
Machine: Device: desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x
UEFI [Legacy]: American Megatrends v: 1206 date: 03/07/2016
CPU: Quad core Intel Core i7-6700 (-HT-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27272
clock speeds: min/max: 800/4000 MHz 1: 799 MHz 2: 799 MHz
3: 917 MHz 4: 906 MHz 5: 799 MHz 6: 799 MHz 7: 799 MHz 8: 799 MHz
Graphics: Card: NVIDIA GP106 [GeForce GTX 1060 6GB]
bus-ID: 01:00.0 chip-ID: 10de:1c03
Display Server: x11 (X.Org 1.19.3) driver: nvidia
Resolution: 1920x1080@60.00hz
OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2
version: 4.5.0 NVIDIA 375.66 Direct Render: Yes
Audio: Card-1 NVIDIA GP106 High Definition Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:10f1
Card-2 Intel Sunrise Point-H HD Audio
driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a170
Sound: Advanced Linux Sound Architecture v: k4.12.1-1-MANJARO
Network: Card: Intel Ethernet Connection (2) I219-V
driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6 chip-ID: 8086:15b8
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full
mac: 34:97:f6:90:35:34
Drives: HDD Total Size: 3000.6GB (28.5% used)
ID-1: /dev/sdb model: WDC_WD20EZRX size: 2000.4GB
serial: WD-WCC4N0891244
ID-2: /dev/sda model: ST31000340NS size: 1000.2GB serial: 9QJ065RD
Partition: ID-1: / size: 881G used: 16G (2%) fs: ext4 dev: /dev/sda1
ID-2: /home size: 1.8T used: 745G (43%) fs: ext4 dev: /dev/sdb1
ID-3: swap-1 size: 40.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 1.0:43C
Fan Speeds (in rpm): cpu: 0
Info: Processes: 220 Uptime: 14 min Memory: 1508.9/15969.4MB
Init: systemd v: 233 Gcc sys: 7.1.1 alt: 5
Client: Shell (bash 4.4.121 running in gnome-terminal-) inxi: 2.3.23

And

0 .pacorig found
14 .pacnew found
1 .pacsave found
0 files are orphans

1 16/09/16 17:19:40 /etc/pamac.conf.pacsave

==> Enter n° :


#63

Checked the log and found these entries:

[2017-07-16 11:08] [ALPM] warning: directory permissions differ on /etc/NetworkManager/system-connections/filesystem: 755 package: 700
[2017-07-16 11:08] [ALPM] upgraded networkmanager (1.8.0-1 -> 1.8.2-1)

So, I guess that I’ll have to roll back the upgrade on the networkmanager. Can I do this without a net connection on manjaro? I’ve had a quick look at the forums and what I’ve seen (so far) suggests that I need an internet connection to roll back the upgrade. Is this correct or have I been looking in the wrong place?


#64

good point, it is true that the reminder might be understood as an encouragement to move to the latest kernel even though the current one in use has longterm support. perhaps this should indeed be changed for less confusion - though i have to admit, i normally move to the latest kernel so to benefit from new features.

for me this is the first time i encounter an error like above. does it still affect my system in any way, even after moving to 4.12 (no errors stated) and removing 4.11?


#65

I think I have the answer to my question. I’ve now looked at the pacman wiki and found out how to roll back the package. I’ll have a go and see what happens. With hindsight, the pacman wiki should have been the first thing I looked at!


#66

KDE install running very well, and Xfce-Gtk3 seems to be pretty much ready for roll out. Only problem is the pulseaudio plugin does not want to stick crashes in panel. Looks good and seems faster. Xfwm4 finally provides a tear free experience.


#67

Smooth update, no problems on KDE.


#68

Downgraded network manager with no effect. Manjaro is still not recognising the router/network connection. I can get a connection using an old wifi dongle. Its ok as a stop-gap but its not as quick or secure as the ethernet connection. A full re-install of manjaro is looking quite likely.


#69

Check if you can install older kernel or revert kernel version. /var/cache/pacman/pkg should have already 4.4 if you didn’t cleaned up cache before.


#70

All fine here on KDE, kernel 4.9.37-1, thanks.


#71

check in the log
sudo journalctl -b0 | grep enp

also
ip route show


#72

smooth update on KDE, i would add a notice to the first post that kernel 4.12 has (temporarily?) a different default scheduler.


#73

It’s true and has been discussed here:


#74

Unless you are really cramped for disk space, just don’t remove a working kernel when you decide to test a new one. You can have several kernels installed.

And on a STABLE branch machine, rushing to test a new kernel seems the wrong thing to do. There is probably a reason you are on STABLE, rather than TESTING.

You can switch back and forth each time you boot.


#75

And its a tempest in a teapot.


#76

Decided to reinstall 17.0.2 from a DVD and update from there. It all went smoothly and ethernet connection has been restored. It will take me a couple of hours tomorrow evening to get everything back the way I like it, but at least its all working. Thanks to all who made suggestions, they were greatly appreciated.


#77

@kouros17
Hello, could you solve the suspension problem with the 4.12 kernel? With the 4.11 and 4.9 kernel works fine, with 4.12 after restoring it is left with the mouse and does not skip the screen to enter the password, only when you suspend. regards


#78

Here in KDE land, the update and reboot worked perfectly!


#79

I have exactly the same problem and some others too:


#80

Can You give info about your system, hardware, desktop and which drivers