[Stable Update] 2017-07-16 - Kernels, Deepin, Palemoon, KDE-Framework, XFCE4-GTK3

Update has killed my system, Will not boot, error about not able to load kernel modules.

Also trying to get to tty2 screen takes about 10 mins as it flashes between tty2 login in and the other error screen.

Have installed another kernel using mhwd-kernel, did not make a differents, also tried re-install nvidia graphics driver with mhwd again did not fix this problem.

Booting up live cd of solus to back up some files, then going to replace manjaro with solus.

It seem like working fine. Thanks a lot. Once more, on boot during starting intel services, especially intel-backlight service, I have something like flickering - suddenly the screen turns off (shows black screen) , wait approximately 2-3 seconds, then turns on. Is it normal?

maybe this : Boot fail after last update

Thanks but no that did not work “systemctl default” just repeats the same error kernel module’s error.

The Error on boot is:

[FAILED] Failed to start load kernel modules.


update ok
everythink run ok

I am having an issue with 4.12.1 too. After I close the lid on my laptop, it goes into suspend as normal. I open the lid and I expect to see the SDDM screen to type in my password but I get a black screen with the mouse cursor only (after a split second view of the desktop).

Switching to tty2 gives just a black screen and Ctrl-Alt-F1 does not take me back to the GUI. All I can do is hard reboot (hold down the power button). 4.11.10 works fine and does not exhibit this behavior.

1 Like

could you give kernel before update ,
and if you have any errors
sudo journalctl -p err

I have the same problem here. With kernel 4.9.37-1 no problem.

Kernel 4.11 (the last latest 4.11).

Ok i now am sort of running, i can only boot on kernel 4.9, mhwd is not updating and shows only older kernel’s (e.g. 4.11.8-1 and 4.12rc7, etc) from manjaro setting or terminal mwhd?

pacman -Syyu from terminal is throwing up loads of warnings e.g. warning: apache: local (2.4.26-3) is newer than extra (2.4.26-1), i would say around 100+ warnings of this type which did not happen before update??

journalctl (1-23)
Aug 20 23:11:17 rob-manjaro-pc systemd[1]: Failed to start Wait for Plymouth Boot Screen to Quit.
Aug 20 23:28:49 rob-manjaro-pc systemd-coredump[2266]: Process 2198 (plugin-containe) of user 1000 dumped core.

                                                   Stack trace of thread 2198:
                                                   #0  0x00007f692a2acd28 n/a (libxul.so)
                                                   #1  0x00007f692b368a44 n/a (libxul.so)
                                                   #2  0x00007f692b363206 n/a (libxul.so)
                                                   #3  0x00007f6917548d95 n/a (libgnome-shell-browser-plugin.so)
                                                   #4  0x00007f6922e46a83 n/a (libgio-2.0.so.0)
                                                   #5  0x00007f6922e47126 n/a (libgio-2.0.so.0)
                                                   #6  0x00007f6922ea0f2b n/a (libgio-2.0.so.0)
                                                   #7  0x00007f6922e46a83 n/a (libgio-2.0.so.0)
                                                   #8  0x00007f6922e47126 n/a (libgio-2.0.so.0)
                                                   #9  0x00007f6922e95a9a n/a (libgio-2.0.so.0)
                                                   #10 0x00007f6922e46a83 n/a (libgio-2.0.so.0)
                                                   #11 0x00007f6922e46ab9 n/a (libgio-2.0.so.0)
                                                   #12 0x00007f6923d70c8a g_main_context_dispatch (libglib-2.0.so.0)
                                                   #13 0x00007f6923d71040 n/a (libglib-2.0.so.0)
                                                   #14 0x00007f6923d710ec g_main_context_iteration (libglib-2.0.so.0)
                                                   #15 0x00007f692a49d346 n/a (libxul.so)
                                                   #16 0x00007f692a4a0da6 n/a (libxul.so)
                                                   #17 0x00007f692bb3e3ec XRE_InitChildProcess (libxul.so)

lines 1-23

have you check free space ?
df -Th

check also packages in local
yaourt --stats

if ok
sudo pacman -Syyuu

Are you connected to a fully updated mirror?

Glad it went smooth for you.

I wanted to point out that you got the notification of 4.12 because of the settings you chose (or the default settings) for Manjaro Notifier.

The notification wasn’t meant as an encouragement to jump to the new kernel simply because it appeared, or a suggestion by the Dev Team that everyone run off and install that kernel.

Personally, I’ve pretty much shut off notifications from Manjaro Notifier. If you are not having problems, and you weren’t waiting for a new kernel feature there is no need to change kernels, and certainly no need to be notified.

I think Notifier is designed wrong, and should only notify about End of Life Kernels, and only then if you are running such a kernel.


Thanks a lot. Update was completed without problem.

Free space 871.5GB Boot Drive and 1.1TB on Home Drive, yes i have 2 harddrives.

yaourt --stats:

Total installed packages: 1437
Explicitly installed packages: 366
Packages installed as dependencies to run other packages: 1071
Packages out of date: 0
Where 100 packages seem to no longer be in use by any package:
assimp audiofile bamf boost clutter-gst2 cmake cups-pdf dumb dvgrab fmodex
gamin gcc5 gdb gnome-icon-theme gnome-shell-extension-manjaro-update
gnutls28 gobject-introspection grunt-cli gtk-doc gvim hardening-wrapper
hplip icoutils id3lib intltool js17 lib32-acl lib32-gperftools lib32-json-c
lib32-libcurl-gnutls lib32-libgnutls28 lib32-libpng12 lib32-mpg123
lib32-nettle4 lib32-rtmpdump lib32-sdl2_image lib32-sdl_image
lib32-sdl_mixer lib32-tcp_wrappers libcdaudio libcurl-compat libieee1284
libindicator-gtk2 libindicator-gtk3 liblrdf libmgba liborcus libpng12
librpcsecgss libtinfo libxml++ llvm35-libs manjaro-features
mlt-python-bindings mono-addins mplayer nasm netcdf nettle4 ninja ossp
parallel perl-json perl-text-csv portmidi pygoocanvas python-httplib2
python-pyzmq python2-httplib2 python2-netifaces python2-pillow python2-xdg
pywebkitgtk retro-gtk rubberband ruby-bundler scons sdl2_ttf sdl_net sfml
snappy soundfont-fluid tesseract upx vala webkitgtk wqy-microhei
xcursor-simpleandsoft xorg-iceauth xorg-sessreg xorg-util-macros
xorg-xbacklight xorg-xcmsdb xorg-xgamma xorg-xrefresh xorg-xsetroot yasm
zeitgeist zimg zziplib
Hold packages: (3) pacman glibc manjaro-system
Ignored packages: (0)
Ignored groups: (0)

Number of configured repositories: 4
Packages by repositories (ordered by pacmans priority):
core(199), extra(886), community(177), multilib(130), others*(45)

*others are packages from local build or AUR Unsupported

Running pacman -Syyuu now and is downgrading 1GB of files?

Update-grub needs to be run manually after installing 4.12.1, installing the kernel removed my Windows boot from GRUB. Happened when I tested 4.12.0 last week as well.

Not happening here.

Perhaps you can dig through journalctl and find out some more clues, and perhaps start a separate thread on that.

Did you, by any chance, switched the branches from unstable/testing to stable ?

wait end pacman & reboot
check sudo journalctl -b0 -p err

if none , check sudo journalctl -b0

have you ever done before
sudo pacman -Qtdq ?

no , i think he had started an pacman -Syyu ( before -Syu )


– Logs begin at Sat 2016-08-20 23:10:52 BST, end at Sun 2017-07-16 17:33:02 BST
Jul 16 17:28:24 rob-manjaro-pc kernel: ACPI Error: [_SB_.PCI0.XHC_.RHUB.HS11] N
Jul 16 17:28:24 rob-manjaro-pc kernel: ACPI Exception: AE_NOT_FOUND, During name
Jul 16 17:28:24 rob-manjaro-pc kernel: ACPI Exception: AE_NOT_FOUND, (SSDT:xh_rv
Jul 16 17:28:24 rob-manjaro-pc kernel: ACPI Error: 1 table load failures, 7 succ
Jul 16 17:28:26 rob-manjaro-pc kernel: kvm: disabled by bios
Jul 16 17:28:26 rob-manjaro-pc kernel: kvm: disabled by bios
Jul 16 17:28:19 rob-manjaro-pc systemd-udevd[257]: specified group ‘pgriffais’ u
Jul 16 17:28:22 rob-manjaro-pc systemd-udevd[257]: specified group ‘pgriffais’ u
Jul 16 17:28:37 rob-manjaro-pc ntpd[794]: bind(21) AF_INET6 fe80::2164:b374:370:
Jul 16 17:28:37 rob-manjaro-pc ntpd[794]: unable to create socket on enp0s31f6 (
Jul 16 17:28:51 rob-manjaro-pc systemd[1]: Failed to start Wait for Plymouth Boo
lines 1-12/12 (END)

sudo pacman -Qtdq ?, no never done this before, only ever -Syu or most of the time -Syyu.

My system is asking to update my files again?

Forum kindly sponsored by Bytemark