[Stable Update] 2017-07-04 - Kernels, Firefox, Mesa, Xfce4-Gtk3

update
stable

#41

The only thing I have noticed is the thashcan icon being huge, with every theme.


#42

Thanks for the updates. No problems at all. Everything went smoothly :slight_smile:


#43

Hey, after the update completed i got the warning: directory permissions differ; as in the screenshot:

is this serious? should i do something about it?

Thank you,


#44

I generally change them to 755, but it is probably unnecessary:


#45

drwxr-xr-x 2 root root 4096 4 juil. 16:55 .
-rw-r–r-- 1 root root 2894 9 juin 14:33 NEWS
-rw-r–r-- 1 root root 5634 9 juin 14:33 README
-rw-r–r-- 1 root root 3051 9 juin 14:33 README.systemd

It’s not serious at all, it’s just the “x” bit missing on the directory for (owner/group/other), allowing to “browse” inside the directory which only contain 3 non important text files.
You can “chmod +x /usr/share/doc/nfs-utils/” if you want to comply with the warning.


#46

It has been added as a mandatory dependency to gmerlin. That’s most likely why it was installed for you with the update.

Edit: No, it was already a dependency of gmerlin :wink: :smiley: But it was added to dvgrab:slight_smile:


#47

KDE partitionmanager doesn’t work as expected. If I open it from a terminal it ask’s for the root password and opens the window, loading the harddrives. Changing anything and starting the partition process it opens a window:

Warnung: You do not have administrative privileges.
It is possible to run KDE-Partitionsverwaltung without these privileges. You will, however, not be allowed to apply operations.
Do you want to continue running KDE-Partitionsverwaltung?
Anmerkung: If administrator login is disabled and your password is not accepted, then check kdesu configuration.

If I choose to continue it reopens the main window checking the harddrives not using root. I can’t change anything. I tried changing kdesu config to use sudo and changed back to su. Both doesn’t work.
It worked in former versions, I am not 100% sure if this happened with the last update or earlier.


#48

See below for full details :


It looks like it has been fixed in 3.1.2 . So you may try to install it with this command :

sudo pacman -U http://repo.manjaro.org.uk/pool/sync/kpmcore-3.1.2-1-$(uname -m).pkg.tar.xz

#49

Having a problem with brightness after this upgrade on my Manjaro deepin install.

For whatever reason brightness control now produces very washed out colors . It looks like as if it would be a software filer applied rather than HW controlled.

As result LCD of my Samsung cronos 7 14" laptop which used to produce a very warm color on low brightness turns into washed out gray. Very unpleasant experience .

Any ideas what can be tried to fix this ?

Many thanks,
Konstantin


#50

smooth update XPS9550+KDE


#51

No problems encountered here.


#52

No issues with Deepin. Although not listed I see I have dock animations when launching the program icon and window previews when I hover over a minimized program icon. Never had this before - It’s nice :wink:


#53

Could this update have demoted webkitgtk2 to the AUR?

$ pacman -Qm
epson-inkjet-printer-escpr 1.6.13-1
google-chrome 59.0.3071.115-1
passwordsafe 1.02BETA-2
skypeforlinux-bin 5.3.0.1-1
webkitgtk2 2.4.11-6

$ pacman -Qi webkitgtk2
Name            : webkitgtk2
Version         : 2.4.11-6
Description     : Legacy Web content engine for GTK+ 2
Architecture    : x86_64
URL             : https://webkitgtk.org/
Licenses        : custom
Groups          : None
Provides        : libwebkit=2.4.11
Depends On      : libxt  libxslt  sqlite  libsoup  enchant  libgl  geoclue2
                  gst-plugins-base-libs  libsecret  libwebp  harfbuzz-icu  gtk2
Optional Deps   : gst-plugins-base: free media decoding [installed]
                  gst-plugins-good: media decoding [installed]
                  gst-libav: nonfree media decoding [installed]
Required By     : passwordsafe
Optional For    : None
Conflicts With  : libwebkit
Replaces        : libwebkit
Installed Size  : 43.93 MiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Wed 26 Apr 2017 11:05:53 PM EDT
Install Date    : Fri 12 May 2017 09:39:19 PM EDT
Install Reason  : Installed as a dependency for another package
Install Script  : Yes
Validated By    : Signature

wxWidgets background
#54

Hello @philm

After this update, in “Manjaro Settings Manager” when i try to install/delete one kernel, the GUI doesn’t show the window for write the password and show the work is done but it hasn’t done.

The console command “mhwd-kernel” work ok.

Note: the new GUI cannot to be able to resize the window to see the messages better. I don’t like it.

List of packages upgrade:

upgraded gcc-libs (7.1.1-2 -> 7.1.1-3)
upgraded libgcrypt (1.7.7-1 -> 1.7.8-1)
upgraded expat (2.2.0-2 -> 2.2.1-1)
upgraded libelogind (229.6-1 -> 231.3-1)
upgraded dbus-elogind (1.10.18-1 -> 1.10.18-2)
upgraded llvm-libs (4.0.0-3 -> 4.0.1-1)
upgraded mesa (17.1.3-1 -> 17.1.4-1)
upgraded xkeyboard-config (2.21-1 -> 2.21-2)
upgraded chromium (59.0.3071.109-1 -> 59.0.3071.115-1)
upgraded elogind (229.6-1 -> 231.3-1)
upgraded exo (0.10.7-2 -> 0.11.3-1)
upgraded libx264 (2:148.20170519-1 -> 2:148.20170521-1)
upgraded opus (1.2-1 -> 1.2.1-1)
upgraded firefox (54.0-1 -> 54.0.1-1)
upgraded firefox-i18n-en-us (54.0-1 -> 54.0.1-1)
upgraded firefox-i18n-es-es (54.0-1 -> 54.0.1-1)
upgraded gcc (7.1.1-2 -> 7.1.1-3)
upgraded git (2.13.1-1 -> 2.13.2-1)
upgraded libgtop (2.36.0-1 -> 2.36.0+2+ge0f97e7d-1)
upgraded gksu (2.0.2-5 -> 2.0.2-6)
upgraded glibmm (2.51.7-1 -> 2.52.0-1)
installed libbytesize (0.10-1)
installed volume_key (0.3.9-3)
installed libblockdev (2.9-1)
upgraded udisks2 (2.6.5-1 -> 2.7.0-1)
upgraded gvfs (1.32.1-1 -> 1.32.1+3+gd852665e-1)
upgraded gvfs-gphoto2 (1.32.1-1 -> 1.32.1+3+gd852665e-1)
upgraded gvfs-mtp (1.32.1-1 -> 1.32.1+3+gd852665e-1)
upgraded inxi (2.3.20-1 -> 2.3.23-1)
upgraded iso-codes (3.74-1 -> 3.75-1)
upgraded libevent (2.0.22-4 -> 2.1.8-1)
upgraded libnl (3.2.29-2 -> 3.3.0-1)
upgraded libvoikko (4.1-1 -> 4.1.1-1)
upgraded mkinitcpio-busybox (1.25.1-2 -> 1.26.1-1)
upgraded linux44 (4.4.73-1 -> 4.4.75-1)
[ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
upgraded linux49 (4.9.33-1 -> 4.9.35-1)
[ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
upgraded linux49-ndiswrapper (1.61-26 -> 1.61-28)
upgraded linux49-virtualbox-guest-modules (5.1.22-8 -> 5.1.22-10)
upgraded lua (5.3.4-1 -> 5.3.4-2)
upgraded manjaro-release (17.0.1-1 -> 17.0.2-1)
upgraded manjaro-settings-manager (0.5.3-1 -> 0.5.3-2)
upgraded manjaro-tools-base (0.15.2-5 -> 0.15.2-6)
upgraded mhwd-db (0.6.0rc2-1 -> 0.6.0-1)
upgraded mhwd (0.6.0rc2-1 -> 0.6.0-1)
upgraded nano (2.8.4-1 -> 2.8.5-1)
upgraded nfs-utils (2.1.1-3 -> 2.1.1-4)
upgraded openvpn (2.4.2-1 -> 2.4.3-1)
upgraded poppler (0.55.0-3 -> 0.56.0-1)
upgraded poppler-qt5 (0.55.0-3 -> 0.56.0-1)
upgraded python-ptyprocess (0.5.1-2 -> 0.5.2-1)
upgraded texinfo (6.3-2 -> 6.4-1)
upgraded thunar (1.6.11-2 -> 1.6.12-1)
upgraded unrar (1:5.5.5-1 -> 1:5.5.5-2)
upgraded vertex-maia-themes (20170621-1 -> 20170702-1)
upgraded webkit2gtk (2.16.4-1 -> 2.16.5-1)
upgraded wpa_supplicant (1:2.6-6 -> 1:2.6-7)
upgraded xfce4-screenshooter (1.8.2-3 -> 1.9.1-1)
upgraded xfdesktop (4.12.3-3 -> 4.12.4-1)

#55

Unable to boot at the moment, so I just made a post about it. This is the first time this has happened to me with my Manjaro installation.


#56

Using xfce, smooth update via terminal, thanks to everyone!


#57

ok thank you


#58

QTdesigner5 crashes on start.

Found the culprit and a solution : Manjaro KDE : designer-qt5 crash on start

Basically, remove extra/kdewebkit package. It also removes kplotting.

Cheers,

M.


#59

Sounds strange. Could you maybe report the issue here?


#60

Manjaro Cinnamon here, everything seems to have gone a-ok for me.

Thanks guys.