[Stable Update] 2017-07-04 - Kernels, Firefox, Mesa, Xfce4-Gtk3



Since this appears to be a very smooth update for me and for most people, I’ll take this opportunity to provide a little feedback on the rough edges.

Last several updates, it’s been necessary to update-grub manually in order to get my other multiboot partitions back on the grub menu. It always works, after that extra step, so no harm done. Just an extra step.

The other thing that happens often, over an even longer period with Manjaro, is that certain applications won’t work after updating, and need to be reinstalled … even if they weren’t updated themselves specifically.

Filezilla is one this happens a lot with, but not this time.

Freefilesync broke this time. There were notes for it in the AUR (“uncomment line 34”), and after following them it reinstalled correctly.

Currently the only semi-permanent casualty appears to be Iceweasel, which isn’t finding a source repo at the old URL. Upstream issue no doubt.

These applications that break often on update also seem to have one other interesting thing in common. If you go in to Add/Remove Software and search for them, they end up being listed as in the Manjaro repos, as well as available from the AUR. Best I can tell, the showing up in the repos part is a bug–they’re not really in the repos, but AUR packages pure and simple.

Anyway. That’s my fine-grained complaining for the day. Overall I continue to be quite happy with my OS and grateful to you all for the work you do.



A wonderfully smooth 4th of July update. And only about 500 and some meg to boot. :smile::laughing:


I didn’t know freedom came with this update.

Also I got some interesting output I haven’t seen before in Konsole while running this update. Any cause for alarm?

:: Running pre-transaction hooks...
(1/2) Unregistering Haskell modules...
unregistering would break the following packages: pandoc- yaml- (ignoring)
unregistering would break the following packages: http-client-tls- (ignoring)
unregistering would break the following packages: resourcet-1.1.9 (ignoring)
unregistering would break the following packages: texmath-0.9.4 (ignoring)
(2/2) Removing old entries from the info directory file...
( 5/10) Registering Haskell modules...
conduit-1.2.11: dependency "lifted-base-" doesn't exist (ignoring)
conduit-1.2.11: dependency "monad-control-" doesn't exist (ignoring)
conduit-1.2.11: dependency "resourcet-1.1.9-DJf1ANdxSraDnKUpiOoSOA" doesn't exist (ignoring)
connection-0.2.8: dependency "tls-1.3.11-2bkxECTaNsr2smYNjiQWEM" doesn't exist (ignoring)
http-client-tls- dependency "tls-1.3.11-2bkxECTaNsr2smYNjiQWEM" doesn't exist (ignoring)
lifted-base- dependency "monad-control-" doesn't exist (ignoring)
pandoc-types- dependency "QuickCheck-" doesn't exist (ignoring)


Running KDE. Every thing was perfect. No Haskell updates, so good. It did request that I add libquicktime, I did but what is that about? I may delete it.


Everything went smoothly, also, this update fixed the infinite bookmarks loop in Firefox-kde for me, thank you!


I have the KDE version, update went fine, didn’t notice any bugs or anything like that.


My system fails to boot after this update (systemd-login.service fails to start). I have provided more details here: https://forum.manjaro.org/t/boot-fail-after-last-update/27132?u=icedaddy



I was updating my system today when it abruptly restarted ( most possibly loose cable somewhere, happened many times). When it restarted it could not recognise any wifi connection. When updating via the terminal it is showing the following error:

error: could not open file /var/lib/pacman/local/wpa_supplicant-1:2.6-7/desc: No such file or directory

I guess wpa_supplicant has become corrupted. I tried to downgrade the package but it shows up with “error: failed to prepare transaction (invalid or corrupted package)”.
So anyone can tell me how to fix this?


As Protokol already reported, Gnome online accounts (google email etc…) appears to be completely broken here.
First it claims your credentials are expired, OK fine. Then you try to put new passwords into “Online Accounts” and it totally skips the step to enter the password or the window is invisible or something.

So as a work around I guess I will set up Thunderbird again. :unamused:

I noticed during update that we where getting updated gksu and goa stuff.


Smooth update on my KDE, thanks :smiley:


SMooth update on 4 machines. Thanks!


If software from the AUR was installed by you and you search this specific software in Octopi, it is listed like any other software. The green alien in front of it shows that it is a package from AUR.
The picture shows qtwebkit in my list because I searched for the term “webk”. This package is from AUR (green alien symbol) while the others just get green ticked boxes if installed.


How about simply installing the package again? And if it says corrupted then clear cache so it gets downloaded again.


@oreki78, Try this :

sudo touch /var/lib/pacman/local/wpa_supplicant-1:2.6-7/desc
sudo touch /var/lib/pacman/local/wpa_supplicant-1:2.6-7/files
sudo pacman -S --force wpa_supplicant

Hope this helps…

Source :


Update turned out okay but some minor hiccups. :neutral_face:

After applying updates I went to reboot and system did not shut down. Got a blinking white cursor on black. No tty or keyboard, including shortcut, response. Eventually I manually powered the system down. On reboot there was a flash of several (a dozen?) lines of message - shown on same screen and directly following the acpi errors I get from out of date firmware - but journalctl does not show what they were. All seems okay now (several boots later) but thought experience worth reporting. Anywhere else those lines might have been logged?


Thanks very kindly for that complete answer, Sir. I’m talking Pamac though.


Hi! I have problems with calibre update.
This is what I get:

error: could not extract /usr/lib/calibre/calibre/gui2/preferences/metadata_sources_ui.py (Lzma library error: Corrupted input data)
error: problem occurred while upgrading calibre
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.

I am running Manjaro Xfce 32bit. Thanks!

EDIT: After running the pacman -Syyu again the error disappeared and now I am fine with the update! All well again! Thanks!


boincmgr stopped working after this update.

boincmgr: error while loading shared libraries: /usr/lib/libwebkit2gtk-4.0.so.37: file too short

Tried reinstalling boinc


Update on 12 Machinres without Problems.




Thanks that worked!! :smile: