[Stable Update] 2017-06-26 - Cinnamon, Kernels, LibreOffice, Haskell

update
stable

#21

Stable, KDE, pacman -Syyu. Smooth update, no problems.


#22

I didnā€™t think I had any Haskell stuff installed, but apparently I now do as there are lots of haskell packages installed as a dependency of another package.

Just donā€™t know what the dependency was that pulled all this haskell stuff in, its like trying to untangle a long fishing line.

Anyway, lots of errors / warningsā€¦

( 7/15) Registering Haskell modules...
aeson-1.1.2.0: dependency "attoparsec-0.13.1.0-ETec0FJZJHgARrgZXhaej9" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "base-compat-0.9.3-KeJp8zYMpcS9WibvTcxU22" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "dlist-0.8.0.2-6Wnps4GD7EFnRucVzXIFD" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "hashable-1.2.6.1-2nPqxcHq7mUGgurrYaLtXr" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "scientific-0.3.4.15-Is44CvKqXBF5ugVqyS94hI" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "tagged-0.8.5-DG0qxw3gXxx4NfDcDx4Iai" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "time-locale-compat-0.1.1.3-KZ1jqNx8uhlHjmuPPj6V1Y" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "unordered-containers-0.2.8.0-1tqMF698WJE3INvmpuzQZc" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "uuid-types-1.0.3-I7xNINqiSgy8XiSgWjW585" doesn't exist (ignoring)
aeson-1.1.2.0: dependency "vector-0.12.0.1-692PQMDMB6pIQ1uGwefDcQ" doesn't exist (ignoring)
asn1-encoding-0.9.5: dependency "asn1-types-0.3.2-5wnfVxEnJ3kDfiPJu0Wloe" doesn't exist (ignoring)
asn1-encoding-0.9.5: dependency "hourglass-0.2.10-pnbvWmzfcY1rOFETQEmcY" doesn't exist (ignoring)
asn1-parse-0.9.4: dependency "asn1-types-0.3.2-5wnfVxEnJ3kDfiPJu0Wloe" doesn't exist (ignoring)
asn1-types-0.3.2: dependency "hourglass-0.2.10-pnbvWmzfcY1rOFETQEmcY" doesn't exist (ignoring)
asn1-types-0.3.2: dependency "memory-0.14.6-vm2tIOaikKE3jdFeeotzN" doesn't exist (ignoring)
async-2.1.1.1: dependency "stm-2.4.4.1-iSYwp3RMY11sHCifJ3gtR" doesn't exist (ignoring)
attoparsec-0.13.1.0: dependency "scientific-0.3.4.15-Is44CvKqXBF5ugVqyS94hI" doesn't exist (ignoring)
attoparsec-0.13.1.0: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
blaze-builder-0.4.0.2: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
blaze-html-0.8.1.3: dependency "blaze-markup-0.7.1.1-Amik95gvtJH76XeEGEdOV0" doesn't exist (ignoring)
blaze-html-0.8.1.3: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
blaze-markup-0.7.1.1: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
case-insensitive-1.2.0.10: dependency "hashable-1.2.6.1-2nPqxcHq7mUGgurrYaLtXr" doesn't exist (ignoring)
case-insensitive-1.2.0.10: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
cmark-0.5.5.1: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
conduit-1.2.11: dependency "exceptions-0.8.3-8AMTYj188ri8VOH6LXt0Fd" doesn't exist (ignoring)
conduit-1.2.11: dependency "lifted-base-0.2.3.11-797F0GSRM4GHiCBSQ3AJmQ" doesn't exist (ignoring)
conduit-1.2.11: dependency "mmorph-1.1.0-BKb9vDVN1ubG7npUIlJCzH" doesn't exist (ignoring)
conduit-1.2.11: dependency "monad-control-1.0.2.0-10S0ywqdsCPHnUTlxJLEct" doesn't exist (ignoring)
conduit-1.2.11: dependency "mtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6" doesn't exist (ignoring)
conduit-1.2.11: dependency "primitive-0.6.2.0-4578caNkWQ54Gt1mxLF2Yh" doesn't exist (ignoring)
conduit-1.2.11: dependency "resourcet-1.1.9-8dcH1R5asu46j8AjnoNKK5" doesn't exist (ignoring)
conduit-1.2.11: dependency "transformers-base-0.4.4-H3XecnBtTa65CX4xecxCVH" doesn't exist (ignoring)
connection-0.2.8: dependency "data-default-class-0.1.2.0-N42RtcTZUUAlapzICmPz4" doesn't exist (ignoring)
connection-0.2.8: dependency "network-2.6.3.2-IsLM4TXcLoRI0fmmBYVyQz" doesn't exist (ignoring)
connection-0.2.8: dependency "socks-0.5.5-F6g2yipDTNR4qkKBdXbx5L" doesn't exist (ignoring)
connection-0.2.8: dependency "tls-1.3.10-I9fEZw7nolG6qstp6qpez8" doesn't exist (ignoring)
connection-0.2.8: dependency "x509-1.6.5-1lNlFxDfEv2287NoJBDt9f" doesn't exist (ignoring)
connection-0.2.8: dependency "x509-store-1.6.2-2JTK3MuGtMw4U8lTBVjl8Z" doesn't exist (ignoring)
connection-0.2.8: dependency "x509-system-1.6.4-KrQrp9ANFMlLdIdHg4WE94" doesn't exist (ignoring)
connection-0.2.8: dependency "x509-validation-1.6.5-KkCaCznBsGnI4IiJkZhJEe" doesn't exist (ignoring)
cookie-0.4.2.1: dependency "data-default-class-0.1.2.0-N42RtcTZUUAlapzICmPz4" doesn't exist (ignoring)
cookie-0.4.2.1: dependency "old-locale-1.0.0.7-KGBP1BSKxH5GCm0LnZP04j" doesn't exist (ignoring)
cookie-0.4.2.1: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
cryptonite-0.23: dependency "foundation-0.0.12-5lnv5i2ZfFl5UxQG6gGkPM" doesn't exist (ignoring)
cryptonite-0.23: dependency "memory-0.14.6-vm2tIOaikKE3jdFeeotzN" doesn't exist (ignoring)
data-default-instances-dlist-0.0.1: dependency "dlist-0.8.0.2-6Wnps4GD7EFnRucVzXIFD" doesn't exist (ignoring)
data-default-instances-old-locale-0.0.1: dependency "old-locale-1.0.0.7-KGBP1BSKxH5GCm0LnZP04j" doesn't exist (ignoring)
doctemplates-0.1.0.2: dependency "parsec-3.1.11-1CA7c0vSU7tJHGhveOjoXR" doesn't exist (ignoring)
doctemplates-0.1.0.2: dependency "scientific-0.3.4.15-Is44CvKqXBF5ugVqyS94hI" doesn't exist (ignoring)
doctemplates-0.1.0.2: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
doctemplates-0.1.0.2: dependency "unordered-containers-0.2.8.0-1tqMF698WJE3INvmpuzQZc" doesn't exist (ignoring)
doctemplates-0.1.0.2: dependency "vector-0.12.0.1-692PQMDMB6pIQ1uGwefDcQ" doesn't exist (ignoring)
exceptions-0.8.3: dependency "mtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6" doesn't exist (ignoring)
exceptions-0.8.3: dependency "stm-2.4.4.1-iSYwp3RMY11sHCifJ3gtR" doesn't exist (ignoring)
exceptions-0.8.3: dependency "transformers-compat-0.5.1.4-IuFogs8HAVUJBWVNMhtssu" doesn't exist (ignoring)
filemanip-0.3.6.3: dependency "mtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6" doesn't exist (ignoring)
filemanip-0.3.6.3: dependency "unix-compat-0.4.3.1-Ausmw6d7KIwA7sl52mzqxC" doesn't exist (ignoring)
hashable-1.2.6.1: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
http-client-tls-0.3.5.1: dependency "http-client-0.5.7.0-8CqgjLtDELe98Oo6kiK06v" doesn't exist (ignoring)
http-client-tls-0.3.5.1: dependency "http-types-0.9.1-IqlxYYwrFhNBj6J7ATsByJ" doesn't exist (ignoring)
http-client-tls-0.3.5.1: dependency "memory-0.14.6-vm2tIOaikKE3jdFeeotzN" doesn't exist (ignoring)
http-client-tls-0.3.5.1: dependency "network-2.6.3.2-IsLM4TXcLoRI0fmmBYVyQz" doesn't exist (ignoring)
http-client-tls-0.3.5.1: dependency "network-uri-2.6.1.0-GzRvaV3udR3JtWfa3CLYOw" doesn't exist (ignoring)
http-client-tls-0.3.5.1: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
http-client-tls-0.3.5.1: dependency "tls-1.3.10-I9fEZw7nolG6qstp6qpez8" doesn't exist (ignoring)
http-client-0.5.7.0: dependency "http-types-0.9.1-IqlxYYwrFhNBj6J7ATsByJ" doesn't exist (ignoring)
http-client-0.5.7.0: dependency "mime-types-0.1.0.7-6S5MIO4mj3aEWOXP65VWnC" doesn't exist (ignoring)
http-client-0.5.7.0: dependency "network-2.6.3.2-IsLM4TXcLoRI0fmmBYVyQz" doesn't exist (ignoring)
http-client-0.5.7.0: dependency "network-uri-2.6.1.0-GzRvaV3udR3JtWfa3CLYOw" doesn't exist (ignoring)
http-client-0.5.7.0: dependency "random-1.1-9tceXaeYIMZ4JrKq20Egog" doesn't exist (ignoring)
http-client-0.5.7.0: dependency "streaming-commons-0.1.18-KZl1SWhWop6Ksa4IiFWi6P" doesn't exist (ignoring)
http-client-0.5.7.0: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
http-types-0.9.1: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
HTTP-4000.3.7: dependency "mtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6" doesn't exist (ignoring)
HTTP-4000.3.7: dependency "network-2.6.3.2-IsLM4TXcLoRI0fmmBYVyQz" doesn't exist (ignoring)
HTTP-4000.3.7: dependency "network-uri-2.6.1.0-GzRvaV3udR3JtWfa3CLYOw" doesn't exist (ignoring)
HTTP-4000.3.7: dependency "parsec-3.1.11-1CA7c0vSU7tJHGhveOjoXR" doesn't exist (ignoring)
hxt-regex-xmlschema-9.2.0.3: dependency "parsec-3.1.11-1CA7c0vSU7tJHGhveOjoXR" doesn't exist (ignoring)
hxt-regex-xmlschema-9.2.0.3: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
hxt-9.3.1.16: dependency "mtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6" doesn't exist (ignoring)
hxt-9.3.1.16: dependency "network-uri-2.6.1.0-GzRvaV3udR3JtWfa3CLYOw" doesn't exist (ignoring)
hxt-9.3.1.16: dependency "parsec-3.1.11-1CA7c0vSU7tJHGhveOjoXR" doesn't exist (ignoring)
JuicyPixels-3.2.8.2: dependency "mtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6" doesn't exist (ignoring)
JuicyPixels-3.2.8.2: dependency "primitive-0.6.2.0-4578caNkWQ54Gt1mxLF2Yh" doesn't exist (ignoring)
JuicyPixels-3.2.8.2: dependency "vector-0.12.0.1-692PQMDMB6pIQ1uGwefDcQ" doesn't exist (ignoring)
JuicyPixels-3.2.8.2: dependency "zlib-0.6.1.2-GcLmGV5PElZD6CJvjR9umm" doesn't exist (ignoring)
lifted-base-0.2.3.11: dependency "monad-control-1.0.2.0-10S0ywqdsCPHnUTlxJLEct" doesn't exist (ignoring)
lifted-base-0.2.3.11: dependency "transformers-base-0.4.4-H3XecnBtTa65CX4xecxCVH" doesn't exist (ignoring)
mime-types-0.1.0.7: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
mmorph-1.1.0: dependency "mtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6" doesn't exist (ignoring)
mmorph-1.1.0: dependency "transformers-compat-0.5.1.4-IuFogs8HAVUJBWVNMhtssu" doesn't exist (ignoring)
monad-control-1.0.2.0: dependency "stm-2.4.4.1-iSYwp3RMY11sHCifJ3gtR" doesn't exist (ignoring)
monad-control-1.0.2.0: dependency "transformers-base-0.4.4-H3XecnBtTa65CX4xecxCVH" doesn't exist (ignoring)
monad-control-1.0.2.0: dependency "transformers-compat-0.5.1.4-IuFogs8HAVUJBWVNMhtssu" doesn't exist (ignoring)
network-uri-2.6.1.0: dependency "parsec-3.1.11-1CA7c0vSU7tJHGhveOjoXR" doesn't exist (ignoring)
pandoc-types-1.17.0.5: dependency "QuickCheck-2.9.2-8nJqNls0Q836oDXpGGg3LD" doesn't exist (ignoring)
pandoc-types-1.17.0.5: dependency "syb-0.6-IcoSwlPi2Nx4zSqMmorFPS" doesn't exist (ignoring)
parsec-3.1.11: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
QuickCheck-2.9.2: dependency "random-1.1-9tceXaeYIMZ4JrKq20Egog" doesn't exist (ignoring)
QuickCheck-2.9.2: dependency "tf-random-0.5-CJZw1ZWS5MOJlR60HqKEZL" doesn't exist (ignoring)
resourcet-1.1.9: dependency "transformers-base-0.4.4-H3XecnBtTa65CX4xecxCVH" doesn't exist (ignoring)
resourcet-1.1.9: dependency "transformers-compat-0.5.1.4-IuFogs8HAVUJBWVNMhtssu" doesn't exist (ignoring)
scientific-0.3.4.15: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
scientific-0.3.4.15: dependency "vector-0.12.0.1-692PQMDMB6pIQ1uGwefDcQ" doesn't exist (ignoring)
skylighting-0.1.1.5: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
skylighting-0.1.1.5: dependency "utf8-string-1.0.1.1-1DpjxLeTvGg7ttZZojxJR5" doesn't exist (ignoring)
streaming-commons-0.1.18: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
streaming-commons-0.1.18: dependency "zlib-0.6.1.2-GcLmGV5PElZD6CJvjR9umm" doesn't exist (ignoring)
tagged-0.8.5: dependency "transformers-compat-0.5.1.4-IuFogs8HAVUJBWVNMhtssu" doesn't exist (ignoring)
tagsoup-0.14.1: dependency "text-1.2.2.2-3ENqlljngKa6xj1Go2fVWq" doesn't exist (ignoring)
texmath-0.9.4: dependency "xml-1.3.14-FVnE0jAbj4fGGraldXZwwG" doesn't exist (ignoring)
tls-1.3.10: dependency "x509-1.6.5-1lNlFxDfEv2287NoJBDt9f" doesn't exist (ignoring)
tls-1.3.10: dependency "x509-store-1.6.2-2JTK3MuGtMw4U8lTBVjl8Z" doesn't exist (ignoring)
tls-1.3.10: dependency "x509-validation-1.6.5-KkCaCznBsGnI4IiJkZhJEe" doesn't exist (ignoring)
transformers-base-0.4.4: dependency "transformers-compat-0.5.1.4-IuFogs8HAVUJBWVNMhtssu" doesn't exist (ignoring)
x509-store-1.6.2: dependency "x509-1.6.5-1lNlFxDfEv2287NoJBDt9f" doesn't exist (ignoring)
x509-system-1.6.4: dependency "x509-1.6.5-1lNlFxDfEv2287NoJBDt9f" doesn't exist (ignoring)
x509-validation-1.6.5: dependency "x509-1.6.5-1lNlFxDfEv2287NoJBDt9f" doesn't exist (ignoring)
zip-archive-0.3.1.1: dependency "zlib-0.6.1.2-GcLmGV5PElZD6CJvjR9umm" doesn't exist (ignoring)

#23

The Arch maintainers are making some changes. Big surprise in the Arch boards, too. Apparently nobody but them (maintainers) knows full why or what, but its prolly stated in the mailing listsā€¦


#24

Changes to what though? What package(s) are now dependent on all these haskell packages?

Both my unstable and testing VMs are up to date and have no haskell stuff installed, but all of a sudden my bare metal stable has a ton of haskell packages installed, none of which seem to register correctly. I have no idea the source of the haskell ā€œdependency vortexā€.

What a mess.

EDIT :

From pacman.log, for some reason the haskell compiler was installed in this update along with a whole heap of other haskell packages. No idea whyā€¦ yetā€¦

[2017-06-26 12:41] [ALPM] installed ghc (8.0.2-1)
[2017-06-26 12:41] [ALPM] installed haskell-network (2.6.3.2-2)
[2017-06-26 12:41] [ALPM] installed haskell-mtl (2.2.1-7)
[2017-06-26 12:41] [ALPM] installed haskell-text (1.2.2.2-2)
[2017-06-26 12:41] [ALPM] installed haskell-parsec (3.1.11-4)
[2017-06-26 12:41] [ALPM] installed haskell-network-uri (2.6.1.0-5)
[2017-06-26 12:41] [ALPM] installed haskell-http (4000.3.7-3)
[2017-06-26 12:41] [ALPM] installed haskell-primitive (0.6.2.0-2)
[2017-06-26 12:41] [ALPM] installed haskell-vector (0.12.0.1-2)
[2017-06-26 12:41] [ALPM] installed haskell-zlib (0.6.1.2-2)
[2017-06-26 12:41] [ALPM] installed haskell-juicypixels (3.2.8.2-1)
[2017-06-26 12:41] [ALPM] installed haskell-sha (1.6.4.2-6)
[2017-06-26 12:41] [ALPM] installed haskell-hashable (1.2.6.1-1)
[2017-06-26 12:41] [ALPM] installed haskell-integer-logarithms (1.0.1-2)
[2017-06-26 12:41] [ALPM] installed haskell-scientific (0.3.4.15-3)
[2017-06-26 12:41] [ALPM] installed haskell-attoparsec (0.13.1.0-13)
[2017-06-26 12:41] [ALPM] installed haskell-base-compat (0.9.3-2)
[2017-06-26 12:41] [ALPM] installed haskell-dlist (0.8.0.2-2)
[2017-06-26 12:41] [ALPM] installed haskell-transformers-compat (0.5.1.4-4)
[2017-06-26 12:41] [ALPM] installed haskell-tagged (0.8.5-2)
[2017-06-26 12:41] [ALPM] installed haskell-time-locale-compat (0.1.1.3-2)
[2017-06-26 12:41] [ALPM] installed haskell-unordered-containers (0.2.8.0-5)
[2017-06-26 12:41] [ALPM] installed haskell-random (1.1-7)
[2017-06-26 12:41] [ALPM] installed haskell-uuid-types (1.0.3-7)
[2017-06-26 12:41] [ALPM] installed haskell-aeson (1.1.2.0-7)
[2017-06-26 12:41] [ALPM] installed haskell-base64-bytestring (1.0.0.1-7)
[2017-06-26 12:41] [ALPM] installed haskell-blaze-builder (0.4.0.2-4)
[2017-06-26 12:41] [ALPM] installed haskell-blaze-markup (0.7.1.1-3)
[2017-06-26 12:41] [ALPM] installed haskell-blaze-html (0.8.1.3-4)
[2017-06-26 12:41] [ALPM] installed haskell-cmark (0.5.5.1-3)
[2017-06-26 12:41] [ALPM] installed haskell-data-default-class (0.1.2.0-2)
[2017-06-26 12:41] [ALPM] installed haskell-data-default-instances-containers (0.0.1-14)
[2017-06-26 12:41] [ALPM] installed haskell-data-default-instances-dlist (0.0.1-18)
[2017-06-26 12:41] [ALPM] installed haskell-old-locale (1.0.0.7-9)
[2017-06-26 12:41] [ALPM] installed haskell-data-default-instances-old-locale (0.0.1-14)
[2017-06-26 12:41] [ALPM] installed haskell-data-default (0.7.1.1-5)
[2017-06-26 12:41] [ALPM] installed haskell-doctemplates (0.1.0.2-22)
[2017-06-26 12:41] [ALPM] installed haskell-extensible-exceptions (0.1.1.4-15)
[2017-06-26 12:41] [ALPM] installed haskell-old-time (1.1.0.3-9)
[2017-06-26 12:41] [ALPM] installed haskell-unix-compat (0.4.3.1-2)
[2017-06-26 12:41] [ALPM] installed haskell-filemanip (0.3.6.3-8)
[2017-06-26 12:41] [ALPM] installed haskell-haddock-library (1.4.3-2)
[2017-06-26 12:41] [ALPM] installed haskell-case-insensitive (1.2.0.10-3)
[2017-06-26 12:41] [ALPM] installed haskell-hxt-charproperties (9.2.0.1-2)
[2017-06-26 12:41] [ALPM] installed haskell-hxt-regex-xmlschema (9.2.0.3-3)
[2017-06-26 12:41] [ALPM] installed haskell-hxt-unicode (9.0.2.4-2)
[2017-06-26 12:41] [ALPM] installed haskell-hxt (9.3.1.16-3)
[2017-06-26 12:41] [ALPM] installed haskell-lexer (1.0.1-2)
[2017-06-26 12:41] [ALPM] installed haskell-pretty-show (1.6.13-2)
[2017-06-26 12:41] [ALPM] installed haskell-regex-base (0.93.2-27)
[2017-06-26 12:41] [ALPM] installed haskell-regex-pcre (0.94.4-3)
[2017-06-26 12:41] [ALPM] installed haskell-safe (0.3.15-1)
[2017-06-26 12:41] [ALPM] installed haskell-utf8-string (1.0.1.1-3)
[2017-06-26 12:41] [ALPM] installed haskell-skylighting (0.1.1.5-23)
[2017-06-26 12:41] [ALPM] installed haskell-hslua (0.4.1-4)
[2017-06-26 12:41] [ALPM] installed haskell-cookie (0.4.2.1-5)
[2017-06-26 12:41] [ALPM] installed haskell-stm (2.4.4.1-4)
[2017-06-26 12:41] [ALPM] installed haskell-exceptions (0.8.3-2)
[2017-06-26 12:41] [ALPM] installed haskell-http-types (0.9.1-12)
[2017-06-26 12:41] [ALPM] installed haskell-mime-types (0.1.0.7-4)
[2017-06-26 12:41] [ALPM] installed haskell-async (2.1.1.1-2)
[2017-06-26 12:41] [ALPM] installed haskell-streaming-commons (0.1.18-2)
[2017-06-26 12:41] [ALPM] installed haskell-http-client (0.5.7.0-4)
[2017-06-26 12:41] [ALPM] installed haskell-syb (0.6-5)
[2017-06-26 12:41] [ALPM] installed haskell-byteable (0.1.1-4)
[2017-06-26 12:41] [ALPM] installed haskell-cereal (0.5.4.0-2)
[2017-06-26 12:41] [ALPM] installed haskell-socks (0.5.5-8)
[2017-06-26 12:41] [ALPM] installed haskell-hourglass (0.2.10-3)
[2017-06-26 12:41] [ALPM] installed haskell-foundation (0.0.12-1)
[2017-06-26 12:41] [ALPM] installed haskell-memory (0.14.6-3)
[2017-06-26 12:41] [ALPM] installed haskell-asn1-types (0.3.2-19)
[2017-06-26 12:41] [ALPM] installed haskell-asn1-encoding (0.9.5-12)
[2017-06-26 12:41] [ALPM] installed haskell-cryptonite (0.23-5)
[2017-06-26 12:41] [ALPM] installed haskell-asn1-parse (0.9.4-23)
[2017-06-26 12:41] [ALPM] installed haskell-pem (0.2.2-4)
[2017-06-26 12:41] [ALPM] installed haskell-x509 (1.6.5-19)
[2017-06-26 12:41] [ALPM] installed haskell-x509-store (1.6.2-20)
[2017-06-26 12:41] [ALPM] installed haskell-x509-validation (1.6.5-20)
[2017-06-26 12:41] [ALPM] installed haskell-tls (1.3.10-15)
[2017-06-26 12:41] [ALPM] installed haskell-x509-system (1.6.4-20)
[2017-06-26 12:41] [ALPM] installed haskell-connection (0.2.8-14)
[2017-06-26 12:41] [ALPM] installed haskell-http-client-tls (0.3.5.1-3)
[2017-06-26 12:41] [ALPM] installed haskell-tf-random (0.5-11)
[2017-06-26 12:41] [ALPM] installed haskell-quickcheck (2.9.2-3)
[2017-06-26 12:41] [ALPM] installed haskell-pandoc-types (1.17.0.5-16)
[2017-06-26 12:41] [ALPM] installed haskell-xml (1.3.14-7)
[2017-06-26 12:41] [ALPM] installed haskell-texmath (0.9.4-12)
[2017-06-26 12:41] [ALPM] installed haskell-tagsoup (0.14.1-3)
[2017-06-26 12:41] [ALPM] installed haskell-temporary (1.2.1-2)
[2017-06-26 12:41] [ALPM] installed haskell-digest (0.0.1.2-4)
[2017-06-26 12:41] [ALPM] installed haskell-zip-archive (0.3.1.1-1)
[2017-06-26 12:41] [ALPM] installed haskell-transformers-base (0.4.4-6)
[2017-06-26 12:41] [ALPM] installed haskell-monad-control (1.0.2.0-2)
[2017-06-26 12:41] [ALPM] installed haskell-lifted-base (0.2.3.11-3)
[2017-06-26 12:41] [ALPM] installed haskell-mmorph (1.1.0-2)
[2017-06-26 12:41] [ALPM] installed haskell-resourcet (1.1.9-6)
[2017-06-26 12:41] [ALPM] installed haskell-conduit (1.2.11-3)
[2017-06-26 12:41] [ALPM] installed haskell-semigroups (0.18.3-3)
[2017-06-26 12:41] [ALPM] installed haskell-yaml (0.8.23.1-2)

#25

@sueridgepipe, can you check which package call those as dependency which this command ?

pactree -r <name_of_package>

Wait, I can do this on my ownā€¦


#26

There are a boatload of haskell packages in the normal repositories as well as some in AUR, but not one of them installed on my machine.

Mystery deepens.


#27

Cinnamon crashed when I went to reboot after the update, otherwise all is well now.


#28

Package pandoc was pulled in by pacman on 24th Janā€¦

$ cat pacman.log | grep pandoc
[2017-01-24 17:28] [PACMAN] Running 'pacman --color auto -S --asdeps --needed community/pandoc'
[2017-01-24 17:29] [ALPM] installed pandoc (1.19.1-10)
[2017-01-31 08:40] [ALPM] upgraded pandoc (1.19.1-10 -> 1.19.1-13)
[2017-02-17 18:51] [ALPM] upgraded pandoc (1.19.1-13 -> 1.19.2.1-9)
[2017-02-25 10:51] [ALPM] upgraded pandoc (1.19.2.1-9 -> 1.19.2.1-14)
[2017-03-01 14:44] [ALPM] upgraded pandoc (1.19.2.1-14 -> 1.19.2.1-15)
[2017-03-06 18:36] [ALPM] upgraded pandoc (1.19.2.1-15 -> 1.19.2.1-18)
[2017-03-15 08:40] [ALPM] upgraded pandoc (1.19.2.1-18 -> 1.19.2.1-20)
[2017-03-20 20:07] [ALPM] upgraded pandoc (1.19.2.1-20 -> 1.19.2.1-25)
[2017-04-03 10:32] [ALPM] upgraded pandoc (1.19.2.1-25 -> 1.19.2.1-32)
[2017-04-16 10:11] [ALPM] upgraded pandoc (1.19.2.1-32 -> 1.19.2.1-40)
[2017-04-24 21:02] [ALPM] upgraded pandoc (1.19.2.1-40 -> 1.19.2.1-42)
[2017-04-25 19:24] [ALPM] upgraded pandoc (1.19.2.1-42 -> 1.19.2.1-44)
[2017-05-13 13:25] [ALPM] upgraded pandoc (1.19.2.1-44 -> 1.19.2.1-50)
[2017-05-19 16:25] [ALPM] upgraded pandoc (1.19.2.1-50 -> 1.19.2.1-52)
[2017-05-27 17:47] [ALPM] upgraded pandoc (1.19.2.1-52 -> 1.19.2.1-56)
[2017-06-07 11:33] [ALPM] upgraded pandoc (1.19.2.1-56 -> 1.19.2.1-65)
[2017-06-19 12:21] [ALPM] upgraded pandoc (1.19.2.1-65 -> 1.19.2.1-72)
[2017-06-26 12:41] [ALPM] installed haskell-pandoc-types (1.17.0.5-16)
[2017-06-26 12:41] [ALPM] upgraded pandoc (1.19.2.1-72 -> 1.19.2.1-80)
[2017-06-26 12:42] [ALPM-SCRIPTLET] pandoc-types-1.17.0.5: dependency "QuickCheck-2.9.2-8nJqNls0Q836oDXpGGg3LD" doesn't exist (ignoring)
[2017-06-26 12:42] [ALPM-SCRIPTLET] pandoc-types-1.17.0.5: dependency "syb-0.6-IcoSwlPi2Nx4zSqMmorFPS" doesn't exist (ignoring)

Which now contains a whole heap of haskell deps

$ pacman -Qi pandoc
Name            : pandoc
Version         : 1.19.2.1-80
Description     : Conversion between markup formats
Architecture    : x86_64
URL             : http://pandoc.org
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : ghc  haskell-http  haskell-juicypixels  haskell-sha  haskell-aeson
                  haskell-base64-bytestring  haskell-blaze-html  haskell-blaze-markup  haskell-cmark
                  haskell-data-default  haskell-doctemplates  haskell-mtl  haskell-extensible-exceptions
                  haskell-filemanip  haskell-haddock-library  haskell-skylighting  haskell-hslua
                  haskell-http-client  haskell-syb  haskell-http-client-tls  haskell-http-types
                  haskell-text  haskell-texmath  haskell-network  haskell-old-time  haskell-pandoc-types
                  haskell-parsec  haskell-random  haskell-scientific  haskell-tagsoup  haskell-temporary
                  haskell-network-uri  haskell-unordered-containers  haskell-zip-archive  haskell-vector
                  haskell-xml  haskell-yaml  haskell-zlib
Optional Deps   : pandoc-citeproc: for citation rendering with pandoc-citeproc filter
                  texlive-core: for pdf output
Required By     : None
Optional For    : None
Conflicts With  : haskell-pandoc
Replaces        : haskell-pandoc
Installed Size  : 31.95 MiB
Packager        : Felix Yan <felixonmars@archlinux.org>
Build Date      : Sat 24 Jun 2017 02:50:23 AM AEST
Install Date    : Mon 26 Jun 2017 12:41:07 PM AEST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

So pandoc is installed as a dependency, but is not required by any other package, huh?


#29

Found this

https://bbs.archlinux.org/viewtopic.php?id=227477

Seems like pandoc was the culprit, no idea why it was installed in the first place, but it recently had a whole heap of haskell dependencies added.

Removed pandoc and all its haskell dependencies.


#30

Thanks. I read all that earlier.

I have a Skylake with hyperthreading. My last BIOS update for my Dell XPS 13 (9360) was 1.35, if I remember well. I went on the Dell support site. Canā€™t find any drivers or BIOS update to download. Windows only.

I guess Manjaro installed the latest intel-microcode.

So, thereā€™s not a real way to find out if you are affected or not, if other Linux distros are OK or not.


#31

Yeah, I donā€™t get that, unless pandoc was a fleeting requirement of something back on 2017-01-24, and subsequently removed such that very few people got it pulled in.

Did you (even temporarily) switch that machine to testing or unstable back then, or install some AUR package that required it?

It does not appear in my pacman.log.


#32

I guess it must have been an old AUR dependency, I have manually checked all my AUR packages and none include pandoc.

I can only assume it was an old dependency that is no longer referenced.


#33

if you have intel , on manjaro you have :

sudo pacman -Ss ucode
extra/intel-ucode 20170511-1 [installƩ]
    Microcode update files for Intel CPUs

you will find in grub.cfg on launch kernel by Grub2

for the others , they have to wait update bios


#34

A fast, flawless update on four comps with XFCE, Cinnamon, and Gnome. Somebody is doing something right. Thank you.


#35

I installed the update and rebooted the system, but afterwards my machine had lost its network connection. I figured out that the wired Realtek interface is not working anymore. Therefore I tried to reinstall the driver through the Manjaro settings dialog, but I ran into the following problem:

Waiting for user inputā€¦
Starting

Installing network-r8168ā€¦
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/network_drivers/r8168/MHWDCONFIG
Processing classid: 0200
:: Synchronizing package databasesā€¦
core is up to date
extra is up to date
community is up to date
multilib is up to date
resolving dependenciesā€¦
looking for conflicting packagesā€¦
Packages (2) linux411-r8168-8.044.02-5 linux49-r8168-8.044.02-8
Total Installed Size: 0.32 MiB
:: Proceed with installation? [Y/n]
checking keyringā€¦
checking package integrityā€¦
loading package filesā€¦
checking for file conflictsā€¦
checking available disk spaceā€¦
:: Processing package changesā€¦
installing linux411-r8168ā€¦

The module r8168 conflicts with r8169. You can blacklist it with:
echo "blacklist r8169" > /etc/modprobe.d/r8169_blacklist.conf
installing linux49-r8168ā€¦

The module r8168 conflicts with r8169. You can blacklist it with:
echo "blacklist r8169" > /etc/modprobe.d/r8169_blacklist.conf
:: Running post-transaction hooksā€¦
(1/1) Arming ConditionNeedsUpdateā€¦
modprobe: ERROR: could not insert ā€˜r8168ā€™: Exec format error
Successfully installed network-r8168
Fertig ā€¦

I guess the solution is to remove the old package network-r8168?

Thanks in advance,

Alex


#36

Great job guys :clap:


#37

Updated two machines running Gnome, all is fine, thanks, great job!


#38

Successful upgrade on two KDE laptops and on one LXQt netbook. No scary warnings.
Two notes:

  1. I did not get the big dump of Haskell packages (and I am fine with that)
  2. For some reason, the downloads seemed faster this time. I am using the same mirror, and I am more than fine with that.

#39

Thank you @philm and Majaro Team. Everything went well with this update.

My system:

OS: Manjaro 17.0.2 Gellivara
Kernel: x86_64 Linux 4.11.7-1-MANJARO
Uptime: 22m
Packages: 1846
Shell: bash 4.4.12
Resolution: 1920x1080
DE: XFCE4
WM: Xfwm4
WM Theme: Default
GTK Theme: Adwaita-Maia [GTK2]
Icon Theme: Papirus-Light
Font: Ubuntu 14
CPU: Intel Core i7-5500U @ 4x 3GHz [51.5Ā°C]
GPU: Mesa DRI IntelĀ® HD Graphics 5500 (Broadwell GT2)


#40

I just had another 75MB update, which included the file linux411-r8168 8.044.02-6, and now everything is working again. Thank you, whoever fixed my problem. :blush: