[Stable Update] 2017-06-18 - Kernels, Plasma, KDE Apps, Firefox, Thunderbird, Mesa

update
stable

#41

Thanks, this worked


#42

Everything works fine. Still no Wayland on Plasma 5.10.2 and Qt 5.9 w/ Radeon 7870, RadeonSI and Mesa.


#43

It must be so rewarding to work on Manjaro project as it always works.

thank you


#44

From Update Fails: conflict between xorg-server and catalyst-server with Nvidia card thread:

After yesterday stable update I had similar problem (same error, but my graphical card is Intel) … when I reinstalled dbus with dbus-x11, problem disappeared.


#45

Installation got stuck on

( 7/15) Configuring pacman-mirrors ...

for about 15 minutes before failing with a message

error: command failed to execute correctly

How can this error be fixed?

Inxi -Fxzc0:

System:    Host: stitch Kernel: 4.11.4-1-MANJARO x86_64 (64 bit gcc: 7.1.1) Desktop: Xfce 4.12.3 (Gtk 2.24.31)
           Distro: Manjaro Linux
Machine:   Device: laptop System: Hewlett-Packard product: HP EliteBook 8530p v: F.11
           Mobo: Hewlett-Packard model: 30E7 v: KBC Version 90.26
           BIOS: Hewlett-Packard v: 68PDV Ver. F.11 date: 12/08/2009
Battery    BAT0: charge: 27.0 Wh 97.1% condition: 27.8/44.0 Wh (63%)
           model: Hewlett-Packard Primary status: Charging
CPU:       Dual core Intel Core2 Duo T9400 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 10113
           clock speeds: max: 2534 MHz 1: 2534 MHz 2: 2534 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV635/M86 [Mobility Radeon HD 3650] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.3) driver: radeon Resolution: 1680x1050@59.98hz
           GLX Renderer: Gallium 0.4 on AMD RV635 (DRM 2.49.0 / 4.11.4-1-MANJARO, LLVM 4.0.0)
           GLX Version: 3.3 Mesa 17.1.2 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RV635 HDMI Audio [Radeon HD 3650/3730/3750]
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.11.4-1-MANJARO
Network:   Card-1: Intel 82567LM Gigabit Network Connection driver: e1000e port: 80c0 bus-ID: 00:19.0
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel PRO/Wireless 5100 AGN [Shiloh] Network Connection driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 120.0GB (55.5% used)
           ID-1: /dev/sda model: KINGSTON_SUV400S size: 120.0GB
Partition: ID-1: / size: 22G used: 18G (87%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 247M used: 179M (77%) fs: ext2 dev: /dev/sda1
           ID-3: /home size: 85G used: 41G (51%) fs: ext4 dev: /dev/dm-3
           ID-4: swap-1 size: 4.11GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
Sensors:   System Temperatures: cpu: 54.0C mobo: 30.0C gpu: 67.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 167 Uptime: 25 min Memory: 1436.7/3920.7MB Init: systemd Gcc sys: 7.1.1
           Client: Shell (zsh 5.3.1) inxi: 2.3.20

#46

My KDE updated without much problems. Only Megasync complained that there is no system tray and that it can’t place an icon. I had to go to Octopi, right click it and install in order for it to update itself.


#47

Is this happen in post-installations?


#48

The error happened after this message in terminal:

:: Running post-transaction hooks...

so I’m guessing the answer to your question is, yes.


#49

You may try to run sudo pacman -Syyu again. If that doesn’t work again, give me the output of this command :

cat /etc/pacman-mirrors.conf

#50

sudo pacman -Syyu

:: Starting full system upgrade...
 there is nothing to do

cat /etc/pacman-mirrors.conf

##
## /etc/pacman-mirrors.conf
##

## Branch Pacman should use (stable, testing, unstable)
Branch = stable

## Generation method
## 1) rank   - rank mirrors depending on their access time
## 2) random - randomly generate the output mirrorlist
# Method = rank

## Specify to use only mirrors from specific a country.
## Can add multiple countries separated by a comma (ex: Germany,France)
## Empty means all
OnlyCountry = Sweden,Denmark,Germany

## Mirrors directory
# MirrorlistsDir = /etc/pacman.d/mirrors

## Output file
# OutputMirrorlist = /etc/pacman.d/mirrorlist

## When set to True prevents the regeneration of the mirrorlist if
## pacman-mirrors is invoked with the --no-update argument.
## Useful if you don't want the mirrorlist regenerated after a
## pacman-mirrors package upgrade.
# NoUpdate = False

#51

Give me the output of this :

ls /usr/share/libalpm/hooks/

I need these infos so we can re-run post installations hooks


#52

Hi,

after the update I can’t open perl based applications any longer (like shutter, gscan2pdf, …)

I always receive following error:

loadable library and perl binaries are mismatched (got handshake key 0xdb80080, needed 0xde00080)

I already tried to reinstall shutter, but no changes.


#53

Try downgrading your perl :

sudo pacman -U /var/cache/pacman/pkg/perl-5.24.1-1-x86_64.pkg.tar.xz

#54

ls /usr/share/libalpm/hooks/

90-linux44.hook     gconf-remove.hook              gtk-query-immodules-3.0.hook  systemd-sysusers.hook  update-desktop-database.hook
90-linux49.hook     gdk-pixbuf-query-loaders.hook  gtk-update-icon-cache.hook    systemd-tmpfiles.hook  update-mime-database.hook
98-linux411.hook    gio-querymodules-32.hook       gvfsd.hook                    systemd-update.hook    update-vlc-plugin-cache.hook
99-grub.hook        gio-querymodules.hook          pacman-mirrors-install.hook   texinfo-install.hook   vimdoc.hook
fontconfig.hook     glib-compile-schemas.hook      pacman-mirrors-upgrade.hook   texinfo-remove.hook    xorg-mkfontdir.hook
gconf-install.hook  gtk-query-immodules-2.0.hook   systemd-hwdb.hook             update-ca-trust.hook

#55

Do this :

sudo pacman -S linux44 linux49 linux411 pacman-mirrors systemd

This will call important hooks cause I’m too lazy to check all of them…
And don’t forget to post its results…


#56

this seems not right solution, as it would break deps…

warning: downgrading package perl (5.26.0-1 => 5.24.1-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: cairo-perl: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: glib-perl: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: gtk2-perl: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: imagemagick: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: net-snmp: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: pango-perl: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-bit-vector: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-clone: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-dbi: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-html-parser: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-json-xs: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-locale-gettext: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-net-dbus: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-proc-processtable: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-text-iconv: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-xml-libxml: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'
:: perl-xml-parser: installing perl (5.24.1-1) breaks dependency 'perl>=5.26'

#57

Wait… Check which AUR packages that uses perl>=5.26 as dependency and remove them…

Or do this :

sudo pacman -Rdd perl
sudo pacman -U /var/cache/pacman/pkg/perl-5.24.1-1-x86_64.pkg.tar.xz

This will remove perl only and then you replaced them with older ones…

NOTE : this will only check if the newest perl that causing the issue


#58

Wow awesome 648mb of update without any issue :smiley:


#59

KDE

the toolbar icons are still to small - the trick with the settings doesn’t seem to be working any more :person_frowning:


#60

Before executing the command @thefallenrat suggested Edit /etc/pacman-mirrors.conf
and modify

# NoUpdate = False

to

NoUpdate = True

then run sudo pacman -Su

/usr/share/libalpm/hooks/pacman-mirrors-upgrade.hook will be run upon pacman-mirrors upgrade and following command is executed

pacman-mirrors --no-mirrorlist

Output shud be similar to

.: Info Downloading mirrors from repo.manjaro.org
"hint: use `pacman-mirrors` to generate and update your pacman mirrorlist."