[Stable Update] 2017-06-10 - Plasma v5.10.1, Kernels, Mesa v17.1.2, Calamares

update
stable

#21

Plasma desktop is borked; no widgets, no panel (also can’t set a new panel), etc. Currently running applications using krunner. What do I do?

EDIT: Also, on the whole, things feel a bit sluggish.


#22

Everything OK on 2 KDE desktops & 1 LXQT laptop – Thanks again, guys!

For those who are having mirror-sync problems, as of this year I started to do the updates this way:

  1. wait for approx. 8 hours after the announcement (also usefull for checking the forum for problems, before updating)
  2. use yaourt to update: yaourt -Syua
    This will also update any AUR packages you have in one go…

#23

Thank you for your hard work! I’m having an issue with this update. I’m running Manjaro KDE 17.0.1, fresh install with the Unstable Repositories enabled.

I’m unable to update filesystem to version 2017.06-4 from 2017.06-3. I get the following message:

filesystem: /etc/os-release exists in filesystem

How should I proceed?


#24
$ sudo mv /etc/os-release /etc/os-release.old

https://forum.manjaro.org/t/unstable-update-file-confict/25558

with unstable repos better search in unstable
cheers


#25

Thank you for the reply. Now I’m getting this after a reboot, can’t open TTY.

EDIT: After a couple of minutes, it goes to the login screen, but I’m unable to login.


#26

Smooth update for me. :slight_smile: Thank you very much!


#27

…have you proceeded your update again before reboot? If not, your file is renamed, but no new file is generated.


#28

Yes, I updated it then rebooted. Also made a thread on this issue, since it feels more appropriate.

EDIT: Running sudo mv /etc/os-release.old /etc/os-release does nothing, sadly.

SOLVED! Thanks to @thefallenrat, I was able to fix the issue by chrooting into Live USB. Then I removed the /var/run directory with rm -rf /var/run in order to reinstall filesystem with sudo pacman -S filesystem.

Thanks once again, mate!


#29

Smooth update on three laptops. But only my oldest installed laptop with the KDE edition got the warning about .pacnew.

The newer installs:

  • A second KDE edition laptop and
  • An LXQt edition netbook

did not get that warning.


#30

Hm, try to rename the file
~/.config/plasma-org.kde.plasma.desktop-appletsrc
and restart the KDE session. KDE will create a new version of that file with default settings.


#31

Smooth update, no problems, KDE.
pacman -Syyu


#32

went smoothly on xfce


#34

Smooth update as usual, thanks!

Specs:

  • linux49
  • XFCE
  • Acer Aspire E 15

#35

No problems on kabylake Cinnamon kernels 4.9/4.11


#36

Successful updates on two notebooks that run Manjaro KDE. Thank you, Manjaro devs!


#37

Hi I just posted on the technical forum about a problem with updating filesystem-2017.06-4 package

I’m running manjaro cinnamon x64, I was updating since 2 yrs ago with no problem until now

FIXED on the thread, had to uninstall tlp package, delete /var/run directory reinstall filesystem package and reinstall tlp, that fixed the problem. Lucky I didn’t reboot after update


#38

LXDE, all smooth.


#39

Today, when I booted up, everything is back to normal; I did not do anything. But all my attempts at creating panels yesterday, were visible, in that there were lots of panels. Also, the panel crashed a couple of times. I have no clue what might be happening.


#40

Only a minor problem. Installation stopped complaining that the permissions on /usr/local/sbin were 2755 rather than 755. Simply changed the permissions and installation went OK.


#41

besides the nsswitch.conf-thing (as posted, did sudo mv /etc/nsswitch.conf.pacnew /etc/nsswitch.conf afterwards), smooth update :smiley:
Thanks Team!