[Stable Update] 2017-06-06 - Plasma 5, Boost, Deepin, Mesa, GCC



First tried pacman on a terminal. Received a 404 error on deepin-file-manager upgrade – no packages upgraded. So I tried with pamac and unchecked deepin-file-manager to upgrade everything else, and that worked.

I am still showing 1 available update.

$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                     139.1 KiB  1046K/s 00:00 [######################] 100%
 extra                   1796.9 KiB  2.54M/s 00:01 [######################] 100%
 community                  4.2 MiB  3.25M/s 00:01 [######################] 100%
 multilib                 181.3 KiB   743K/s 00:00 [######################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

warning: insufficient columns available for table display
Packages (4) deepin-file-manager-1:  libbson-1.6.3-1
             libmongoc-1.6.3-1  treefrog-framework-1.17.0-1

Total Download Size:    3.41 MiB
Total Installed Size:  12.44 MiB
Net Upgrade Size:       4.14 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
error: failed retrieving file 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' from mirror.dacentec.com : The requested URL returned error: 404
error: failed retrieving file 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' from mirror.solarvps.com : The requested URL returned error: 404
error: failed retrieving file 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' from mirror.nexcess.net : The requested URL returned error: 404
error: failed retrieving file 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' from mirror.jmu.edu : The requested URL returned error: 404
error: failed retrieving file 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' from distro.ibiblio.org : The requested URL returned error: 404
error: failed retrieving file 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' from mirror.clarkson.edu : The requested URL returned error: 404
error: failed retrieving file 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' from mirrors.ocf.berkeley.edu : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.


you are not the first to experience the 404 issue (see β€œskweresp” post).

@philm I investigated a bit :
Inside "/var/lib/pacman/sync/community.db"
The file β€œdeepin-file-manager-1:” contain :
Should be :


I check files .xsession-errors and .xsession-errors.old and they are empty. Everything was great until last update. Then problems occure and first I delete and install again manjaro-deepin-settings. Then I can’t login because Lightdm failed to start, I try to enable systemctl service but it don’t help so I install gdm and it works but still cannot change wallpapers. Is there a way to fix it or the best thing will be to reinstall Manjaro?


Something went wrong with the package file name when I pushed it to the repo. Phil has since fixed it.
To replace the file you can

sudo rm /var/cache/pacman/pkg/deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz
sudo pacman -S deepin-file-manager


Try this:

sudo pacman -U http://manjarolinux.polymorf.fr/stable/community/x86_64/deepin-file-manager-1\:


I also ran into the issue with the gcc dependency. The above provided solution to install gcc-multilib first, before applying the update worked fine for me, although I used the point and click approach :slight_smile:

In any case, great work with the update and I am very happy with Manjaro overall.


Unfortunately, it doesn’t change anything.

I have this issue on both my laptops.


@oberon @philm @Yoy0 I find solution. Thanks for Your help .


The upgrade was smooth as usual.


Reemplace gcc with gcc-multilib if you’re using multilib packages (as I am). I follow the instructions from Philm and they work as expected.


Reemplace gcc with gcc-multilib and then update. It works well.


This morning, I got a strange pacman error in a train station (public Wi-Fi):

I did nothing, but when I came home on my home Wi-Fi, I did not get this error.
Is there some kind of strange port that might have been blocked?

GPGME error: No data

Hi there! Had the same problem, solved as @philm described.
Thanx!! :grin:


That worked – Thanks!


OS: Manjaro 17.0.1 Gellivara
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ Kernel: x86_64 Linux 4.11.3-1-MANJARO
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ Uptime: 1d 3h 21m
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ Packages: 1608
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ Shell: bash 4.4.12
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ Resolution: 3040x900
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ DE: Deepin
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ WM: Deepin WM
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ WM Theme: Vertex-Maia
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ GTK Theme: Vertex-Maia [GTK2/3]
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ Icon Theme: ardis-icon-theme-circle
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ CPU: AMD Phenom II X6 1100T @ 6x 3.3GHz [48.6Β°C]
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ GPU: GeForce GTS 450
RAM: 3725MiB / 7986MiB

Running Deja-Dup Backup and now this Deepin (DDE) Dock β€œwindow” appears in the corner of my screen, only when running this program. Also the regular Dock just has a black square (Deja-Dup icon is a Black Circle) See enclosed screenshot:

EDIT Just realized the black square on the Dock is supposed to be the USB/Removable Media Icon. I’ve had trouble with this showing correctly in the past for Deepin. At that time it was just a blank space.


Update went smoothly. Which is exactly how I like my updates to go. :slight_smile:



The update went smooth on my tower at home but broke my laptop at work. I lost the whole yesterday afternoon trying to figure out the problem and reinstalling xorg, the drivers and gdm… I should have tried this link earlier :frowning:. Thank you anyway!

It’s weird that it worked on one PC but not the other. Could it possibly be related to Optimus/Bumblebee and Xorg?
As a hint for further debugging, as I was stuck in the gdm loop, I could not start gnome-session nor startx but /var/log/Xorg.0.log didn’t show any errors. Finally, xinit worked with a modified ~/.xinitrc which did only:

exec dbus-launch --sh-syntax --exit-with-session gnome-session

Now everything is working fine again (except the external display but I broke it myself :smiley:).

Hope my feedback can help.

I have disabled Wayland in GDM following this link to make the external display work with Bumblebee (see this one). That’s why the post login script of @Ste74 may have broken it.
I can’t reproduce the bug since I deleted /etc/gdm/PostLogin/Default …


For the spyder3 issue, in case anyone encounters it, it finally worked when I removed python-pyqt4.
Otherwise spyder3 tries to use Qt4 for whatever reason and fails.



after installing this update and rebooting, I noticed that my audio device was not able to play sound anymore. After I looked into the KDE System Settings, I found that all audio devices were greyed out, and only a β€œDummy Output” was available and active. I can manually enable the HDMI output (though I don’t have HDMI but rather a DisplayPort), but I cannot enable the speaker and headphone output (broadwell-rt286 Speaker Playback + Headphones Playback).

I really don’t know what to post, here is an excerpt from lspci:

00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Broadwell-U Processor Thermal Subsystem (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)

My notebook is the Dell XPS 13 from two years ago, sadly having a Broadcom WLAN, Bluetooth and audio chip. Driver support for these hasn’t been very great to begin with, but it has gotten better. I hope this issue is easily resolvable.
If I should post more logs just tell me which, I don’t really have any experience debugging driver issues (as this usually just works with Linux).



Has anyone else had an issue with themes in plasma since the update? The icons in the desktop panel are now extremely small, and they weren’t that way before.