[Stable Update] 2017-06-06 - Plasma 5, Boost, Deepin, Mesa, GCC

update
stable

#123

Correct ( unless you need a qt4 interface for the zeitgest )


#124

I have the same output and your workaround is helping me.
Manjaro Cinnamon

Before:
pacman -Q | grep gcc
gcc 6.3.1-2
gcc-libs-multilib 6.3.1-2
lib32-gcc-libs 6.3.1-2

After:
pacman -Q | grep gccgcc-libs-multilib 7.1.1-3
gcc-multilib 7.1.1-3
lib32-gcc-libs 7.1.1-3


#125

I don’t know whether its an issue (more like a mild inconvenience) I’m experiencing however I find it worth mentioning.

Since the update the icon grid on my desktop does not distribute properly, meaning icons I try to place besides the right desktop edge are farther away than to the left. This was not the case prior to the update. This glitch persists when playing around with the settings or rebooting.

I can provide a screenshot if my explanation wasn’t clear enough.


#126

BEST. DISTRO. EVER. KDE install here. All went good.


#127

@philm I check mirrors from Germany, France and UK and it’s the same error:
błąd: nie udało się pobrać pliku 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' z repo.manjaro.org.uk : The requested URL returned error: 404 błąd: nie udało się pobrać pliku 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' z manjarolinux.polymorf.fr : The requested URL returned error: 404 błąd: nie udało się pobrać pliku 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' z mirror.chmuri.net : The requested URL returned error: 404 błąd: nie udało się pobrać pliku 'deepin-file-manager-1_4.1.5.20170607-1-x86_64.pkg.tar.xz' z manjaro.ieji.de : The requested URL returned error: 404


#129

from http://ftp.free.org/mirrors/repo.manjaro.org/repos/stable/community/x86_64/.syncpackages :
deepin-file-manager-1:4.1.5-2-x86_64.pkg.tar.xz
07-Jun-2017 11:26
from http://ftp.free.org/mirrors/repo.manjaro.org/repos/stable/community/x86_64/ :
deepin-file-manager-1:4.1.5.20170607-1-x86_64.pkg.tar.xz
07-Jun-2017 10:28

Seems weird


#130

@Yoy0 How to install from that mirror ?


#131

You can download it via http :
ftp.free.org/mirrors/repo.manjaro.org/repos/stable/community/x86_64/deepin-file-manager-1:4.1.5.20170607-1-x86_64.pkg.tar.xz

Go to download folder and :
sudo pacman -U deepin-file-manager-1:4.1.5.20170607-1-x86_64.pkg.tar.xz

I tested it to be sure and package will be seen as community package (not local) :slight_smile:


#132

@philm @Yoy0 Thanks, but now it even worse :confused: when I click rmb and choose change wallpaper everything’s gone, I only see wallpaper and the only option is to ctrl+alt+F2 and sudo reboot. If thats only my problem maybe it has something with that I have also gnome session installed ?


#133

I don’t know anything about deepin, can’t help.

You can still downgrade :
pacman -U /var/cache/pacman/pkg/package-old_version.pkg.tar.xz


#134

OK, thanks for help


#135

Hi,
I cannot update, this is the message

resolving dependencies…
looking for conflicting packages…
warning: removing ‘gcc-libs’ from target list because it conflicts with 'gcc-libs-multilib’
error: failed to prepare transaction (could not satisfy dependencies)
:: gcc: requires gcc-libs=7.1.1-2

Any tips?
Thanks
Melissa


#136

RTFT :wink: (used to be RTFM) :stuck_out_tongue:

All good for my update. :blossom:


#137

See post #18 by philm, you are not the first.


#138

Congratulations to Manjaro team .You’re doing an excellent work keeping us up-to-date and stable at the same time. I tried several rolling releases and this has been the only one who have achieved both golas reasonably since I installed it.

As for the plasma 5.10 itself, it seems that it appeals more to newcomers or fresh installations. Gladly it haven’t changed the configuration I already have. But it doesn’ t seem to be “faster” as they advertised. It seems to be a little bit “slower”. And the new features doesn’t seem to bring many new things to those who already have plasma installed and configured. Personally, the only feature I adopted and found very practical was pinning dolphin to task manager to have instant access to my favorite folders. (That only works if you choose to “pin” dolphin to “task manager”. It’s not the same as adding dolphin to panel icons as I used to do before.)


#139

I’m not sure I’m in the right place, but since the upgrade, spyder3 isn’t working;

$ spyder3
Traceback (most recent call last):
  File "/usr/bin/spyder3", line 3, in <module>
    start.main()
  File "/usr/lib/python3.6/site-packages/spyder/app/start.py", line 103, in main
    from spyder.app import mainwindow
  File "/usr/lib/python3.6/site-packages/spyder/app/mainwindow.py", line 92, in <module>
    from qtpy import QtWebEngineWidgets  # analysis:ignore
  File "/usr/lib/python3.6/site-packages/qtpy/QtWebEngineWidgets.py", line 31, in <module>
    from PyQt4.QtWebKit import QWebPage as QWebEnginePage
ModuleNotFoundError: No module named 'PyQt4.QtWebKit'

I don’t get why there is a Qt4 error, since spyder is now Qt5, but I would appreciate any help.
From what I found out, Arch removed the python Qt4 webkit, but that was done ages ago it seems, so… weird.


#140

I’ve just confirmed on stable branch. For me wallpaper-chooser works fine again. Not sure what might be going on at your end.
Any helpful information to be found in your ~/.xsession-errors ?


#141

kde - after the update widget network monitor show wrong speed connection

EDIT removing and adding again the widget fix the issue


#142

I had the gcc issue, solved thanks the Philm tips; so AFAIK nothing else gone wrong. :slight_smile:


#143

A freshly installed version of spyder3 is working fine for me. Maybe it has something to do with your existing config? What happens when you move your ~/.config/spyder-py3 directory out of the way at least temporarily by renaming it or something like that?