[Stable Update] 2017-06-06 - Plasma 5, Boost, Deepin, Mesa, GCC

update
stable

#62

Apart from the issue with Okular, everything seems to run fine on my side.
I will wait for my mirror to be synced.

Thanks !


#63

I will wait a week or so to update. Too freaky right now. I have the same problem with the gcc stuff. This needs to be fixed. Oddly, Okular runs fine without the update. I love KDE but will wait awhile.

not my first time at the rodeo…


#64

All clear in Gnomeland.

Will report how is going in XFCE as well once is done. :fearful:

Thanks for your effort.


#65

By the time you did this, you should have had a working Okular.
Maybe you need to update your mirrors ?


#66

Just not being first, seems I’ve avoided all the drama.
Okular would have been a show stopper for me, but by the time I got to is (west coast USA) it was already fixed.


#67

The issue is already known upstream. U should be able to push a fix later tonight…


#68

I had the issue with gcc, but was able to resolve it according to the instruction provided above.


#69

Everything went well with this update. Thank you @philm and the Manjaro team.


#70

Can he log in far enough to get a Console (ctrl-alt-F3 type)?
There are new mirrors to check
There are new keys to import.
There is a new pacman after that.

Maybe he can do all that manually at a non graphical console or via chroot.


#71

@jsamyth

Yes, he can chroot I just don’t know what steps he should be doing after it. System update fails. If you have few minutes, could you give him a hand here:

Can't login - error messages upon system boot


#72

Actually I just did sudo pacman -S gcc and confirmed that I wanted to remove gcc-libs-multilib.


#73

everything went good on xfce here


#74

Aside from the following error with GCC (gcc 7.1.1-2 requires gcc-libs=7.1.1-2), which was easily solved by installing gcc-multlib, everything went smooth as usual.

Thanks once again for the great work!

Specs:

  • linux49
  • XFCE
  • Acer Aspire E 15

#75

I just did an update on my mirrors and still no new packages found whereas Okular can’t still read anything…

KDE
Okular 17.04.1-1


#76

@jsamyth

I’ve tried performing new mirrors check, new keys import and updating pacman. I keep getting the same dependency issue. I even tried using pacui option 12, Fix Pacman Errors but to no avail.

I’m not sure what else to do. I can’t keep using a live install usb.

Is there any way to check if something important was removed during the last update?


#77

bash lists this:

pacman -Q | grep gcc
gcc-libs-multilib 6.3.1-2
gcc-multilib 6.3.1-2
lib32-gcc-libs 6.3.1-2

so is this going to be a problem?


#78

What you are looking for is an update to poppler, not an update to Okular.

Do:

sudo pacman-mirrors -g -b stable -f 10
suso pacman -Syy


#79

Only if you have a dependency on 6.3.1-2.
I didn’t, so I upgraded to 7.1.1-3 without problems.

pacman -Q | grep gcc
gcc-libs-multilib 7.1.1-3
gcc-multilib 7.1.1-3
lib32-gcc-libs 7.1.1-3


#80

Smooth update, no problems on KDE. Used pacman -Syyu.


#81

Yeah I get the fact that poppler was the problem :slight_smile:

By the way, I was able to update it, thanks a lot anyway !