[Stable Update] 2017-06-06 - Plasma 5, Boost, Deepin, Mesa, GCC

update
stable

#41

Unable to update. Says “gcc-objc: requires gcc=7.1.1-2”

Trying to “sudo pacman -S gcc-multilib gcc-libs-multilib lib32-gcc-libs” says that installing gcc-multilib (7.1.1-3) breaks the requirement “gcc=6.3.1-2”

Running KDE


#43

Packages that you must install:
sudo pacman -S gcc-libs-multilib gcc-multilib lib32-gcc-libs


#44

Thanks for your reply.

I get the same mistake: breaks dependency “gcc-libs-multilib=6.3.1-2”


#45

@stratosl: I had the same problem. I fixed it by doing sudo pacman-mirrors -g and then doing sudo pacman -Syyuu


#46

Update your repositories using the command sudo pacman-mirrors -g -b stable -f 10 and try again sudo pacman -S gcc-libs-multilib gcc-multilib lib32-gcc-libs.


#47

Update tranquil.
VLC updated to 2.2.6, mesa and gcc also updated.


#48

I noticed that my themes Window Decorations are no longer working.

According to the Arch forum its because of some new thing the nvidia driver cannot handle.
Forced to use either Breeze, Oxygen or Plastic decorations untila new version of kwin is built. It seems to happen with custom theme window decorations only.

Really annoying. :stuck_out_tongue:


#49

No, still no luck. Pacman wants to exclude gcc-libs and gcc from the update, due to conflict with gcc-libs-multilib and gcc-multilib. Should I remove gcc and install gcc-multilib?


#50

Yes. gcc-multilib provides gcc, so there is no downside to doing that.


#51

Exist is gcc and gcc multilib.
You can install only gcc or gcc multilib you can choose e remembering that they are from different repositories.[quote=“stratosl, post:49, topic:25265, full:true”]
No, still no luck. Pacman wants to exclude gcc-libs and gcc from the update, due to conflict with gcc-libs-multilib and gcc-multilib. Should I remove gcc and install gcc-multilib?
[/quote]


#52

I solved it by removing first gcc-objc which required gcc 6.1, upgraded and then reinstalled that package


#53

Doesn’t work for me:

sudo pacman -Syyu
:: Synchronizing package databases...
 core                                      139,1 KiB  97,7K/s 00:01 [#####################################] 100%
 extra                                    1796,9 KiB   197K/s 00:09 [#####################################] 100%
 community                                   4,2 MiB   246K/s 00:17 [#####################################] 100%
 multilib                                  181,3 KiB   124K/s 00:01 [#####################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
warning: removing 'gcc-libs' from target list because it conflicts with 'gcc-libs-multilib'
warning: removing 'gcc' from target list because it conflicts with 'gcc-multilib'
error: failed to prepare transaction (could not satisfy dependencies)
:: gcc-fortran: requires gcc=7.1.1-2


pacman -Q | grep gcc
gcc-fortran 6.3.1-2
gcc-libs-multilib 6.3.1-2
gcc-multilib 6.3.1-2
lib32-gcc-libs 6.3.1-2

What to do?


#54

you could uninstall gcc and gcc-fortran, and afterwards install gcc-multilib and gcc-fortran-multilib.


#55

Yep, just gcc-fortran wasn’t multilib, Thank you.


#56

Hi,
I have a problem of locale in Lightdm and Xfce.

$ cat /etc/environment
LANG=fr_FR.UTF-8
BROWSER=/usr/bin/xdg-open

In manjaro-settings-manager, I have no language set and when I try to add one it disappears as soon as I click on “Apply” button.

$ manjaro-settings-manager

(process:2216): Gtk-WARNING **: Locale not supported by C library.
Using the fallback ‘C’ locale.

Do you have any idea of what could cause this ?


#57

Anyone knows how to solve this:

After system update he can’t access his system. If he chroot into it and try to update it, he gets upper error.


Can't login - error messages upon system boot
#58

Plasma (more strictly - plasma-nm package) needs urgent update to fix this outstanding bug:

https://bugs.kde.org/show_bug.cgi?id=380299


#59

Hi,
sudo pacman -Syu gives me:

warning: removing 'gcc-libs' from target list because it conflicts with 'gcc-libs-multilib'
error: failed to prepare transaction (could not satisfy dependencies)
:: gcc: requires gcc-libs=7.1.1-2

I check installed gcc pkgs:

$ pacman -Q | grep gcc
gcc 6.3.1-2
gcc-fortran 6.3.1-2
gcc-libs-multilib 6.3.1-2
gcc-objc 6.3.1-2
lib32-gcc-libs 6.3.1-2

and trying this do not work:

$ sudo pacman -S gcc-multilib gcc-libs-multilib lib32-gcc-libs
resolving dependencies...
looking for conflicting packages...
:: gcc-multilib and gcc are in conflict. Remove gcc? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: gcc-fortran: removing gcc breaks dependency 'gcc=6.3.1-2'
:: gcc-objc: removing gcc breaks dependency 'gcc=6.3.1-2'

Help!!!


#60

Hi Team,

tried updating mirrors and then running:

sudo pacman -Syyu

I get this:

Suche nach in Konflikt stehenden Paketen…
Warnung: Entferne ‘gcc-libs’ aus der Ziel-Liste, da es mit ‘gcc-libs-multilib’ in Konflikt steht
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: gcc: benötigt gcc-libs=7.1.1-2

Please advise how I should proceed.

Many thanks in advance.
Martin


#61

If you have problems with dependencies gcc:

sudo pacman-key-refresh-keys

possibly remove gcc (A new version will be downloaded):

sudo pacman -Rs gcc

next:

sudo pacman -Syu