[Stable Update] 2017-05-27 - Kernels, Cinnamon, Firefox, Mesa, OpenSSL, Kodi



Thank you @philm for answering.

The output is identical to yours:

luis@pc ~ $ pacman -Qo /usr/lib/libcrypto.so.1.0.0
/usr/lib/libcrypto.so.1.0.0 pertence a openssl-1.0 1.0.2.l-1

Tried reinstalling with pacman -S openssl-1. Error persists, I have been using steam runtime while this is not been sorted out.


Is lib32-openssl-1.0 also installed?


Manjaro KDE updated on two notebooks. No issues. Thank you, Manjaro devs!


NO issues or whatsoever. Went smooth as usual. Thanks guys :slight_smile:

Kernels: linux44 & linux49


Hi there, I have this problem again with compiz compositor, where I get this large black border around some windows and black bar in place of Cairo Dock. I had this before but can’t remember how to solve it.
Switched to xfwm4 instead.
Everything else is fine.


Smooth update on 3 machines


so far so good on xfce for the update


No problems, including an update on my Alpha Litebook.


Smooth update, no problems, KDE.


No problems, thank you guys!


Just a quick tip, if you are also relatively new to Linux, don’t rush with the updates. Some will at some point break something. Do you want to be the first one to experience it? :wink:

Lees you know, less you are comfortable, longer you wait with the updates.
Lower pool number in first msg “No issues, everything went smoothly”, longer you wait with your update. (btw, this time pool numbers are one of the best.)

See what kind of problems others had. What was the fix? Once you gather all this intel, then you proceed :slight_smile:

Also, because of the nature of rolling distributions, have a backup done at least every so often!


Same issue, resolved the same way. Is colord required for scanning/printing ?


Thanks for the updates and making this disro one of the best out there!

I have an issue however related to OpenGl graphics after I installed these updates. I’ve been developing an opengl app using Qt for the last couple of years. After this update, however, the colors of the 3D objects displayed became weird and different from what I’ve been used to. I’m wondering if this is linked somehow to the new mesa package (I use gl.h) or nvidia drivers. My graphic card is nvidia 720m and I run my opengl app using primusrun. (Manjaro Gnome)

Thanks you.


Update on 12 Machines without Problems.

Switching from Catalyst on Kernel 4.10 to AMDGPU on Kernel 4.11 without Problems too.



A bit scared when the open programs froze during the update, including Pamac, but the system seems fine.


It is, @philm.


Thank you again @philm and the Manjaro Team for another success. The update run flawlessly in my machine. No problems at the moment.

My specs:

OS: Manjaro 17.0.1 Gellivara
Kernel: x86_64 Linux 4.11.3-1-MANJARO
Uptime: 7h 49m
Packages: 1807
Shell: bash 4.4.12
Resolution: 1920x1080
WM: Xfwm4
WM Theme: Default
GTK Theme: Adwaita-Maia [GTK2]
Icon Theme: Faience-Ocre
Font: Ubuntu 14
CPU: Intel Core i7-5500U @ 4x 3GHz [44.0°C]
GPU: Mesa DRI Intel® HD Graphics 5500 (Broadwell GT2)
RAM: 4144MiB / 7903MiB


Seeing any difference in graphical performance with that switch?


Everything went smooth for me as always. Great job Team. Manjaro Rocks!!!


System can’t function without colord.

error: missing 'colord' dependency for 'cinnamon-control-center'
error: missing 'colord' dependency for 'cinnamon-settings-daemon'
error: missing 'colord' dependency for 'lib32-colord'