[Stable Update] 2017-05-27 - Kernels, Cinnamon, Firefox, Mesa, OpenSSL, Kodi



Hi community,

some of our updated kernels got marked as EOL. Please move on to the next kernel series soon. We also consider to remove some EOL kernels from our repositories.

With this update-pack we have the latest Mesa v17.1 series, Firefox v53.0.3, Cinnamon v3.4.x and updated KODI-Addons. Additionally we have the latest ALSA and updated Python and Haskell packages. With an API-fix of openssl-1.0 the issue we had with Steam games should be fixed now. For all fans of XFCE, we added the latest GTK3 packages. Currently the panel got completely ported. Additionally you get the regular upstream updates of packages.

If you use Samba as a connection to your Windows machines, please update to the latest Samba release as soon as possible due a security issue we had fixed.

Please give us feedback as usual and report any issues you may see with this update.

Current supported Kernels

  • linux310 3.10.105
  • linux312 3.12.74 [EOL]
  • linux316 3.16.42
  • linux318 3.18.55 [EOL]
  • linux41 4.1.39
  • linux44 4.4.70
  • linux48 4.8.17 [EOL]
  • linux49 4.9.30
  • linux410 4.10.17 [EOL]
  • linux411 4.11.3
  • linux-RT-LTS 4.4.66_rt79 (x86_64)
  • linux-RT 4.9.27_rt18 (x86_64)

Package Updates (Sat May 27 07:26:39 CEST 2017)

  • stable community i686: 636 new and 628 removed package(s)
  • stable community x86_64: 644 new and 635 removed package(s)
  • stable core i686: 19 new and 19 removed package(s)
  • stable core x86_64: 19 new and 19 removed package(s)
  • stable extra i686: 281 new and 278 removed package(s)
  • stable extra x86_64: 281 new and 278 removed package(s)
  • stable multilib x86_64: 28 new and 29 removed package(s)

A detailed list of package changes can be found here.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Spotify dependencies (openssl)
XFCE Panel GTK+3 resetting after restart

pacman says nothing to update.

I did:

pacman-mirrors -g
pacman -Syy
pacman-mirrors -f 5
pacman -Syyu


Check http://repo.manjaro.org/ and pick the mirror that is up to date. Else you can to wait until the mirrors you are using get synchronized.


doesnt pacman-mirrors -f 5 do it?

it pics

Germany         : http://mirror.ragenetwork.de/manjaro/stable
   United_Kingdom  : http://manjaro.mirrors.uk2.net/stable
   Poland          : http://mirror.chmuri.net/manjaro/stable
   Germany         : https://manjaro-mirror-a.alpix.eu/stable
   Germany         : https://mirror.netzspielplatz.de/manjaro/packages/stable

they seem to be synced…


Your first mirror is ragenetwork, but when you check http://repo.manjaro.org/ you can see that it’s not in the “Up to date” list.


I am fairly new to manjaro but it seems on my side it shows as up to date… what am I missing?


@m4g1c check again


Crash after updating

May 27 16:30:10 xmg colord[1121]: GLib (gthread-posix.c): Unexpected error from C library during 'pthread_setspecific': Invalid argument.  Aborting.
May 27 16:30:10 xmg systemd[1]: Created slice system-systemd\x2dcoredump.slice.
May 27 16:30:10 xmg systemd[1]: Started Process Core Dump (PID 1224/UID 0).
May 27 16:30:10 xmg systemd-coredump[1225]: Process 1132 (colord-sane) of user 124 dumped core.
                                            Stack trace of thread 1137:
                                            #0  0x00007f035c1f7a10 raise (libc.so.6)
                                            #1  0x00007f035c1f913a abort (libc.so.6)
                                            #2  0x00007f035ca65831 n/a (libglib-2.0.so.0)
                                            #3  0x00007f035ca65e1a g_private_set (libglib-2.0.so.0)
                                            #4  0x00007f035ca3e485 g_slice_alloc (libglib-2.0.so.0)
                                            #5  0x00007f035ca1c1a6 g_list_prepend (libglib-2.0.so.0)
                                            #6  0x00007f035ca31661 g_queue_push_head (libglib-2.0.so.0)
                                            #7  0x00007f035b94a62d n/a (libgio-2.0.so.0)
                                            #8  0x00007f035b94a679 n/a (libgio-2.0.so.0)
                                            #9  0x00007f035ca2066a g_main_context_dispatch (libglib-2.0.so.0)
                                            #10 0x00007f035ca20a20 n/a (libglib-2.0.so.0)
                                            #11 0x00007f035ca20d42 g_main_loop_run (libglib-2.0.so.0)
                                            #12 0x00007f035b98bf86 n/a (libgio-2.0.so.0)
                                            #13 0x00007f035ca48295 n/a (libglib-2.0.so.0)
                                            #14 0x00007f035c56f2e7 start_thread (libpthread.so.0)
                                            #15 0x00007f035c2b054f __clone (libc.so.6)
                                            Stack trace of thread 1132:
                                            #0  0x00007f035d5cf5f4 n/a (n/a)

Using sudo pacman -Rdd colord solves the problem. If I don’t use scanners, cameras or printers. Do I need “colord” package?


not too sure whats going on :slight_smile: I’ve checked the site before updating at the beginning and it was showing me it was up to date… then the last screen was taking after an hour and it shows up to date… and now it shows it isnt :confused:


First they showed the status according to the previous updates, then they found out there are new updates (today, May 27) and so now they are not up to date anymore till they sync.


The page has a bug. You have to load the page and then refresh it to get the acutal status. We update that page every 20 minutes. Keep the generated date of the page in mind :wink:


its pretty clear I didnt check the website yesterday but today after philms announcement so in my understanding it should give me up to date list… anyway now I know theres a bug and all is good


yeah I was too fast :smiley: thanks I’ve learned something new again :slight_smile:


An announcement from me only means that I’ve updated the master server. When the mirrors sync is out of my hand. Either you have a mirror which syncs fast, or you wait for the updated as everybody else does. repo.manjaro.org is only our service to indicate which mirror might be in-sync. Netzspielplatz in Germany syncs every 5 minutes for example.


KDE, smooth update, thanks.


I still get openssl errors:

/home/luis/.local/share/Steam/steamapps/common/GRID Autosport/bin/GridAutosport: libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /home/luis/.local/share/Steam/steamapps/common/GRID Autosport/bin/GridAutosport)
/home/luis/.local/share/Steam/steamapps/common/GRID Autosport/bin/GridAutosport: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.2d' not found (required by libssl.so.1.0.0)


Lesson learned :wink:

After syncing everything went smooth. Thank you.


Everyhing went well,
thank you! :+1:


All good, KDE on 2 machines, update with Konsole. Thanks !


Which files do you have? Check if you have the latest openssl packages:

pacman -Qo /usr/lib/libcrypto.so.1.0.0
/usr/lib/libcrypto.so.1.0.0 is owned by openssl-1.0 1.0.2.l-1