[Stable Update] 2017-05-12 - Kernels, KDE, KDE Apps, Gnome, Browsers

update
stable

#142

everything seems to be OK here on KDE, but i got 2 warnings:

> (393/393) Überprüfe verfügbaren Festplattenspeicher                                                                             [##############################################################################] 100%
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/pkg_resources/__pycache__/__init__.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools-35.0.1-py3.6.egg-info/ nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools-35.0.1-py3.6.egg-info/PKG-INFO nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools-35.0.1-py3.6.egg-info/SOURCES.txt nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools-35.0.1-py3.6.egg-info/dependency_links.txt nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools-35.0.1-py3.6.egg-info/entry_points.txt nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools-35.0.1-py3.6.egg-info/requires.txt nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools-35.0.1-py3.6.egg-info/top_level.txt nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools-35.0.1-py3.6.egg-info/zip-safe nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/__init__.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/archive_util.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/config.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/dep_util.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/depends.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/dist.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/extension.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/glob.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/launch.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/lib2to3_ex.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/monkey.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/msvc.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/namespaces.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/package_index.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/py26compat.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/py27compat.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/py31compat.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/py33compat.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/py36compat.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/sandbox.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/site-patch.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/ssl_support.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/unicode_utils.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/version.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/__pycache__/windows_support.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/__init__.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/alias.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/bdist_egg.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/bdist_rpm.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/bdist_wininst.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/build_clib.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/build_ext.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/build_py.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/develop.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/easy_install.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/egg_info.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/install.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/install_egg_info.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/install_lib.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/install_scripts.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/py36compat.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/register.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/rotate.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/saveopts.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/sdist.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/setopt.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/test.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/upload.cpython-36.opt-1.pyc nicht ermitteln
> Warnung: konnte Dateiinformationen für usr/lib/python3.6/site-packages/setuptools/command/__pycache__/upload_docs.cpython-36.opt-1.pyc nicht ermitteln

and

Warnung: /etc/pacman-mirrors.conf installiert als /etc/pacman-mirrors.conf.pacnew

i hope i can ignore them?

will now try 4.11 and rebooting :smiley:


#143

No issue here on two machines running Gnome, thanks.

Kernel 4.10.15-1


#144

But, if they are not required by anything, why do I get this dialogue when I try to remove them?


#145

sddm refuses to start when I don’t install the openssl-1.0-compat and lib32-openssl-1.0-compat from the repo.
I don’t know what I did to screw this up?
But installing both packages fixed it.

sddm without openssl-1.0-compat:

~ >>> systemctl status sddm                                                                                           
● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2017-05-13 13:04:49 CEST; 14s ago
     Docs: man:sddm(1)
           man:sddm.conf(5)
  Process: 982 ExecStart=/usr/bin/sddm (code=exited, status=127)
 Main PID: 982 (code=exited, status=127)

mei 13 13:04:48 steambox systemd[1]: Started Simple Desktop Display Manager.
mei 13 13:04:48 steambox systemd[1]: sddm.service: Main process exited, code=exited, status=127/n/a
mei 13 13:04:48 steambox systemd[1]: sddm.service: Unit entered failed state.
mei 13 13:04:48 steambox systemd[1]: sddm.service: Failed with result 'exit-code'.
mei 13 13:04:49 steambox systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
mei 13 13:04:49 steambox systemd[1]: Stopped Simple Desktop Display Manager.
mei 13 13:04:49 steambox systemd[1]: sddm.service: Start request repeated too quickly.
mei 13 13:04:49 steambox systemd[1]: Failed to start Simple Desktop Display Manager.
mei 13 13:04:49 steambox systemd[1]: sddm.service: Unit entered failed state.
mei 13 13:04:49 steambox systemd[1]: sddm.service: Failed with result 'exit-code'.
~ >>>    

Maybe I run too many packages,
openssl packages that are installed:

openssl
openssl-1.0
lib32-openssl
lib32-openssl-1.0
openssl-1.0-compat
lib32-openssl-1.0-compat

btw, all my Ferral games work without symlinking


#146

Hi I got the same issue as the poster above. I tried to remove the package but I got this:

sudo pacman -r gstreamer0.10-good-plugins
error: failed to initialize alpm library
(could not find or read directory: gstreamer0.10-good-plugins/var/lib/pacman/)

I navigated to the folder (var/lib/pacman/local) and I found the folder for gstreamer:
gstreamer0.10-good-plugins-0.10.31-11.1
I tried to do sudo pacman -r gstreamer0.10-good-plugins-0.10.31-11.1
but that too didn’t work, got same error as above
What can be done in this case?
Thank you


#147

sudo pacman -R gstreamer0.10-good-plugins :wink:


Got this popup while trying to Apply update
#148

I don’t use pulseaudio, so I don’t want to remove xfce4-mixer that is the only tool for me (except console alsamixer, but it will be inconvinient to run it every time). So I deleted just “good plugins” that conflicted with some packages and I don’t know how it will work after update (it will take a day to download all 573 Mb :confused:). Is there other plugins that still work with alsa?

(edit: first symbol didn’t pasted properly)


#149

Everything went smoothly, at first i had the gstreamer dependency issue, but unistalling that package solved the issue. Also after the update I updated the kernel to 4.9 LTS using the gui utility, as I was still on 4.4. Not a single problem yet.

Keep the good work!


#150

I didn’t notice this one being answered.
Should we update via “normal” console, or go the ctrl+alt+f3 route?


#151

Ok, this time i’ve got the short straw - system doesn’t boot anymore :frowning:

Update went through (although i accidently interrupted it during mirrorlist-generation (early in the morning and i wanted to copy some warnings -.-), but seemed to have finished when issuing “sudo pacman -Syu” again.
ran pacman-mirrors -g afterwards to be sure.

then, i installed 4.11 and tried rebooting.
Now, i cant boot -.-
4.11 is stuck at “loading initial ramdisk”, 4.10 and 4.9 get to the manjaro-splash but keep running the dots forever.

I’ve got a fully encrypted system if that matters.
Just chrooted, pacman -Syyuu says everything is up to date.

when trying to reinstall 4.10 or 4.9 (pacman -S linux410 / 49) in chroot, i get the warning:

Found initrd fallback image: /boot/initramfs-4.9-x86_64-fallback.img
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Found memtest86+ image: /boot/memtest86+/memtest.bin

any ideas? :confused:

edit: Ok, it works again - don’t know if reinstalling the kernels or grub did the trick. Maybe by interrupting the update i skipped the building of the images?

but 4.11 is still stuck at “loading initial ramdisk” for me…
edit2: tried to get any logs from the attempted 4.11 boots, but they don’t even show up in journalctl --list-boots


#152

Not sure if this helps but have you tried sudo update-grub


#153

Just as @Shadow.Warden wrote in his seperate topic I got:

while trying to update.

Fixed it by simply removing gstreamer0.10 (including gstreamer0.10-plugins).

Update went smoothly afterwards! :slight_smile: Thanks a lot maintainers! :smile:


#154

How shud i proceed for xorg-utils and xorg-server-utils. Is it safe to remove meta package dependencies

sudo pacman -Rns xorg-utils xorg-server-utils
checking dependencies…
:: inxi optionally requires xorg-xdpyinfo: inxi -G multi screen resolution

Packages (21) dmxproto-2.3.1-3 libdmx-1.1.3-1 libxxf86dga-1.1.4-1 xf86dgaproto-2.1-3 xorg-iceauth-1.0.7-1 xorg-sessreg-1.1.1-1
xorg-xbacklight-1.2.1-1 xorg-xcmsdb-1.0.5-1 xorg-xdpyinfo-1.3.2-1 xorg-xdriinfo-1.0.5-1 xorg-xev-1.2.2-1 xorg-xgamma-1.0.6-1
xorg-xhost-1.0.7-1 xorg-xinput-1.6.2-1 xorg-xlsatoms-1.1.2-1 xorg-xlsclients-1.1.3-1 xorg-xrefresh-1.0.5-1 xorg-xvinfo-1.1.3-1
xorg-xwininfo-1.1.3-1 xorg-server-utils-7.6-4 xorg-utils-7.6-9

Total Removed Size: 0.95 MiB

:: Do you want to remove these packages? [Y/n]


#155

nvm … should be -R and not -r
worked now


#156

Did the update on KDE edition yesterday, no problems as far as I can tell.

This is how I did the update:
Drop to tty (CTRL-ALT-F3) and login.

sudo pacman -R gstreamer0.10-good-plugins
sudo pacman -Syyu
sudo reboot

As usual, great work Manjaro Team. :slight_smile:


#157

In KDE all run fine, but the sddm theme don’t show the background. I use breath theme


#158

Well, we should have fixed that already with this.


#159

This works for me


#160

Updated KDE, everything works perfectly


#161

No problems here, just had to recompile the new nvidia module.
Good work!