[Stable Update] 2017-05-12 - Kernels, KDE, KDE Apps, Gnome, Browsers



It appears that xorg-utils and xorg-server-utils were dropped to the AUR and replaced by a newer meta-package (xorg-apps).


How do you uninstall that gstreamer thingie, I don’t see it listed in Pamac.


…look in pamac - status - orphand…


Thank you everything went smoothly KDE. Fingers crossed that was a big update :grin:


Do you mean pamac/state/orphans? There’s no gtreamer there.
edit: I found it in AUR but it’s not installed.


…then you are fine.


Failed to connect to database: Can’t connect to local MySQL server through socket ‘/tmp/akonadi-phenom.WH210Q/mysql.socket’ (2 “Datei oder Verzeichnis nicht gefunden”) QMYSQL: Unable to connect

Well not so cool after updating. Now akonadi can´t connect. Any ideas?


I had no errors come up, but since the update none of the installed kernels (4r, 410, 411) boot past the hard drive check (/Dev/sdax: clean, x/x files, x/x blocks).
I am using Linux for a couple of years now, but never had that sort of problem. I am hence open for the most basic of suggestions.
I am running the KDE version (no dual boot)


Everything went fine on my laptop running KDE
> Total Download Size: 1026,55 MiB
> Total Installed Size: 3676,87 MiB
> Net Upgrade Size: 87,36 MiB


Smooth update on my systems :slight_smile:


244 packages updated without a problem on Cinnamon, kernel 4.9LTS. For some reason though I keep getting a “newer kernel available, update” message from Manjaro Settings Manager, even though I set it to only notify about LTS kernels, but of course that is just a minor little thing. Thanks for the great update! Can finally use Thunderbird now because I needed 52.1 to be able to use it with Gmail and 2 factor authentification once again.


Oh dear, for some reason (probably my fault), my keyrings are totally f*cked up.

Fehler: <pkgname>: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust

Manually running pacman-key --refresh-keys results in:

gpg: [don't know]: invalid packet (ctb=7f)
gpg: keyring_get_keyblock: read error: Ungültiges Paket
gpg: keydb_get_keyblock failed: Ungültiger Schlüsselbund
gpg: keydb_search failed: Ungültiger Schlüsselbund
gpg: Ohhhh jeeee: ... this is a bug (getkey.c:3284:merge_selfsigs)
/usr/bin/pacman-key: Zeile 643: 10609 Abgebrochen             (Speicherabzug geschrieben) "${GPG_PACMAN[@]}" --refresh-keys "$@"

EDIT: It’s okay now. Had to remove pacman’s gnupg directory and repopulate the whole mess.


yaourt -Rs ask to remove some stuff:
yaourt -Rs xorg-server-utils
(10) xorg-iceauth-1.0.7-1 xorg-sessreg-1.1.1-1 xorg-xbacklight-1.2.1-1 xorg-xcmsdb-1.0.5-1 xorg-xgamma-1.0.6-1 xorg-xhost-1.0.7-1 xorg-xinput-1.6.2-1 xorg-xrandr-1.5.0-1
xorg-xrefresh-1.0.5-1 xorg-server-utils-7.6-4

yaourt -Rs xorg-utils
(7) xorg-xdriinfo-1.0.5-1 xorg-xev-1.2.2-1 xorg-xlsatoms-1.1.2-1 xorg-xlsclients-1.1.3-1 xorg-xvinfo-1.1.3-1 xorg-xwininfo-1.1.3-1 xorg-utils-7.6-9

or should I use only yaourt -R for both?

OT waiting for the new 4.11.1


No luck this time… I can’t boot, system freezes at the hard disk check. :frowning:


Same here. Did you update directly from the terminal? Because I got lazy last night and just let it run through octopi. Dear that may have been a mistake.


That is because your pacman-mirrors has been updated. It reverts you to stable branch. You have to re-enable what branch you were on in pacman-mirrors.conf


After this update, I can’t install i-nex. The i-nex packages has xorg-server-utils as a dependency.

$ pacman -S i-nex 
resolving dependencies...
warning: cannot resolve "xorg-server-utils", a dependency of "i-nex"
:: The following package cannot be upgraded due to unresolvable dependencies:

:: Do you want to skip the above package for this upgrade? [y/N] N
error: failed to prepare transaction (could not satisfy dependencies)
:: i-nex: requires xorg-server-utils


If you have the newer pacman-mirrors 4.x you have the --fasttrack option which is special in the sense that it gives you mirrors which are up-to-date as seen on repo.manjaro.org

If you want to be sure you are using up-to-date mirrors then do

sudo pacman-mirrors --fasttrack 5

This gives you 5 mirrors which are up-to-date with the master repo. You cannot use combine it with thedr arguments --country, --geoip, --method, --interactive.

This type of mirorlist is a moving target :slight_smile:


I updated mine (deepin) through package manager (pamac) Only because I didn’t read the instructions in the OP. I know I’m a rebel!!

Everything went without a hitch :slight_smile:


A good trick but involves you to look at the repo list. Have you tried doing

sudo pacman-mirrors --fasttrack 5

If 5 up-to-date mirrors is available that is what you get in the mirrorlist :slight_smile:

This type of mirorlist is a moving target :slight_smile: