[Stable Update] 2017-05-12 - Kernels, KDE, KDE Apps, Gnome, Browsers



Having these upgrades is really awesome…But something went not right. my USB mouse isn’t working…I don’t know where I could find the faulty reaction after the system upgrade


Thanks for being so nice. I did try clonezilla right at the start when I were reading a lot of the wiki & forum. As I now know the reason it didn’t work for me is because my laptop has an internel emmc drive that clonezilla doesn’t know what to do with.

I keep my stuff on a giant usb stick anyway so I didn’t really regard backing up the os as that important. I’ll figure something out though :slight_smile: Worst case I can revert to my favourite sport of reinstalling if I can’t fix it lol


:relieved: No more doubts. thanks


@MattAV in my case it’s just e without CTRL, but removing quiet and splash entries to deactivate plymouth temporarily is what you will have to do additionally to what I wrote, yes.
F10 or CTRL+x should both work to launch the boot process after you edit the boot parameters.


sudo pacman-mirros -f 5

Generates list of 5 most recently updated mirrors sorted by response time. They are not fastest 5 up to date mirrors. Pls observe the last sync time below marked in bold and generated mirrorlist.

[mickey@manjaro ~]$ sudo pacman-mirrors -f 5
[sudo] password for mickey:
.: Info Downloading mirrors from repo.manjaro.org
.: Info: Querying mirrors - This may take some time
1.563 United_States : 00:13: http://distro.ibiblio.org/manjaro/
1.899 Germany : 00:01: https://mirror.netzspielplatz.de/manjaro/packages/
… Bulgaria : 00:10: https://manjaro.ipacct.com/manjaro/
1.464 Australia : 00:10: http://manjaro.uberglobalmirror.com/
1.378 Poland : 00:02: http://mirror.chmuri.net/manjaro/
1.397 Japan : 00:12: http://ftp.tsukuba.wide.ad.jp/Linux/manjaro/
.: Info Writing mirror list
Poland : http://mirror.chmuri.net/manjaro/stable
Japan : http://ftp.tsukuba.wide.ad.jp/Linux/manjaro/stable
Australia : http://manjaro.uberglobalmirror.com/stable
United_States : http://distro.ibiblio.org/manjaro/stable
Germany : https://mirror.netzspielplatz.de/manjaro/packages/stable
.: Info Mirrorlist generated and saved to: /etc/pacman.d/mirrorlist


xps9550, KDE, smooth update. no issues at all. kernel 4.4.67-1


Smoth update on KDE, thanks :smiley:


Thanks for the suggestion. I did wait 24h to be sure, and I confirm than downgrading networkmanager from 1.8 to the last 1.6 version was the solution for me.
I have now again a stable internet connexion without loosing the network every 2 hours or so.
I have marked the current 1.8 version as “ignore package” for further upgrades… will try with new versions when one will arrive, but for now I am OK.


I am getting errors like this

error: ncurses: signature from "Lukas Fleischer <lfleischer@lfos.de>" is invalid
:: File /var/cache/pacman/pkg/ncurses-6.0+20170429-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: glib2: signature from "Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>" is invalid
:: File /var/cache/pacman/pkg/glib2-2.52.1+4+g2eddcef1e-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

What should I do? I tried pacman -Syyu but that didn’t help

Edit: Fixed it with pacli


82 posts were split to a new topic: Problem with clementine


if looks like you require some detailed documentation of pacman-mirrors and the simple help function is not enough for you.
please look here for a detailed documentation (for the latest development version of pacman-mirrors):


The update seemed to go more or less okay using the UK mirrors.

At some point I left for a few mins, when I returned the screen were completely blank. Pressing random keys and the “obligatory mouse click™” didn’t do anything, even tried switching tty’s, nothing. So thinking it’s smegged (broke) I initiated the sinking ship three-finger-salute (ctrl+alt+del) and somehow a tty appeared yay.

Spammed the pacman -Syyu repeatedly until no more updates were found, rebooted and everything seems okay.

Nice job guys! :slight_smile:


So it looks like I should uninstall Evolution and give up any customization. :pensive:


I can confirm having experienced random stalls of the LAN connection, but not since this update, it was until the before-last or so. I have the impression that the behaviour has improved with the present update … it’s a little weird though …

EDIT: oops; I saw you downgraded the package … so I’ll try that if my LAN borks again … :wink:


Yes, I am running now networkmanager version 1.6.2-3 and I have a stable LAN connection. It was not the case with the new 1.8.0-1 version. Hope it will works for you also… in case you have the same issue.


Thank you for this fantastic work. Everything went fine with this huge update. Biggest update I’ve experienced with lowest number of config files to check.

And best: I was able to finally upgrade libvirt and qemu, which were blocked due to a bug. They work like charm now again.


mobile broadband usb sticks huawei model k4203 and k4606
not working after update.
fixed by downgrade networkmanger


I had the same issue. I removed gstreamer10-good-plugins and then updated the system and now it all seems to run fine.

I’m running XCFE with a mix of gnome and KDE apps thrown in.

To do this using the terminal I did the following commands:

sudo pacman -Rns gstreamer0.10-good-plugins

sudo pacman -Syu


All’s well with the system, a few (probably upstream) bugs on gnome:

  • Arc Maia colour scheme is inadequate for 3.24; notification’s titles are light gray on white and that’s hard to read
  • Something weird happens when removing user extensions on gnome-tweak-tool: you click the “Remove” button then all extensions are disabled for some reason


Using Xfce-4-Terminal, confirmed mirror status, and ran sudo pacman -Syu. No issues on Xfce Laptop with intel integrated GPU. Thanks to all of you, as I did read many of your posts before updating!