[Stable Update] 2017-05-12 - Kernels, KDE, KDE Apps, Gnome, Browsers

update
stable

#244

Until the package is updated, you could use e.g.:

sudo pacman -S --assume-installed xorg-server-utils i-nex

this tells pacman to assume xorg-server-utils is installed.


#245

Hi all!

I was too lazy and tried to update from the terminal inside a KDE session. Big mistake! The system froze when installing VBox modules. There was no keyboard response so I had to make a hard shutdown. Tried rebooting… kernel 44 booted into rootfs but there was no keyboard response, kernel 41 booted into sddm but there was no keyboard response. Booting into emergency mode got no keyboard response, and changing usb port had no effect.

So, I burned a live image using another PC, chrooted into the system and tried updating again. There was nothing to do! Checking database and files had no error output. So, I tried reinstalling kernels without VBox modules. No effect!

I finally chrooted again into the system, cleaned the cache (except installed packages), and reinstalled all the packages from the cache. Rebooted again and everything seems to be there and working fine :slight_smile:

Big thanks to all the devs and testers.

Cheers,

EDIT: had to rebuild megasync.


#246

@mbb - thanks for that, I usually update in the GUI (XFCE in my case) in a terminal…that is potentially part of the DE…and CAN break in the update…
If I need a log for later (and I always make one) I use

pacman -Syu | tee update.txt
…writes to the screen and a file…
Anyway…thanks team…an other one wel done :slight_smile:
Melissa
:rose: :rose: :rose:


How to export or find update logs?
#247

Are you sure your update has completed after force-installing openssl-1.0?
Try to run once more

sudo pacman -Syyu

Also it would be interesting what says

pacman -Q openssl

The output should be openssl 1.1.0.e-1


#248

950Mb full KDE 64bit on i7 Optimus and old AthlonAti hardware
350Mb mini Lxde 32bit on old Intel Atom/950GMA

No problems, brilliant.
Thanks


#249

Thank you, I did again pacman -Syyu on tty and it said “Nothing to do”. And yes pacman -Q openssl gives openssl 1.1.0.e-1. But no plasma on boot :disappointed:


#250

I checked pacman’s log. It was interrupted installing VBox kernel modules (and the database was still locked). However, the database synced fine and the system told me everything was updated! That’s why I opted for a cache clean and then a reinstall.


#251

The update seems to have proceeded fine, though there was some weirdness during hooks:

:: Running pre-transaction hooks...
(1/2) Remove DKMS modules
==> dkms remove bbswitch/0.8 -k 4.8.17-1-MANJARO
==> dkms remove vboxhost/5.1.20_OSE -k 4.10.12-1-MANJARO
==> dkms remove bbswitch/0.8 -k 4.9.24-1-MANJARO
==> dkms remove vboxhost/5.1.20_OSE -k 4.9.24-1-MANJARO
rmdir: failed to remove '': No such file or directory
rmdir: failed to remove '': No such file or directory
==> dkms remove bbswitch/0.8 -k 4.10.12-1-MANJARO
==> dkms remove vboxhost/5.1.20_OSE -k 4.8.17-1-MANJARO
(2/2) Unregistering Haskell modules...
unregistering would break the following packages: yaml-0.8.22 skylighting-0.1.1.5 pandoc-1.19.2.1 pandoc-citeproc-0.10.4.1 http-conduit-2.2.3.1 texmath-0.9.4 pandoc-types-1.17.0.5 doctemplates-0.1.0.2 (ignoring)
unregistering would break the following packages: http-client-tls-0.3.4.1 x509-1.6.5 x509-validation-1.6.5 x509-system-1.6.4 x509-store-1.6.2 tls-1.3.10 connection-0.2.8 asn1-parse-0.9.4 (ignoring)
unregistering would break the following packages: memory-0.14.3 (ignoring)

#252

Clever, the cache clean especially. Forces the lil guy to download everything afresh :slight_smile:


#253

Since the update, dolphin keeps crashing constantly and is unusable. When I start it in a terminal, this is the output I get:

kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find "stash"
Cannot creat accessible child interface for object: PlacesView(0x1fa2a00) index: 13
kf5.kio.core: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf\nError loading services.\n"
kf5.kio.core: KSambaShare: Could not find smb.conf!
kf5.kio.core: We got some errors while running 'net usershare info’
kf5.kio.core: “Can’t load /etc/samba/smb.conf - run testparm to debug it\n”

The same thing happens when I use octopi as well, although I don’t get the same output from the terminal. I am unable to even search for packages. As soon as I start typing a package name, octopi crashes.


#254

I’m usually very confident of saying yes to all package removal due to conflict during upgrades, but not this time:

warning: removing 'dbus' from target list because it conflicts with 'dbus-elogind'
:: elogind and systemd-sysvcompat are in conflict. Remove systemd-sysvcompat? [y/N] y
:: dbus-elogind and dbus are in conflict (libdbus). Remove dbus? [y/N] y
:: polkit-elogind and polkit are in conflict. Remove polkit? [y/N] y
:: libeudev and libsystemd are in conflict (libudev.so). Remove libsystemd? [y/N]

once my eye catches libsystemd removal, I’m in doubt. Is it safe?

EDIT:
No, it is not safe. Browsing the forum I found this which solves the problem. Bye2 pm-utils…


#255

No, I cleaned it with -Sc not -Scc so nothing was downloaded. I just cleaned it because I had older packages there and those would create conflicts. I just had to download VBox host modules because these weren’t installed when I cleaned the cache.


#256

i just update
and when restart
i got this error
amdgpu: [ powerplay ] VBIOS did not find boot engine clock value in dependency table. Using Memory DPM level 0!
what is it and how can solve it …!


#257

Are you sure you need to solve it?
Does your system boot properly, with no video issues?
There is quite a bit of stuff in Google about this that suggests the message still happens but the problem is solved.

You might try kernel 4.10 if you aren’t already using that.


#258

I am newbie on manjaro (6 months old) and happen to follow steps detailed below during update. Thought it might be worth sharing.

  1. Save and close all application.
  2. Logout to sddm
  3. Press Ctrl + alt + F2
  4. login on tty2
  5. Run nmtui (Ncurses based network manager gui to connect to Lan / Wifi.)
  6. Run sudo pacman-mirros -f 5
  7. Run sudo pacman -Syyuw (First only download all packages to manage breaking change during package installation)
  8. Run sudo pacman -Syu
  9. Done with update, Run systemctl reboot

I never use force or assume “yes” to conflicts. whenever in doubt prefer searching for solution on manjaro forum


Applying manjaro update from TTY
#259

After reading the thread I’m scared to update. Yeh I think I’ll sit this one out lol


#260

well, at this stage, you knwo more than I did when 6 months old, but…I never left the GUI…I was of Fedora8…and everything was done graphically…
Sen in hindsight…dangerous if the GUI breaks :slight_smile:


#261

For most users the update went fine. :wink:
It can only become problematic when you have exotic hardware, or interrupt the update process.
It’s really best to do sudo pacman -Syyu in a console. - That’s what I do and I never had a problem with an update so far.


#262

281 packages upgraded without pain (XFCE4, Intel GPU driver, kernel 4.9) !
Thanks to the Manjaro team for this excellent job !


#263

I was able to remove gstreamer with the following command:

pacman -Rsc $(pacman -Qqs gstreamer0.10)

Then proceed with:

pacman -Syyu

Also, I find “pacman-mirrors --geoip” generates a nice mirror list of servers in my country.

As for Manjaro not being user friendly, that is not my experience at all. The forum is fairly active, useful, and generally helpful. For in-depth information, there is no better source than the upstream “Arch” wiki.