[Stable Update] 2017-04-25 - Firefox, KDE Apps, Haskell, Virtualbox

update
stable

#22

I’m experiencing two problems on my box (OpenRC, i3wm): one related to udiskie and the other to mpv

1- udiskie do not luanch (the problem is in udisks2) and when run from terminal it gives:

$ udiskie 
Failed to connect UDisks2 dbus service..
Falling back to UDisks1.
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/udiskie/cli.py", line 288, in _start_async_tasks
    self.udisks = yield get_backend(self.options['udisks_version'])
  File "/usr/lib/python3.6/site-packages/udiskie/async_.py", line 293, in _interact
    value = func(*args)
  File "/usr/lib/python3.6/site-packages/udiskie/cli.py", line 59, in get_backend
    daemon = yield get_backend(1)
  File "/usr/lib/python3.6/site-packages/udiskie/async_.py", line 293, in _interact
    value = func(*args)
  File "/usr/lib/python3.6/site-packages/udiskie/cli.py", line 62, in get_backend
    daemon = yield udiskie.udisks1.Daemon.create()
  File "/usr/lib/python3.6/site-packages/udiskie/async_.py", line 293, in _interact
    value = func(*args)
  File "/usr/lib/python3.6/site-packages/udiskie/udisks1.py", line 532, in create
    version = yield cls.get_version()
  File "/usr/lib/python3.6/site-packages/udiskie/async_.py", line 293, in _interact
    value = func(*args)
  File "/usr/lib/python3.6/site-packages/udiskie/udisks1.py", line 544, in get_version
    cls.Interface, 'DaemonVersion'))
  File "/usr/lib/python3.6/site-packages/udiskie/dbus.py", line 102, in _callback
    value = proxy.call_finish(result)
GLib.GError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UDisks was not provided by any .service files (2)

2- mpv no audio!!!

$ mpv quantum espresso installation.mkv
Warning: option --ass-force-style was replaced with --sub-ass-force-style and might be removed in the future.
Warning: option --sub-text-font was replaced with --sub-font and might be removed in the future.
Warning: option --sub-text-font-size was replaced with --sub-font-size and might be removed in the future.
Warning: option --sub-text-color was replaced with --sub-color and might be removed in the future.
Warning: option --sub-text-border-color was replaced with --sub-border-color and might be removed in the future.
Warning: option --sub-text-border-size was replaced with --sub-border-size and might be removed in the future.
Warning: option --sub-text-shadow-offset was replaced with --sub-shadow-offset and might be removed in the future.
Warning: option --sub-text-shadow-color was replaced with --sub-shadow-color and might be removed in the future.
Warning: option --sub-text-spacing was replaced with --sub-spacing and might be removed in the future.
Playing: quantum espresso installation.mkv
 (+) Video --vid=1 (*) (h264 1280x720 15.000fps)
 (+) Audio --aid=1 --alang=eng (*) (opus 2ch 48000Hz)
Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory
[ffmpeg] Cannot load libnvcuvid.so.1
[ffmpeg/video] h264_cuvid: Failed loading nvcuvid.
Could not open codec.
[drc] libavfilter filter 'drc' not found!
Couldn't create or open audio filter 'drc'
Error at audio filter chain pre-init!
Audio: no audio

EDIT: I solved the audio problem in mpv. Just comment a line in ~/.config/mpv/mpv.conf : af=drc

any hints!


#23

KDE did not restore my previous saved session after this update.
It was still there in ~/.config/session/, but logout/login did not open any windows.

I guess KDE caused it – not blaming Manjaro :relaxed:

When I saved a new session, it was restored on logout/login.
(KDE restores only Dolphin windows in a useful way,
but from those I can re-open whatever I was working on. :slight_smile: )


#24

no issues on xfce all went well


#25

All good on Manjaro Deepin. One thing though, I cannot play Netflix videos with Firefox (https://www.netflix.com/browse). I only have 4 add-ons, disabled them all, restarted Firefox and still will not work. I get the β€œUnexpected Error” : Error Code: F7361-1253, go to Netflix support site: https://help.netflix.com/en/node/40988.

DRM playback is enabled in settings, other times I’ll get a Widevine error code, but not consistently.

I know it’s not a Manjaro issue, but curious if anyone else experiencing this?


#26

Manjaro KDE screen flickers

It won’t stop(flickering), here, until a window is moved or activated using the mouse pointer.

So far the triggers are opening a menu, window roll-up or the roll-down and reducing a window from full screen using F11.

Nothing consistent in the logs …

{edit:
It appears to be kwin as the cause. The LXQt install is completely unusable with kwin as the window manager.

The Openbox desktop works as normal so far. No flickering. …etc.

EDIT2:

KDE/Openbox works without any flickering.

=> kwin or something needed for kwin is broken.


As above in post about broken browsers, which is probably related, this install is

OS: Manjaro 17.0 Gellivara~Stable; Kernel: 4.10.12-1-MANJARO x86_64 (or 4.9.24-1-MANJARO x86_6);
CPU(s)~2 Quad core Intel Xeon X5687s (-HT-MCP-SMP-); Mem~2901.0/24104.9MB; NUMA~2 nodes; Network~2x Intel 82576 (igb); HDD~4961.0GB(17.9% used); GPU~GeForce GTX 1060 6GB; Resolution~3840x2160; GLX~4.5.0 NVIDIA; GP106 ~375.39; DE~KDE 5.32.0 / Plasma 5.9.4 (Qt 5.8.0); WM~KWin; *.

}


#27

Any particular kind of window ?

Can not replicate any flicker here with intel graphics.


#28

[quote=β€œjsamyth, post:27, topic:22480”]
Any particular kind of window ?
[/quote]No special window. Any will trigger it with kwin as far as I can tell. :frowning2:


#29

As I also wrote in the thread I started about this: https://forum.manjaro.org/t/manjaro-kde-screen-flickers/22527/9 it looks like my problems are over. I also use Intel graphics and have the April 25 update installed after which the flickering stopped.
Will report back when it should start again.


#30

Elaisticsearch does no longer work, the new version does not start. Any hints?


#31

I have a good question, why is bibletime automatically included ?


#32

I see it is in the repos, we do have a divers community.
It is not installed on my xfce, I never removed it.

error: package 'bibletime' was not found```

[quote="0_x1, post:31, topic:22480"]
why is bibletime automatically included ?
[/quote]

Where, what do you mean???

#34

My Firefox tabs are completely broken in Cinnamon DE since the last update.

I had no issues before. I also don’t have problems with my other browsers: Chrome, Chromium, Vivaldi or Opera.


#35

Ah, in my case some new tab handling code in Firefox messes up the Tab Mix Plus addon. When I disable this addon, tabs are back to normal. Found the clue in this article.


#36

That sucks though. Tab Mix Plus is one of the things that keeps me with Firefox. I hope you can find a workaround. Must be the fade effect FF switched to for the tab titles.


#37

Since the update I get the following error, when I try to boot up my vagrant machine:

Vagrant was unable to mount VirtualBox shared folders. This is usually
because the filesystem "vboxsf" is not available. This filesystem is
made available via the VirtualBox Guest Additions and kernel module.
Please verify that these guest additions are properly installed in the
guest. This is not a bug in Vagrant and is usually caused by a faulty
Vagrant box. For context, the command attempted was:

mount -t vboxsf -o uid=1000,gid=1000 vagrant /vagrant

The error output from the command was:

mount: wrong fs type, bad option, bad superblock on vagrant,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

Edit: I tried on Kernel Versions 4.9 and 4.10, same error on both.


#38

I hope Tab Mix gets fixed soon. But apparently this was already an issue in beta releases, so I wonder why it hasn’t been fixed yet… We’ll see.


#39

Hi all, since the recent updates I am having serious problems with my wireless microsoft keyboard. The keys are not always responding. I’ve checked and the batteries are fine. It seems to be struggling when I type fast. Also the arrow keys don’t work.
Any suggestions?

I’m running XFCE.

It was very hard to type this message!!! ha ha


#40

I downgrade udisk2 as suggested by @v17564 and it solved my problem.


#41

@muvvenby: I am not having problems with Tab Mix Plus. It may be a problem with other extensions you have installed that are messing with TMP. Have you tried turning all them off just to check? Some time ago I had problems with Firefox after an update, and after a lot of tests I discovered that the problem came from another extension that became incompatible with a new library.

My system:

 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     OS: Manjaro 17.0.1 Gellivara
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Kernel: x86_64 Linux 4.10.12-1-MANJARO
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Uptime: 39m
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ            β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Packages: 1765
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Shell: bash 4.4.12
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Resolution: 1920x1080
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     DE: XFCE4
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     WM: Xfwm4
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     WM Theme: Default
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     GTK Theme: Adwaita-Maia [GTK2]
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Icon Theme: Faience-Ocre
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Font: Ubuntu 14
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     CPU: Intel Core i7-5500U @ 4x 3GHz [44.5Β°C]
                                  GPU: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) 
                                  RAM: 2577MiB / 7903MiB

#42

I donΒ΄t know if itΕ› either the Mesa or MPV update or both, but whether streaming or from files, video playback stutters and glitches now. Experiencing CPU spikes during playback as well. Those are the only issues IΒ΄ve encountered, so far.

ItΕ› been smooth running with i3 for three days - :grin: - but this latest Manjaro update has put a damper on things. :disappointed: Unless these updates are necessary, IΒ΄m going to downgrade. At least I will downgrade MPV, to see what happens. Or maybe somebody has encountered the same problems and knows of a solution? Thanks! :slight_smile:

Update: Downgrading MPV fixed the problem. Glitches, CPU spikes, stuttering, and screen tears have been eliminated. Might have to tell pacman to ignore this package for a while. MPV updates donΒ΄t happen often.