[Stable Update] 2017-04-23 - Kernels, KDE Framework, Mesa, Budgie



After 4 attempts,

:: Starting full system upgrade…
there is nothing to do


No bumblebee anymore!

optirun -b primus glxgears

Gives me:

[12579.969516] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[12579.969592] [ERROR]Aborting because fallback start is disabled.

Does anyone has an idea on how to solve this? Thanks.


systemsettings5 -> application style -> Gnome Application Style -> cursor theme
If you do not want the change from one cursor to another, set the Cursor Theme to same as the K Desktop.
Mozilla Firefox uses GTK3, BTW. JIC you want to select the Gnome Theme.

[quote=“themew, post:56, topic:22325”]
Having an issue like this with XFCE.
[/quote]Use the Settings for XFCE and do the same.


Thanks! That worked like a charm.


This is odd. On my end it works:

phil@manjaro ~/Arbeitsfläche $ uname -a
Linux manjaro 4.9.24-1-MANJARO #1 SMP PREEMPT Fri Apr 21 08:32:28 UTC 2017 x86_64 GNU/Linux
phil@manjaro ~/Arbeitsfläche $ lsmod | grep nvidia
nvidia_drm             53248  2
nvidia_modeset        782336  3 nvidia_drm
nvidia              12070912  41 nvidia_modeset
drm_kms_helper        126976  1 nvidia_drm
drm                   294912  6 ttm,nvidia_drm,drm_kms_helper
phil@manjaro ~/Arbeitsfläche $ pacman -Q linux49-nvidia
linux49-nvidia 1:375.39-14


firefox-gtk2 should not own that file.

pacman -Qo /usr/lib/firefox/distribution/distribution.ini
/usr/lib/firefox/distribution/distribution.ini is owned by manjaro-browser-settings 20161221-1

Check the firefox-gtk2 filelist
pacman -Ql firefox-gtk2

and if it’s in the list, remove firefox-gtk2(AUR). If you must have it you can modify the package build and re-install.

You might try
sudo pacman -Sy manjaro-browser-settings
to reinstall it and that might fix the database.



We don’t support anymore. Use firefox as it is fine now with most of the themes. Else use palemoon.


The graphical environment doesn’t load after update, Linux4.9, gnome. The systemd-modules-load.service fails to load. Anyone encountered this?


Thanks for the tip.
I continue to use firefox gtk2 via markzz’s repo (i prefer it because of the behaviour of scrolling).

The file is indeed in firefox gtk2, that’s the reason why i had this message…



Problem with wifi - no network connection
I’m running xfce


This might be the problem; when I query my nvidia package I get:

(.venv) ➜ ~ pacman -Q linux49-nvidia
linux49-nvidia 1:375.39-13

There is no update that gives me -14:

(.venv) ➜ ~ sudo pacman -Syu
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…

Packages (5) lib32-mesa-17.0.4-1 linux44-4.4.63-1 linux44-headers-4.4.63-1 linux49-4.9.24-1


2 posts were split to a new topic: Cannot update on Manjaro Openbox 0.8.6 install - elogind, pm-utils, systemd


I did the latest update today and included linux49 and it now works



xfce stable 4.9.24-1: no more internet connection, networkmanager says ‘no network interface available’. I’m on cable so no wlan-stuff.

I noticed a failed module on boot (see pictures)

€2: kept on digging:


Switch to a more current server like Netzspielplatz from Germany.


Sorry, I can’t seem to locate where I need to change the settings in XFCE.


Try Menu > settings > mouse and touchpad > theme


Please post issue in forum with XFCE tag and XFCE (ab)user may/should help. :slight_smile:

I stopped using XFCE a long time ago(years!) so do not know what file needs to be changed these days or the XFCE tool to do it auto-magically. ( Most likely the ~/.gtkrc if that still exists … or ~/.config/gtkrc if present on XFCE …or ??? )

FWIW, I like the change of cursors as it tells me what programs are using GTK2 or GTK3 UI on my KDE/plasma or LXQt DE, ;).


Thank you! The newest update fixed things for me. Happy belated birthday!


I sidestepped this problem by removing Virtualbox, but the network problem persists, so Virtualbox wasn’t the cause. I’m kinda out of ideas…

edit: Solved by uninstalling the driver in manjaro settings manager