[Stable Update] 2017-04-15 - Kernels, Thunderbird, Firefox, Libreoffice

update
stable

#101

Don’t think so:

james@xena:~/Documents$ pacman -Qs openrc
local/manjaro-system 20170406-5 (base)
    Manjaro Linux System - Update script
james@xena:~/Documents$

#102

Good evening guys,

I noticed some weird bug since last update. Nitrogen does not list any new images added to any of my wallpaper folders at all. I tried various fixes, created a new folder and tried adding there the images, running it as root, even moving the images directly to /usr/share/backgrounds but no change at all.

Does anybody else have the same problem? (everything was running 100% smoothly before the update)

I’m using Manjaro i3-community edition.

EDIT: Nevermind, I removed the package and re-installed it and everything runs smoothly now.


#103

kernel 4.10.10 seems to have problem with bluetooth after wakeup from sleep. It doesn’t even try to redetect bluetooth adapters after rfkill block bluetooth followed by rfkill unblock bluetooth. I don’t even see the familiar USB device disconnected message after rfkill block bluetooth (mine is connected via USB internally).


#104

If you use XFCE ,KDE or something similar, remove pm-utils first. After that, you can upgrade your system.


#105

Thanks,
I guess that is one drawback of rolling releases – a slow accumulation of debris. I don’t think this box has been fully re-installed since it was converted to Manjaro only a few weeks after the first public release.


#106

update went well with the exception of one thing;
when i rebooted my laptop, i noticed the login screen showed up on the wrong monitor. i use my 32 inch tv screen as my default screen via hdmi. after researching i found this:


the last entry in this thread fixed it. i used nvidia x server settings generated config file to copy a new nvidia.config file in /etc/X11/mhwd.d. i don’t know if this was the proper way of doing it nor do i know why it happened, but the login screen now appears on the 32 inch which is what i want. i rebooted 2 more times to make sure it wasn’t a coincidence and login screen shows up on my chosen default monitor.
i worry however what will happen if i unplug the hdmi and use the laptop screen only…so im not sure if this was the right fix. but it works for now


#107

Hi everybody,

I noted some visual artefacts in Thunderbird.

There are some thick grey lines around the recipient lines and the resize handle looks a bit strange due to wrong colors. I remember we had this effect some weeks ago but it was fixed with a later update again.

Do I need to do anything? Used theme is Greybird (AUR).

Thanks!


#108

A late “Happy Birthday” to you @philm from me too!

I get similar “Could not satisfy dependencies” errors about systemd on an old Samsung NF-310 netbook running Manjaro.XFCE, even after removing all orphaned packages.
Indeed pm-utils 1.4.1-7 is still installed, but as a dependency of samsung-tools 2.3.1-1. This samsung-tools package makes all the proprietary hardware (extra keys, fan control, …) functional.

Any chance to run the update and keep samsung-tools?


#109

kde plasma / xps9550 / smooth update


#110

The IgnorePkg option in pacman.conf could you consider to use. With that option ignore elogind, since elogind replaces pm-utils. But this is more a dirty hack than a solution.


#111

I would uninstall the Samsung stuff do the update try to reinstall Samsung if it doesn’t work raise a bug with the maintainer.


#112

I have this exact same issue, it seems the update thinks I have Openrc installed??? As far as I know I am running systemd, very confused at this point.

Update found the solution already posted
https://forum.manjaro.org/t/stable-update-2017-04-15-kernels-thunderbird-firefox-libreoffice/21784/26?u=anika200

Update 2: update broke my spideroak install see thread here


#113

Happy Birthday!! Philip sir

Thanks for the updates. Really appreciate your work.


#114

Seems OpenRC systems have some issues. Would be great to collect them and report them here.


#115

Hi @philm and happy birthday for many many more years. :slight_smile: and thanks for your great job with Manjaro.

In my case, the problem is with update process itself, i need remove one package, add other, run the update process and add elogind to the boot, and all manually. post 95

The other issue is in the program that generate the vmware kernel modules, vmconfig, that cause a segfault in the new kernels and VMware don’t work. post 99


#116

Smooth update here, great again!

P.S.: after the latest update, pamac-daemon service is active ati login in background, ist this normal? How I can disable this feature (if it’s possible do it)?


#117

On a Mate system is it okay to remove pm-utils?


#118

Yes, it should be safe.


#119

Belated Happy Birthday. Update smooth as usual. thanks


#120

I had the same issue, removing pm-utils resolved it