[Stable Update] 2017-04-15 - Kernels, Thunderbird, Firefox, Libreoffice

update
stable

#81

100 issue free and 100th is mnie.

beep beep !

Happy Bday mate!


#82
System:    Host: manjaro Kernel: 4.10.10-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.9.4
           Distro: Manjaro Linux
Machine:   Device: desktop System: Dell product: Inspiron 560 v: 00
           Mobo: Dell model: 018D1Y v: A00 BIOS: Dell v: A06 date: 12/01/2010
CPU:       Dual core Pentium E5500 (-MCP-) cache: 2048 KB 
           clock speeds: max: 2803 MHz 1: 1203 MHz 2: 2803 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 310]
           Display Server: X.Org 1.19.3 driver: nvidia Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce 310/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.101
Audio:     Card-1 NVIDIA High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.10-1-MANJARO
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8168
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2000.4GB (32.4% used)
           ID-1: /dev/sda model: WDC_WD1001FAES size: 1000.2GB
           ID-2: /dev/sdb model: WDC_WD10EAVS size: 1000.2GB
Partition: ID-1: / size: 48G used: 14G (31%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A gpu: 53C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 139 Uptime: 40 min Memory: 1579.0/3955.5MB Client: Shell (bash) inxi: 2.3.8

All good here,

Thanks


#83

Happy Birthday @philm :slight_smile:
Thank you.


#84

I had the same problems as you, could not shut down, and after reboot, sound did not work and regular user could not activate network. I had to also run
sudo rc-update add elogind default

After another reboot, sound and network works again, and shutdown options are no longer greyed out.


#85

Happy birthday :champagne:


#86

Hi there, Thank you for all the great job done in MANJARO

I have one issue: I can not connect to wifi network as a normal user, I get this message:

nm-applet: Connection activation failed: Not authorized to control networking 

So I tried sudo nmtui and it is woking. I think the problem is with networkmanger permission and it arises because the removal of consolekit, polkit-consolekit and networkmanger-consolekit. There is a number of OLD (2010 ~2012) bugs about NetwotkManager permission and all of them suggest solutions using polkit and consolekit (which were replaced during the update).
I verified that the current user is part of network group. I failed to use the tried the following

$ groups
disk lp wheel network video audio optical storage scanner input power users

I added dbus-launch to my slim.conf:

login_cmd           exec dbus-launch /bin/bash -login ~/.xinitrc %session

I changed deny to allow in /etc/dbus-1/system.d/org.freedesktop.NetworkManager.Manjaro.conf:

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy group="network">
                <allow own="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Settings"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.AgentManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="SetLogging"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="Sleep"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="sleep"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="wake"/>
        </policy>
</busconfig>

Here is nmcli gen perm output:

PERMISSION                                                 VALUE 
org.freedesktop.NetworkManager.enable-disable-network      no    
org.freedesktop.NetworkManager.enable-disable-wifi         no    
org.freedesktop.NetworkManager.enable-disable-wwan         no    
org.freedesktop.NetworkManager.enable-disable-wimax        no    
org.freedesktop.NetworkManager.sleep-wake                  no    
org.freedesktop.NetworkManager.network-control             auth  
org.freedesktop.NetworkManager.wifi.share.protected        no    
org.freedesktop.NetworkManager.wifi.share.open             no    
org.freedesktop.NetworkManager.settings.modify.system      auth  
org.freedesktop.NetworkManager.settings.modify.own         auth  
org.freedesktop.NetworkManager.settings.modify.hostname    auth  
org.freedesktop.NetworkManager.settings.modify.global-dns  auth  
org.freedesktop.NetworkManager.reload                      auth  
org.freedesktop.NetworkManager.checkpoint-rollback         auth  
org.freedesktop.NetworkManager.enable-disable-statistics   no  

and still I cannot connect to my wifi as a normal user ! Any suggestions

Other info

DM: slim WM: i3 with gaps uname -a: Linux sxX 4.4.61-1-MANJARO #1 SMP PREEMPT Wed Apr 12 20:39:45 UTC 2017 x86_64 GNU/Linux openrc -V: openrc (OpenRC) 0.24.2 (Manjaro Linux)

~/.xinitrc

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then

    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then

    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

# sart udiskie
udiskie --no-automount --no-notify --tray --use-udisks2 &

# .Xresources
[[ -f ~/.Xresources ]] && xrdb -merge -I$HOME ~/.Xresources

# fonts
xset +fp /usr/share/fonts/local
xset fp rehash

# sessions: DE and WM
session=${1:-i3}
case $session in
	i3|i3wm		) exec i3;;
	*) exec $1;;
esac

rc-status output:

Runlevel: default
 dbus                                                              [  started  ]
 NetworkManager                                                    [  started  ]
 syslog-ng                                                         [  started  ]
 acpid                                                             [  started  ]
 sshd                                                              [  stopped  ]
 netmount                                                          [  started  ]
 xdm                                                               [ starting  ]
 alsasound                                                         [  stopped  ]
 cupsd                                                             [  stopped  ]
 ccpd                                                              [  stopped  ]
 cronie                                                            [  stopped  ]
 ntpd                                                              [  stopped  ]
 local                                                             [  stopped  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 modules-load                                                      [  started  ]
 xdm-setup                                                         [  started  ]
Dynamic Runlevel: manual

inxi -F output:

System:    Host: sxX Kernel: 4.4.61-1-MANJARO x86_64 (64 bit) Desktop: i3 4.13-non-git Distro: Manjaro Linux
Machine:   Device: laptop System: ASUSTeK product: K50IE v: 1.0
           Mobo: ASUSTeK model: K50IE v: 1.0 BIOS: American Megatrends v: 207 date: 01/12/2010
Battery    BAT0: charge: 43.5 Wh 99.3% condition: 43.8/48.4 Wh (90%)
CPU:       Dual core Pentium T4400 (-MCP-) cache: 1024 KB 
           clock speeds: max: 2200 MHz 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: NVIDIA GT218M [GeForce 310M]
           Display Server: X.Org 1.19.3 driver: nouveau Resolution: 1366x768@60.00hz
           GLX Renderer: Gallium 0.4 on NVA8 GLX Version: 3.0 Mesa 17.0.3
Audio:     Card-1 NVIDIA MCP79 High Definition Audio driver: snd_hda_intel Sound: ALSA v: k4.4.61-1-MANJARO
           Card-2 NVIDIA High Definition Audio Controller driver: snd_hda_intel
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8168
           IF: enp3s0 state: down mac: 48:5b:39:07:c6:e2
           Card-2: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k
           IF: wlp4s0 state: up mac: a6:5f:32:dd:59:42
Drives:    HDD Total Size: 164.1GB (47.9% used)
           ID-1: /dev/sda model: Hitachi_HTS54251 size: 160.0GB
           ID-2: USB /dev/sdb model: USB_Flash_Drive size: 4.0GB
Partition: ID-1: / size: 69G used: 21G (32%) fs: ext4 dev: /dev/sda4
           ID-2: /boot size: 488M used: 39M (9%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 4.72GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 76.0C mobo: N/A gpu: 67.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 172 Uptime: 9:39 Memory: 794.7/3956.3MB Client: Shell (bash) inxi: 2.3.8 

#87

Happy birthday, Manjaro Daddy! Everything good with 4 systems here. :stuck_out_tongue_winking_eye:


#88

Happy Birthday @philm !
I am new here and first I would like to thank you and the community for awesome work. I love Manjaro so far!
I had an issue with this update, wine 2.6-1 caused some graphic bugs in Torchlight, so I installed 2.4-1 instead (2.5-1 is also good, I had it before the update). I will probably post to wine Bugzilla if it is not yet posted


#89

Getting issues running anything through bumblebee after the update.

The error I see:
primus: fatal: bumblebee daemon reported: error: could not load GPU driver

When I try to restart the bumblebeed.service, I get a failure.


#90

Working fine here


#91

Are you using Open- rc? If so use sudo rc- update add elogind default and reboot.


#92

Thank you @kb41 that solved my issue… :grin:


#93

thank you @kb41 that solved my issue :grin: :penguin:


#94

Update on 12 Systems without Problems.

DK3


#95

Hi @kb41

I use open-rc and your answer solve my problem: after the update i can’t shutdown the system, now it’s work correctly.

I need to run this commands for update work.

  • Before update:

sudo pacman -Rdd light-locker-consolekit
sudo pacman -S networkmanager

  • Update

sudo pacman -Syu

Answer “yes” to all questions about add/remove packages

  • After update:

sudo rc-update add elogind default
pacdiff


Updating (Stable, 4-15-17)
#96

same here, maybe I’m a bit tired but I only saw Lightfirefox and no standard firefox update…


#97

Taking the default options is a non starter:

sudo pacman -Syyuu
:: Synchronising package databases...
core                               138.1 KiB   609K/s 00:00 [################################] 100%
extra                             1783.6 KiB  2036K/s 00:01 [################################] 100%
community                            4.1 MiB  1924K/s 00:02 [################################] 100%
multilib                           181.6 KiB  2.04M/s 00:00 [################################] 100%
:: Starting full system upgrade...
:: Replace pm-utils with community/elogind? [Y/n] 
resolving dependencies...
looking for conflicting packages...
:: elogind and systemd-sysvcompat are in conflict. Remove systemd-sysvcompat? [y/N] y
:: dbus-elogind and dbus are in conflict (libdbus). Remove dbus? [y/N] y
:: polkit-elogind and polkit are in conflict. Remove polkit? [y/N] y
:: libeudev and libsystemd are in conflict (libudev.so). Remove libsystemd? [y/N] y
:: eudev and systemd are in conflict (udev). Remove systemd? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: device-mapper: requires systemd
:: lvm2: requires systemd
:: accountsservice: removing systemd breaks dependency 'systemd'
:: bluez-utils: removing systemd breaks dependency 'systemd'
:: ceph: removing libsystemd breaks dependency 'libsystemd'
:: colord: removing systemd breaks dependency 'systemd'
:: crda: removing systemd breaks dependency 'systemd'
:: cups: removing systemd breaks dependency 'systemd'
:: dhcpcd: removing libsystemd breaks dependency 'libsystemd'
:: entangle: removing libsystemd breaks dependency 'libsystemd'
:: lib32-systemd: removing systemd breaks dependency 'systemd'
:: libatasmart: removing libsystemd breaks dependency 'libsystemd'
:: libgudev: removing libsystemd breaks dependency 'libsystemd'
:: libinput: removing systemd breaks dependency 'systemd'
:: libmbim: removing systemd breaks dependency 'systemd'
:: libpulse: removing systemd breaks dependency 'systemd'
:: libusb: removing systemd breaks dependency 'systemd'
:: libwacom: removing systemd breaks dependency 'systemd'
:: mariadb: removing libsystemd breaks dependency 'libsystemd'
:: media-player-info: removing systemd breaks dependency 'systemd'
:: mkinitcpio: removing systemd breaks dependency 'systemd'
:: modemmanager: removing systemd breaks dependency 'systemd'
:: netctl: removing systemd breaks dependency 'systemd'
:: pcmciautils: removing systemd breaks dependency 'systemd'
:: plymouth: removing systemd breaks dependency 'systemd'
:: procps-ng: removing libsystemd breaks dependency 'libsystemd'
:: qtwebkit: removing systemd breaks dependency 'systemd'
:: rpcbind: removing libsystemd breaks dependency 'libsystemd'
:: rtkit: removing systemd breaks dependency 'systemd'
:: subversion: removing systemd breaks dependency 'systemd'
:: syslog-ng: removing systemd breaks dependency 'systemd'
:: udisks: removing systemd breaks dependency 'systemd'
:: udisks2: removing systemd breaks dependency 'systemd'
:: upower: removing systemd breaks dependency 'systemd'
:: util-linux: removing libsystemd breaks dependency 'libsystemd'
:: xdg-user-dirs: removing systemd breaks dependency 'systemd'
:: xf86-input-evdev: removing libsystemd breaks dependency 'libsystemd'
:: xf86-input-wacom: removing libsystemd breaks dependency 'libsystemd'
:: xf86-video-ati: removing libsystemd breaks dependency 'libsystemd'

It does update if I refuse the replacement of pm-utils, but not otherwise. I first tried the update yesterday, then left it till just now in case the mirror had not updated properly.


[Stable Update] 2017-05-12 - Kernels, KDE, KDE Apps, Gnome, Browsers
#98

Happy Birthday @philm
Everything OK with the update!

System: Host: ULIAK-2017 Kernel: 4.10.10-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.9.4
Distro: Manjaro Linux
Machine: Device: laptop System: ASUSTeK product: X551CA v: 1.0
Mobo: ASUSTeK model: X551CA v: 1.0 UEFI: American Megatrends v: X551CA.211 date: 06/04/2014
Battery BAT0: charge: 14.9 Wh 95.1% condition: 15.7/37.4 Wh (42%)
CPU: Dual core Intel Core i3-3217U (-HT-MCP-) cache: 3072 KB
clock speeds: max: 1800 MHz 1: 799 MHz 2: 799 MHz 3: 800 MHz 4: 799 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
Display Server: X.Org 1.19.3 driver: intel Resolution: 1366x768@59.99hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 17.0.3
Audio: Card Intel 7 Series/C216 Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.10.10-1-MANJARO
Network: Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
IF: wlp2s0 state: up mac: 40:f0:2f:9f:1a:04
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
IF: enp3s0f2 state: down mac: e0:3f:49:30:11:ea
Drives: HDD Total Size: 500.1GB (22.4% used)
ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
ID-2: /dev/mmcblk0 model: N/A size: 31.1GB
Partition: ID-1: / size: 15G used: 9.9G (72%) fs: ext4 dev: /dev/sda3
ID-2: /home size: 428G used: 88G (22%) fs: ext4 dev: /dev/sda4
ID-3: /var size: 9.8G used: 1.3G (14%) fs: ext4 dev: /dev/sda5
ID-4: swap-1 size: 6.44GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 62.0C mobo: N/A
Fan Speeds (in rpm): cpu: 2400
Info: Processes: 192 Uptime: 12 min Memory: 1520.6/3842.2MB Client: Shell (bash) inxi: 2.3.8


#99

I update my physical machine with VMware installed and now the VMware don’t start, the process to update modules don’t work. I try in terminal with sudo and root but nothing.

I looking for in the everything.log and appear a message of segfault for any time that i exec vmware-modconfg:

Apr 16 16:13:21 manjaro kernel: vmware-modconfi[2973]: segfault at 3680 ip 0000000000003680 sp 00007ffe2e917c08 error 14 in appLoader[55abde0fe000+ad000]

I use lats kernel 4.10, also test kernels 4.9 and 4.4 with the same result.


#100

Are you using Open-rc?