[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox



Thanks mate,
you just save my day :slight_smile:
Really appreciate it…


So far so good on 4 out of 6 machines updated with no issues. I’ll get the last 2 when I go to work tomorrow


Ya it’s the first time I used realtek, the rest of the laptop is great except for that, so no big deal, I’ll just swap the card out.
The realtek ethernet works good at least
When ever I get a new laptop in the future, I’ll just make sure I have another wireless card laying around just in case it has realtek, I won’t even test it, I’ll just swap it out right away and avoid any headaches

EDIT: swapped the card today for an intel 5300 wireless and it worked right away, no more issues with the wireless now, I got two antennas hooked up, no need for the third one, it just works :smile:


Just got home after a long weekend, presented with the libglvnd mesa stack in stable and a new plasma update. Nice. Update went smooth, no issues here. Thanks.

After reading the announcement thread OP I honestly thought there would be more issues given the scope of this update, no issues would be better of course, but unstable and testing repos have proven to be very valuable throughout the transition to libglvnd.


No issues on the upgrade for me. Zenbook UX303L.

Thank you!


Manjaro Cinnamon community edition - bluetooth device manager is missing.



Do you receive any messages in your logs with errors using the 4.10 kernel and NVIDIA? I’m just curious because I’m stuck at 4.9 currently and waiting for NVIDIA to address some of the bugs.


[quote=“philm, post:1, topic:20843”]
Also it is possible to start fresh with Manjaro v17.0.1 release, which includes this update.
[/quote]Servers are/must-be currently slammed & DLD rate is slow(<400kiBps). Prepare for long download or wait 'till Monday|Tuesday …for KDE at least.
I tried most USA, France, Bulgaria, … a couple of other mirrors from SourceForge: https://sourceforge.net/projects/manjarolinux/files/release/17.0.1/.

I figured I’d get it first & put on USB FD, then try the update cuz I cannot ascertain from the posts what is going to happen.

I surely do wish that DE, CPU, HDD and, especially, Graphics info were mandatory info provided so I could at least make a WAG.
Something like a modified screenfetch -n would be advantageous:

 OS: Manjaro 17.0 Gellivara
 Kernel: x86_64 Linux 4.10.4-1-MANJARO
 Resolution: 3840x2160
 DE: KDE 5.32.0 / Plasma 5.9.3
 WM: KWin
 CPU: Intel Xeon X5687 @ 16x 3.601GHz
 GPU: GeForce GTX 1060 6GB
 RAM: 3470MiB / 24104MiB

Oh well …


Updated xfce laptop this am. and desktop just now, from terminal sudo pacman -Syu.
All went well .
Thanks @philm and all the development team for your diligent and often thankless work .

Manjaro Stuck during boot[Solved]

I updated the 2 updates (archkeyring and manjaro-system) via pamac, but decided to hold off on further updates as I was not home. Of course my laptop only had a blank screen when I opened it back up. I was able to get terminal by adding a 3 to the boot options in grub. Just hit ‘E’ when the grub menu comes up and from there just add a space and the number 3 to the end of the long line of text. This will force it to boot directly to terminal. From there I fixed it with sudo pacman -Syyuu.


Good point I noticed this just now updating.

Excellent point! Please folks add some detail to your profile. When you have an issue a reader (wizard?) can see where you are coming from simply by clicking on your avatar. Just do it.

happy trails…


Same here, ran into the problems after I ran the update this morning after work…was unable to fix the issue so I will be reinstalling in the morning after work (hopefully) if I can get the download fast enough. I am not sure how I could have avoided this train wreck, hope it will be a very rare occurrence. :slight_smile:


After being unable to log into a console using Ctrl-Alt-F(2-6), I modififed the Grub to force it to a command prompt.

At Grub press “e” to enter Grub config. At the end of the line that starts with “linux” add a space and the number “3”. This will force booting to a command line. From there you can find the sequence to finish your update. Not sure how this works with UEFI.


Everything went fine with the update except grub did not detect my windows installation in /dev/sda1/ anymore(which is fixed using the command sudo update-grub).




On KDE, and still loving the hiccup-free system of yours.

thank you


I cannot start compton.


They fit. I rather think you have not finished the update and broke your system somehow. Since you’re able to chroot into your system, try to check if you can update some packages with sudo pacman -Syu. In the end you can issue sudo update-grub.


No nvidia related messages in my logs. (Message settings at warning or error.) I only get a couple of ACPI messages of a non-serious nature that a firmware update would presumably fix.


Tried chroot with earlier with only pacman -Syu.
Now, it’s showing error