[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox



update went fine so far.
Using XFCE on an asus laptop
Firefox right click still doesn’t work so good (no big deal for that one)
My rtl8821ae wireless actually works better now, so far no need of plugging in the ethernet yet.
I got a new card coming but I might not need it now :slight_smile:
I’ll keep it in case, realtek is usually a nightmare anyhow so I might swap it out anyhow for the intel one on it’s way just to be safe for future card issues with updates.

I haven’t tested everything but good so far

EDIT: My rtl8821ae wireless card still craps out, I’ll swap that out as soon as the new one gets here



it’s totally your bad luck man. this happened after a long time i can say that. i had troubles too. but a piece of advice don’t run every command gets thrown at you. i am no saying they are wrong, just your problem maybe different. I had to reinstall couple of times. Now, i try to understand the command and if crucial wait for a maintainers reply. We have been here. good luck.


Update on 12 Machines without Problems.



Oddly enough, I had no problems with pamac on this update, far less trouble than many are reporting in the posts using command line.
It did all the steps mentioned in the right order.

Of course I have a simple system with intel graphics.
4.9.20-1-MANJARO #1 SMP PREEMPT 64bit.
Plasma 5.9.4

Maybe I just got lucky. I’ve been lucky a long time. I’m coming up on my one year anniversary of using Manjaro, and most of that time on Pamac, and nothing but tiny issues except one Stable update that bit everybody.


Completely hosed my system, 64bit Deepin, AMD with NVidia.

Received a “kernel panic” error - A new one for me. Tried all of the suggestions above (keyring, mirror, run update, mhwd, etc) because initially I could get to tty, I could not get to a tty after running commands mentioned just another kernel panic error after reboot, but this time I can’t access anything. Rescue mode not even listed after 2nd reboot.

Currently deleting my partition and starting from scratch.


Same problem here, update went well, apart from annoying lag on touchpad.
Anyone else with this problem, or suggestions to fix. ??


No problems on Mate. All good.

Thanks to the Team!

Quad core Intel Core i5-4570
Kernel: 4.10.8-1-MANJARO x86_64
Cedar [Radeon HD 7350/8350 / R5 220]
Display Server: X.Org 1.19.3 driver: radeon
Desktop: MATE 1.18.0 (Gtk 3.22.10)


Probably not. Its just telling you where it stashed your old version in case you need it for some reason, and there is no indication you do need it.

Just read the /etc/pacman-mirrors.conf file, its 95% comments anyway. See if it looks reasonable, and stay with it.


[quote=“samriggs, post:125, topic:20843, full:true”]EDIT: My rtl8821ae wireless card still craps out, I’ll swap that out as soon as the new one gets here[/quote]Commits here mentions some kind of improvement expected in 4.11

In other news, I updated from pamac without problems


On my 32-bit Manjaro netbook edition, the GUI Update manager did not work. Using:

sudo pacman -Syyu

I got something similar. I copied and pasted into a shell script, edited:

rm /usr/lib/libEGL.so 
rm /usr/lib/libEGL.so.1 
rm /usr/lib/libEGL.so.1.0.0 
rm /usr/lib/libGL.so 
rm /usr/lib/libGL.so.1 
rm /usr/lib/libGLESv1_CM.so 
rm /usr/lib/libGLESv1_CM.so.1 
rm /usr/lib/libGLESv2.so 
rm /usr/lib/libGLESv2.so.2 
rm /usr/lib/libGLESv2.so.2.0.0 

marked it as executable, and the sudo ran it. I then re-ran:

sudo pacman -Syyu

re-booted, and all is well.

EDIT: After that experience, on my next laptop (HP, running 64-bit KDE), I did not try Octopi, but simply started with

sudo pacman -Syyu

And followed all its defaults, re-booted and all was well.

Edit-2: On my last laptop (T61, running 64-bit KDE), I did not try Octopi, but simply started with

sudo pacman -Syyu

And followed all its defaults, re-booted and noticed Chromium was missing from the kicker Application Launcher favorites, but it was easy to add it back.


Thanks for reply @jsamyth. I edited pacman-mirrors.conf and was it all with hash #
I edited it to custom then I used sudo pacman-mirrors -g. It’s works with terminal, but don’t gives choice mirrors in Pamac preferences. I still do everything in terminal, but maybe other users may need to select the mirror through the pamac preferences, Maybe other users should check it too?


Anyone faced issues with “failed to start light display manager”? I got this from running journalctl -p err -b -1. In mhwd -li i have just video-hybrid-intel-nouveau-bumblebee installed. I reinstalled it too when I saw this issue. I do have lightdm-gtk-greeter installed. Should I just reboot and see what happens? If i do sudo mhwd-gpu --setgl it says invalid argument setgl. If I do setxorg it does nothing.


Thanks mirh
I’m just getting tired of dealing with realtek, I have another card on the way to replace it with, hopefully intel wireless will play nicer.
Just a hassle installing it as I have to take the whole top off the asus laptop to get to it, but it should be alright as long as it works I’m happy.


So far, so good on two Plasma installs, one with an Nvidia card.

Just to be on the safe side, I went through the cli installing manjaro-keyring first, then manjaro-system, and finally pacman -Syyuu.

@samriggs I can sympathize. My previous laptop had Realtek wireless. I made absolutely sure my current one didn’t :yum:

Edit: Completed the third update at work flawlessly through the cli.


I have no idea what went wrong with this update,

Screen went black halfway through the updates, can’t boot to any kernel at all (perma black screen after trying to boot). Probably going to spend the whole night formatting and trying to figure out what went so wrong :confused:


Update went perfectly fine for me, but I’m slightly worried listening people had issues :dizzy_face: :dizzy_face: :dizzy_face: This is stable version so it should be stable for everyone. I’m new to Manjaro btw.


Got the UUIDs using DriveDroid.

But, which ones should I replace?
There are lot of fields. Most of them matches to current UUIDs.


There is always possibility that something may go wrong, with any linux.

More stuff you have installed and more hardware, (like double graphic card…) better chances… It can happen. for that reason:

  • wait with updates say one day to see what is going wrong and what are solutions
  • read first post, announcement. Sometimes there are special instructions about system update
  • have backup done before system update. Best is to just clone the whole disk with Clonezilla on separate disk. Before every update, just to be on a safe side.
  • learn in advance how to chroot into your system. Some day you may need this and it will help if you will already know the steps.


I came in the office in the morning and there was a notification on my Manjaro about the update.
There are two updates in the beginning: manjaro-system and arch-keyring if I am not mistaken.
And then I proceed the update.
While updating, I am opening Manjaro news and found a recommendation to update Manjaro via Pacman.
Then I stop the update and tried to open my terminal, but nothing happen.
The terminal is unable to open. I am using xfce-terminal.
Then I decided to reboot my laptop and it ended up with following screen…

I waited for about 20 minutes and nothing happen.
Any suggestion to address this issue is highly appreciate…

Kernel patch needed for Dell Precision 5520

Try it: