[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox

update
stable

#328

It is called “inxi”


#329

Manjaro team :-

I didn’t have any problem with using the GUI (pamac) upgrader, but I guess I was lucky, as I had no idea of the recomendation to use the CLI.

If there had been a problem, I would have walked straight into it, unknowingly.

Is there any way you can pop up a message/info/recomendation in pamac ?

That’s the only way most users are going to see such a warning - I would never have thought to go check this forum before an (all ?) updates.

I really would highly recomend adding that to pamac - the ability to display a message about the updates, before someone runs them.

It’s not that I would not use the CLI (I quite like it), but with Manjaro, I’m trying to stick more to the GUI way of doing things.


#330

It is like that, yes. https://www.kernel.org/pub/linux/kernel/projects/rt/4.4/
4.4.53_rt66 is the latest availble patch


#331

I just had the same problem as @sjh. I already tried different tips found in the forum like turning off the option "Lock screen when system is going for sleep" in Power Manager. In fact, that tip was the fix for the last time I had the same problem, but now it seems we will need another solution.


#332

I have got the same black screen problem, but everything’s up to date, no conflicts and the .pacnew are applied. Is there something else to do?

(I already read many posts but nothing helped)

more info there : Bumblebee black screen after 2017-04-02 stable update

thanks :slight_smile:


#333

failed with two “database https not found” messages. running pacman -U instead of -S, as per here fixed it.


#334

Having failure to boot on kernels 4.4 and 4.9. 4.1 still boots though. cant find root partition because can’t find uuid=XXX, but the uuid is correct. will open a separate thread.


#335

Is there any update on this? I have the same issue with speechd errors spamming in the syslogs.


#336

Nothing to do with manjaro, the calls are made by kde.
Remove the errors => install unecessary packages (flite & speechd)
Ignore the errors => wait for a proper implementation of accessibility functionalities from KDE

Edit: https://bbs.archlinux.org/viewtopic.php?id=223788


#337

KDE, smooth update but after reboot it stucked just after “…232” message, changing display driver did the trick, now it works.


#338

Updated using the recommendations (on a TTY) : no problem encountred. :wink:


#339

[OT]

[quote=“Beherit, post:335, topic:20843”]
Is there any update on this? I have the same issue with speechd errors spamming in the syslogs.
[/quote]None here.
Installing the flite program will help clean-up the journal. I.e.,
sudo pacman -Sy flite

There is, apparently, some interdependency between qt5-speech(“speechd”) and flite … the “optional” dependency

Optional Deps   : flite: flite TTS backend [installed]

seems to be non-optional.

I have not yet had the KDE programs complain about speechd or flite with the “Error loading text-to-speech plug-in” since installing flite.

On the flip-side, I have no idea how to easily remove all of that ‘my computer can listen and talk to me’ stuff safely.

[/OT]
{Edit
Spoke too soon. I had a reason to reboot and as KDE loaded got:

Apr 10 19:52:02 *** yakuake[1239]: Error loading text-to-speech plug-in "speechd"

The up side is that it’s the only app complaining …so far.

}


#340

Thanks guys, installing flite “fixed” it. Now I just wish there was a way to safely remove qt5-speech altogether as I never use it. :slight_smile:


#341

Hi,

I believe the recent libglvnd update broke my system. I’ve already posted about it here.

Just posting the link here too, so it will be listed in the links.

Summary: Single NVidia GPU MacbookPro (2009 Unibody model), libgl broke after libglvnd upgrade. Removing libglvnd works around, but of course does not fix the issue. Nouveau is not usable on this GPU. More details - such as inxi output - on the linked thread.

EDIT: The breakage was caused by LD_LIBRARY_PATH being set in my case. See the link above.


#342

Was really worried about this update but everything worked out alright, haven’t ran into any issues so far.


#343

[quote=“niandekuera, post:262, topic:20843, full:true”]“OpenGL GLX context is not using direct rendering, which may cause performance problems.” when running Steam.
Please help. I’m using Catalyst drivers.
Thanks.[/quote]Long story short [instead of using non-glvnd mesa] manjaro just override graphics libraries order.
Unfortunately steam ships with a dumb override that override the aforementioned one.

A quick and dirty solution would be to just remove the seventh line of the steam start script.
EDIT: this also explain why actual games were working fine then; they have no such interfering thing.


#344

Woks all fine here. KDE installation.


#345
$ compton
glx_init(): No GLX extension.

I had this before as well but a reboot usually fixed it.

$ sudo mhwd-gpu --check
xorg configuration symlink valid...

I’m running on mesa (Ivy Bridge GPU) and (sometimes) use optirun to enable Nvidia Gx 650m

System:    Kernel: 4.9.20-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
           Desktop: LXDE (Openbox 3.6.1) Distro: Manjaro Linux
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK107M [GeForce GT 650M] bus-ID: 01:00.0
           Display Server: X.Org 1.19.3 driver: intel Resolution: 1920x1080@60.00hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A

EDIT: new update fixed it


#346

Update went okay apart from http/https links in Thunderbird no longer work.

Attempting to sort this out.


#347

You’re right there…
It is still a pain this Update. Have a useless PC since this Update, since the Mesa Part broke every use of a Nvidia Compatible Graphics Driver. This is far from Stable Version, more like a Pre-Alpha.
And since no one in the Community who could help wants to help…
But 1 Month without any Bugfix, for the Users who are really hard hit by this Update, thats really long for a Linux System. Useless PC for as long as Manjaro exists…