[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox

update
stable

#308

Nope, no desktop effects working with any of the OpenGL backend, only XRender works.


#309

I just retested the upgrade process on one of my systems: now it works flawlessly.


#310

I have the same problem with effects and everything looks fine:

[mochobb@mocho-desktop ~]$ glxinfo | grep Open
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD REDWOOD (DRM 2.43.0 / 4.4.59-1-MANJARO, LLVM 3.9.1)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.0.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.0.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.0.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
[mochobb@mocho-desktop ~]$ glxinfo32 | grep Open
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD REDWOOD (DRM 2.43.0 / 4.4.59-1-MANJARO, LLVM 3.9.1)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.0.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.0.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.0.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

#311

Use qdbus org.kde.KWin /KWin supportInformation to get detailed info.
Might be worth checking if your ~/.config/kwinrc somehow changed to egl instead of glx.


#312

Any error messages being logged?


#313

My system still does not work.

On resume from “Suspend to RAM” both the keyboard & mouse stop responding within a few seconds. Monitor works OK, but only option is to turn off the power.

Anyone have any ideas how to fix it.

Thanks.


#314

AHA!

KWin Support Information:
The following information should be used when requesting support on e.g. http://forum.kde.org.
It provides information about the currently running instance, which options are used,
what OpenGL driver and which effects are running.
Please post the information provided underneath this introductory text to a paste bin service
like http://paste.kde.org instead of pasting into support threads.

==========================

Version
=======
KWin version: 5.9.4
Qt Version: 5.8.0
Qt compile version: 5.8.0
XCB compile version: 1.12

Operation Mode: X11 only

Build Options
=============
KWIN_BUILD_DECORATIONS: yes
KWIN_BUILD_TABBOX: yes
KWIN_BUILD_ACTIVITIES: yes
HAVE_INPUT: yes
HAVE_DRM: yes
HAVE_GBM: yes
HAVE_X11_XCB: yes
HAVE_EPOXY_GLX: yes
HAVE_WAYLAND_EGL: yes

X11
===
Vendor: The X.Org Foundation
Vendor Release: 11903000
Protocol Version/Revision: 11/0
SHAPE: yes; Version: 0x11
RANDR: yes; Version: 0x14
DAMAGE: yes; Version: 0x11
Composite: yes; Version: 0x4
RENDER: yes; Version: 0xb
XFIXES: yes; Version: 0x50
SYNC: yes; Version: 0x31
GLX: yes; Version: 0x0

Decoration
==========
Plugin: org.kde.breeze
Theme: 
Blur: 0
onAllDesktopsAvailable: false
alphaChannelSupported: false
closeOnDoubleClickOnMenu: false
decorationButtonsLeft: 0, 2
decorationButtonsRight: 6, 3, 4, 5
borderSize: 3
gridUnit: 10
font: Noto Sans,10,-1,5,50,0,0,0,0,0
smallSpacing: 2
largeSpacing: 10

Options
=======
focusPolicy: 0
nextFocusPrefersMouse: false
clickRaise: true
autoRaise: false
autoRaiseInterval: 0
delayFocusInterval: 0
shadeHover: false
shadeHoverInterval: 250
separateScreenFocus: false
placement: 4
focusPolicyIsReasonable: true
borderSnapZone: 10
windowSnapZone: 10
centerSnapZone: 0
snapOnlyWhenOverlapping: false
rollOverDesktops: true
focusStealingPreventionLevel: 1
legacyFullscreenSupport: false
operationTitlebarDblClick: 5000
operationMaxButtonLeftClick: 5000
operationMaxButtonMiddleClick: 5015
operationMaxButtonRightClick: 5014
commandActiveTitlebar1: 0
commandActiveTitlebar2: 30
commandActiveTitlebar3: 2
commandInactiveTitlebar1: 4
commandInactiveTitlebar2: 30
commandInactiveTitlebar3: 2
commandWindow1: 7
commandWindow2: 8
commandWindow3: 8
commandWindowWheel: 31
commandAll1: 10
commandAll2: 3
commandAll3: 14
keyCmdAllModKey: 16777251
showGeometryTip: false
condensedTitle: false
electricBorderMaximize: true
electricBorderTiling: true
electricBorderCornerRatio: 0.25
borderlessMaximizedWindows: false
killPingTimeout: 5000
hideUtilityWindowsForInactive: true
inactiveTabsSkipTaskbar: false
autogroupSimilarWindows: false
autogroupInForeground: true
compositingMode: 1
useCompositing: true
compositingInitialized: true
hiddenPreviews: 1
glSmoothScale: 1
xrenderSmoothScale: true
maxFpsInterval: 16666666
refreshRate: 0
vBlankTime: 6000000
glStrictBinding: true
glStrictBindingFollowsDriver: true
glCoreProfile: true
glPreferBufferSwap: 97
glPlatformInterface: 2
windowsBlockCompositing: false

Screen Edges
============
desktopSwitching: false
desktopSwitchingMovingClients: false
cursorPushBackDistance: 1x1
timeThreshold: 150
reActivateThreshold: 350
actionTopLeft: 0
actionTop: 0
actionTopRight: 0
actionRight: 0
actionBottomRight: 0
actionBottom: 0
actionBottomLeft: 0
actionLeft: 0

Screens
=======
Multi-Head: no
Active screen follows mouse:  no
Number of Screens: 1

Screen 0:
---------
Name: eDP1
Geometry: 0,0,1366x768
Refresh Rate: 60.0591


Compositing
===========
**Compositing is not active**

Again, you’re correct. I think I’ll need to relogin to see the changes in effect.
EDIT: It works again now, big thanks.


#315

Nope, that’s what I’m actually looking for.


#316

Good pickup

[Compositing]
AnimationSpeed=3
Backend=OpenGL
Enabled=true
GLColorCorrection=false
GLCore=true
GLPlatformInterface=glx
GLPreferBufferSwap=a
GLTextureFilter=2
HiddenPreviews=5
OpenGLIsUnsafe=false
WindowsBlockCompositing=true
XRenderSmoothScale=false

#317

For those who struggle with the update cause of mhwd here’s what I do to get around quickly:

sudo pacman -Rdd mhwd && sudo pacman -S mhwd
sudo pacman -Syyu

#318

Computer is doing fine, but the strangest thing happened. I did update with Pacli and after reboot I noticed a file in home dir called “e[Aq” and in it’s content was a PACMAN man page with fjucked up encoding. :smiley: what the heck? I don’t remember doing anything with manpages and the closest thing to pacman is updating the system…


#319

Seems to be some kind of temporary file.
I have seen such files on CentOS Servers running a Java stack too


#320

You nailed it! After changing the interface all is fine. Thanks. This can also explain some glitches I had when running Wine applications or VM’s (too soon to tell for sure). Until some months ago KDE let you choose between GLX and EGL. I tried EGL several times, but always ended up with GLX because of glitches. It seems they removed that option and silently changed the interface to EGL.

Thank you,


#321

All smooth here! Thanks again!


#322

This one was a chore for newbies for sure.

Never had a kernel panic error before, on the plus side reading these posts helped me learn to chroot and access my partition, which I never did before so thank you for the helpful posts. I have 2 partitions, 1 for Win 10 the other for Manjaro. Running Deepin 64 bit. AMD Phenom processor, 6 GB RAM
$ lsblk
$ mount /dev/sda3/ /mnt [My partition #]
$ manjaro-chroot /mnt
$ pacman -Syyu
$ reboot

First time, fstab error, restarted LiveCD followed the steps, second time an mtab error. Third time a charm and it worked. Did nothing to address the errors. Formatted my partition, installed Manjaro Deepin. Rebooted - - kernel panic !

Dug out my older 16.03 version of Deepin, rebooted to the LiveCD, installation of Manjaro was flawless, was going to then run my backup to restore programs, files, etc. using Timeshift and Deja Dup.

I had two updates showing one for Manajaro-Settings the other for Keyrings, I was not going to touch the Manajaro-Settings update so I unchecked it and just updated the keyring. After the keyring update, low-and-behold, there were 512 updates.

Being very leery, I updated them anyway, more or less just to see what would happen to my system, and after the updates, I rebooted my system and now am running Manjaro Deepin 17.0.1.

Didn’t think that would be possible since I unchecked Manjaro-Settings update which then triggers further updates, but hey, I’m not complaining :wink:


#323

Your advice did it for me, i’m very happy.


#324

No issues, however…and this may not be pallatable to some…the update should be done from a terminal, not the GUI.
Ctrl-Alt-F2…as someone suggested.
The best way to update is to use the terminal anyway :slight_smile:
Melissa


#325

Everything went ok on two machines (gnome and xfce). Thanks guys.


#326

deleted


#327

What did you use to get that system info dump???