[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox

update
stable

#267

Great, works.


#268

I also only see ‘Worldwide’ as a mirrors option in Pamac. I can configure the mirrorlist correctly with pacman-mirrors -c but that doesn’t change what Pamac is showing, namely “Worldwide”.

This is rather unsatisfying. If there is a GUI option to change a setting, it should work. If it isn’t supposed to work, remove it from the GUI.


#269

Had two problems after update on xfce:

  1. touchpad scrolling functionality on my touchpad wasn’t flawless anymore.
    solved this problem with downgrade libinput (to the older version 1.6.3-1)

  2. brightness Fn keys don’t work anymore yet. I’m going to search this forum to find a solution.
    The other Fn keys work fine.
    In addition: Very easy solution for this problem:
    I don’t know why, but the option handle display brightness keys in the Xfce Power Manager menu was disabled. After turning the radio button “on” everthing works fine.


[Solved] Problems with scrolling using touchpad after update
#270

Yes, it’s a know “issue” after the update of pacman-mirrors to v4.0:


#271

Thanks! I’ll wait for an update then :slight_smile:


#272

Thanks kai… :sweat:, I need to fix my system, so I bite the bullet and reinstall manjaro (with a long backup of home).
After reinstalling I see post #250 that says sudo pacman -Syyu fix the blank screen, sad that I read late.

I took pictures of the messages. I run your 4 lines suggested above:
lines 1 & 2 runs ok.
But next gives conflict packages and dependencies errors.
3) pacman -S lib-mesa:


4) pacman -Syu mhwd:

I leave it, maybe other have the same issue and can be helped.
Regards


#273

Hi,

I use wine for my windows apps.

When I try to update my system give me that errors

> pacman -Syu
> :: Synchronizing package databases...
>  core is up to date
>  extra is up to date
>  community is up to date
>  multilib is up to date
> :: Starting full system upgrade...
> :: Replace pacman-mirrorlist with core/pacman-mirrors? [Y/n] y
> resolving dependencies...
> looking for conflicting packages...
> error: failed to prepare transaction (could not satisfy dependencies)
> :: lib32-glu: installing mhwd (0.6.0rc1-4) breaks dependency 'lib32-libgl'
> :: lib32-primus: installing mhwd (0.6.0rc1-4) breaks dependency 'lib32-mesa-libgl'

After that the X server won’t work


#274

could you try

pacman -Sy libglvnd lib32-libglvnd

what happens in this case?


#275

In your case you have more package conflicts, maybe because I have intel gpu and you have nvidia. You should install a package that provides libgl dependency. So try what @Tids suggested.


#276

An update not suitable for cardiac. I had to interrupt the update. Unfortunately the boot did not do it correctly.

I was able to restart the update from a terminal using ctrl + alt+ f3 and ready, everything worked great.


#277

Thanks @Tids & @kainonergon .
@Tids, I’m running a reinstalled manjaro at this moment.
BTW, you suggestion looks like if mage pull a rabbit out of hat (magic) :smile: and as a child I wonder how he doit?

I’ll try to keep note of this “stable upgrade” and learn more about how this kind of issues occurs. I wonder how this conflicts occurs. Before this, I got some issues with the previous upgrade because of Plymouth (how was this installed some months ago?) each kernel upgrade lets me without a login screen and a kernel downgrade fix it, but… maybe, who knows, this was the reason of my troubles?

Finally just one question:
Is better/recommended to upgrade manjaro Always from a terminal+pacman (this was my choice most of the times), exists some way to receive upgrade notifications but disable octopi to do it? just in case my brain is in parking mode.
But octopi is my choice to install new applications because is very easy to use :relieved:.


#278

IMHO you should not install packages without updating the system. That can brake it any moment. So better to take time and find a way to update it properly than to waste time braking the system and reinstalling it again
EDIT. If you prefer to reinstall, use the latest iso that contains all updates


#279

CTRL+ALT+F2 to prevent problems.
Smooth update, no problems in 2 laptops


#280

Uninstall wine. (You won’t lose any of your windows applications or data). Probably have to use pacman in a console.
You can then reinstall after the fact.


#281

Looks like a good way out. Putting it in my ‘emergency recovery’ notes. :slight_smile:

But what is chmnt? Google doesn’t find any info about it.
Did you mean chroot? Or is it an alias you’ve set up?


#282

Manjaro has its own chroot tool

sudo manjaro-chroot /mnt

#283

Thanks for catching my typo! Post fixed.


#284

I’ve updated the first post to use TTY for this one.


#285

Updated 3 systems, all XFCE 64bit. A Dell 7440 laptop with no issues, a custom desktop with no issues.

However another desktop locked up during upgrade and totally froze (upgrading via pacman in terminal). Left for an 3hours and no progress so hard reset. System was then “screwed”, not booting past GRUB and no access to any tty, only black display, no cursor, nothing. Fixed by editing the GRUB boot options on the “Linux” line and simply adding a “3” after quiet. (No need for chrooting).

This then booted to a terminal and i was able to recover the system simply by install the upgrade again. This time no crashing and everything install fine. Rebooted and system is good again.

Not sure if it matters but the system is a Haswell i7 with Quadro k620 GPU.

Small issue but easily fixed. Thanks for all the hard work team. :slight_smile:


#287

Ok then… i updated with the new tips using TTY method and AFAIK, so far so good… very well to have avoided other complications; thank you for the effort. :slight_smile: