[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox

update
stable

#247

I don’t have this:

sudo pacman -R mhwd-tui

This gives me an error as “…removing mhwd breaks dependency ‘…’ I can’t pass from this point”

sudo pacman -S lib32-mesa
Answer yes to remove mhwd

Then If I try this:

sudo pacman -Syu mhwd

It says something related to other “…removing {something} breaks dependency’…’” I can’t remember.
I’m on a windows system right now, I’ll try again and post the errors. But I need to wait for the new KDE iso to download just in case.


#248

My main problem was being tired and not paying attention - I clicked to update via pamac with brain in neutral, and then thought it sensible to close down the other windows!

The manjaro-system and package-mirrors updates were ok, but it all went blank during large update of number of packages. no additional tasks were running by then. I left it for over half an hour before re-booting

Totally a user problem, should have left it until the morning and checked forum.

I have only needed to use chroot for grub repair couple of times in last 2 years, so was good learning experience. Takes a while with these old brain cells learning the exact commands, but knew where to find them (and almost none of the usual muttering of swear words needed!)


#249

In the communities that I participate there are many people with the system broken after the update. I did not have any problems. I used the command sudo pacman -Syyu to update.
I told everyone to report here in forum. :slight_smile:


#250

No problem here. I had to update the keyring manually beforehand

spiros@HOME:~$ uname -a
Linux HOME 4.9.20-1-MANJARO #1 SMP PREEMPT Fri Mar 31 17:49:34 UTC 2017 x86_64 GNU/Linux
spiros@HOME:~$ lsb_release -a
LSB Version: n/a
Distributor ID: ManjaroLinux
Description: Manjaro Linux
Release: 17.0.1
Codename: Gellivara
spiros@HOME:~$ screenfetch
spiros@HOME
OS: Manjaro 17.0.1 Gellivara
Kernel: x86_64 Linux 4.9.20-1-MANJARO
Uptime: 39m
Packages: 1914
Shell: bash
Resolution: 1920x1200
DE: XFCE4
WM: Xfwm4
WM Theme: Ambiance-XFCE-LXDE-Brown
GTK Theme: Greenbird [GTK2]
Icon Theme: Faenza-Green
Font: Sans 10
CPU: Intel Core i7 860 @ 8x 2.794GHz
GPU: GeForce GTS 250
RAM: 4228MiB / 16047MiB


#251

Thanks a lot mSx, I’ll give it a try.

Edit, got it working with info from your link…Cheers


#252

Also got a dark screen during update. So I re-imaged system partition with a working image and tried again. The second time it worked. My suspicion is Catalyst pkgs.

So, I reinstalled from ISO (USB stick) but this time accepted default options with NO non-free display driver.

Everything works. Performance is as good if not better than with Catalyst drivers on both an 10-year-old AMD64 and A6-6400K cpus.


#253

Hi:
The update succeeded.
During the update for GrUB, the only issue is GrUB could not read the superblock for the extended partitions:

4/3/17 8:58 PM	kernel	EXT4-fs (sde3): unable to read superblock
4/3/17 8:58 PM	kernel	EXT4-fs (sdf4): unable to read superblock

I.e., it is still not ignoring extended partitions.


These are the “Priority: Error” and “Priority: Critical” items in the log after the first boot @9:09 with the updates installed.

4/3/17 9:09 PM	/usr/bin/gpm	O0o.oops(): [daemon/old_main.c(58)]:
4/3/17 9:09 PM	/usr/bin/gpm	Could not open /dev/input/mice.

4/3/17 9:10 PM	yakuake	Error loading text-to-speech plug-in "speechd"
4/3/17 9:10 PM	kdeinit5	Error loading text-to-speech plug-in "flite"
4/3/17 9:10 PM	kwin_x11	Error loading text-to-speech plug-in "speechd"


4/3/17 9:10 PM	kernel	NVRM: Xid (PCI:0000:84:00): 31, Ch 00000028, engmask 00000101, intr 10000000

4/3/17 10:46 PM	dolphin	Error loading text-to-speech plug-in "speechd"

4/3/17 11:56 PM	ksystemlog	Error loading text-to-speech plug-in "flite"


pacman -Qo for speechd.so and flite.so

/usr/lib/qt/plugins/texttospeech/libqtexttospeech_speechd.so is owned by qt5-speech 5.8.0-2

/usr/lib/qt/plugins/texttospeech/libqttexttospeech_flite.so is owned by qt5-speech 5.8.0-2

SO there’s some issue with qt5-speech 5.8.0-2. I do not think this is new but it is not fixed in this update either, ;).
Maybe qt5-speech has a new path for plugins? I would not know since I, like 90% of the population, have no need for it and never use it.

I would remove it but qt5-speech:
Required By : knotifications ktextwidgets

It would be really nice if ARCH/MANJARO fixed it or the apps that are complaining about it.


The gpm error started with a previous Manjaro system update.

$>  systemctl status gpm
● gpm.service - Virtual console mouse server
   Loaded: loaded (/usr/lib/systemd/system/gpm.service; enabled; vendor preset: disabled)
   Active: inactive (dead) since Mon 2017-04-03 21:09:56 CDT; 3h 4min ago
  Process: 835 ExecStart=/usr/bin/gpm -m /dev/input/mice -t imps2 (code=exited, status=0/SUCCESS)

I have not found the cause. As reported before, it starts manually:

$>  systemctl start gpm
It's 00:16:02 CDT (UTC-0500) on Tue Apr 04.

$>  systemctl status gpm
● gpm.service - Virtual console mouse server
   Loaded: loaded (/usr/lib/systemd/system/gpm.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2017-04-04 00:16:02 CDT; 4s ago
  Process: 26567 ExecStart=/usr/bin/gpm -m /dev/input/mice -t imps2 (code=exited, status=0/SUCCESS)
 Main PID: 26568 (gpm)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/gpm.service
           └─26568 /usr/bin/gpm -m /dev/input/mice -t imps2
It's 00:16:07 CDT (UTC-0500) on Tue Apr 04.

I do not know what the nvidia kernel is complaining about as an “error” priority. The NVRM: ‘error’ is not gnu, :slight_smile:.


I was shocked that Manjaro took action that was not authorized or expected. The removal of all those symlinks without so much as a line of text stating it would be done is not good practice, to say the least. …smells like MICROSOFT.

Thank you for the updates.



OS: Manjaro 17.0 Gellivara;
CPU(s)~2 Quad core Intel Xeon X5687s (-HT-MCP-SMP-); Mem~2901.0/24104.9MB; HDD~4961.0GB(17.9% used); GPU: GeForce GTX 1060 6GB; Resolution: 3840x2160; GLX Version: 4.5.0 NVIDIA 375.39; Kernel~4.10.8-1-MANJARO x86_64; DE: KDE 5.32.0 / Plasma 5.9.4; WM: KWin; *.


#254

You don’t need that if mhwd-tui is not installed. When you will try agaun, read messages carefully and make sure you know their meaning.


#255

You can fix it like this with packages from our unstable branch:

sudo pacman -S https://repo.stdout.net/manjaro/pool/sync/blueberry-1.1.10-2-any.pkg.tar.xz https://repo.stdout.net/manjaro/pool/sync/bluez-tools-0.2.0-1-$(uname -m).pkg.tar.xz

#256

Same problem with the “black screen” here. Alt+F2 and sudo pacman -Syyu did the job. :wink:


#257

After updating the keyrings in the GUI, I remembered the update warnings, so I tried to open a terminal. When that failed, I reflexively rebooted, and ended up with the blank screen. With the posts here, I was able to update my system without re-installing. I used a liveUSB (xfce 17.0) and manjaro-chroot. After the updates and then rebooting back to my desktop, I still needed to update-grub to get windows back in the grub menu.

Thanks to all who helped solve the update issues.


#258

You can fix it like this with packages from our unstable branch:

sudo pacman -S https://repo.stdout.net/manjaro/pool/sync/blueberry-1.1.10-2-any.pkg.tar.xz https://repo.stdout.net/manjaro/pool/sync/bluez-tools-0.2.0-1-$(uname -m).pkg.tar.xz

Thx, did the trick for me :grinning:


#259

This update is, sorry to say this, really ■■■■■■ up.

On new installed 17.0 machines I get this:

Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: lib32-glu: das Installieren von mhwd (0.6.0rc1-4) löscht ein benötigtes Packet von 'lib32-libgl'

so the update didn’t work, and after a reboot, the greeter is broken and the users end up with a black screen and a blinking underscore.

Had to chroot in the installed machine, remove plymouth and the lightdm-greeter, installed gdm-greeter and the machine was again usable.

To solve the mhwd problem I had to remove it without dependencies and reinstall it again, after that the update went smoothly.

But for inexperienced users this update leaves them with a broken machine!


#260

I did misunderstand, sorry. And I am not exactly sure about how they handle things differently.


#261

We have 4 laptops running Manjaro.
The first showed the update with 2 packages and I updated and got stuck (like many users here). I decided to just re-install Manjaro because I had experimented with many packages on it, clean slate seemed reasonable.
Read the comments and problems in the forums.
Approached the other 3 laptops (2 mediacentres with Cinnamon and 1 other KDE laptop).
On all three pamac stopped at the two updates with errors, but opening a terminal and running pacman -SYu finished the install.
Last time I had a major problem with updates was the luks-encryption not working after kernel-upgrade from about a year ago (on one laptop I accidentally rebooted before installing some encryption-library then and had to chroot in to install it).

Overall: 2 years+ (since August 2014), 4 laptops (2 intensively used as mediacentres, 1 used as laptop intensively and one as laptop used occasionally).
Some glitches after updates that were easy to solve.
3 re-installs of OS by choice as an easy solution (do not store on the laptops but on the NAS and can re-install OS+tvheadend+kodi+get-iplayer and some other tools in about an hour).

I have had to break my promise to myself to manage the laptops using GUI-only a couple of times, nearly all of them related to solving glitches by copying command-lines from the forum. Some related to non-gui tools like get_iplayer.

I’d say that I have used the computers a lot more with the family and have had to spend significantly less time on solving problems than I would have to under Win. I would be reluctant to recommend Manajaro to beginners, though.

I have grown to really appreciate Manjaro as a distro.


#262

“OpenGL GLX context is not using direct rendering, which may cause performance problems.” when running Steam.
Please help. I’m using Catalyst drivers.
Thanks.


#263

This resolved my issue

ctrl+alt+F2
sudo pacman -Syyu


#264

@neognomic

As to the problem about symlinks, more information is in the forum:
[Xorg] MESA with libglvnd support.

AND, you really can’t compare Microsoft’s current flagship to a rolling release open source Linux distribution. The two have little in common with each other.:pensive:


#265

Only one problem with poor performance of touchpad. Solved by downgrading libinput. First problem after many months of smooth updates :slight_smile:

$ inxi -F
System:    Host: z710 Kernel: 4.10.8-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.9.4 Distro: Manjaro Linux
Machine:   Device: laptop System: LENOVO product: 20250 v: Lenovo Z710
           Mobo: LENOVO model: Durian 7A1 UEFI [Legacy]: LENOVO v: 7FCN90WW date: 11/28/2013
Battery    BAT0: charge: 18.5 Wh 99.9% condition: 18.5/37.5 Wh (49%)
CPU:       Dual core Intel Core i5-4200M (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 3100 MHz 1: 2663 MHz 2: 2300 MHz 3: 1907 MHz 4: 2679 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GK107M [GeForce GT 745M]
           Display Server: X.Org 1.19.3 driver: intel Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 17.0.2
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.8-1-MANJARO
Network:   Card-1: Intel Wireless 7260 driver: iwlwifi
           IF: wlp7s0 state: up mac: fc:f8:ae:4f:c2:1b
           Card-2: Qualcomm Atheros QCA8171 Gigabit Ethernet driver: alx
           IF: enp8s0 state: down mac: 0c:54:a5:13:d2:6d
Drives:    HDD Total Size: 240.1GB (65.5% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 240.1GB
Partition: ID-1: / size: 211G used: 147G (74%) fs: ext4 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 43.0C mobo: 43.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 190 Uptime: 11 min Memory: 1411.2/7912.3MB Client: Shell (zsh) inxi: 2.3.8

#266

The Update seems to have put me in a crash loop. That is the problem when I make any update or install something the graphics drivers of Bumblebee seem to fail completely and looks like part of the kernel also does. So I cannot get into a gui, but I can use tty1. When I reinstall like the link to the other thread:

1.I remove the graphics driver:
sudo mhwd -r pci video-hybrid-intel-nvidia-340xx-bumblebee
No errors here, so no problem.
2.I reinstall the drivers with:
sudo mhwd -a pci nonfree 0300
Again no problem. Works, but it installs video-hybrid-intel-nvidia-bumblebee instead of the 340xx Version. Any other version cannot get into the gui then. I get it half loaded and then it says "opengl 2.0 not found"
3.I use startx
With the default Nonfree driver, I can get into the gui now without a problem. Rebooting over the Gui without a problem. But with this driver the external monitors do not work.
When I now install any other driver via the mhwd tool in system settings or via mhwd from konsole Or just installing something else or Updating via Pacman. Everything seems to work at first, no errors while installing. But when I try to reboot, i can not do it via GUI. When I click on Shutdown or reboot nothing happens. But I can open other programs, so somehow the GUI seems to fail.
I can reboot via Konsole. But when I do that the GUI does not boot with the error:
Could not load Kernel Modules
I will make a photo of the errors and post a link to them in a moment. Without GUI I cannot make a proper screenshot, Sorry.

Here are some Photos from the exact Error Messages.

https://drive.google.com/folderview?id=0B9gU1Q_jM5LPcE9hQW9PYXQ5cGM1

When I run the command from the Error Message systemctl status systemd-modules-load.service, I get:

process: 560 ExecStart=/usr/lib/systemd/systemd->modules-load (code=exited, status=1/FAILURE)…

The Rest I have on one of the photos, too long for typing on a phone, without GUI.
But when I reinstall the Graphics Driver again, with the steps before and the cycle begins a new time. I reinstalled Manjaro 3 times now and I really don’t know what to do. But every Time the same problem. I also tried to use the new 17.0.1 Image. Same Crash Loop as before.

o work. Bumblebee has the great battery life while Nvidia Driver offered at least partially Multi Monitors, but crappy Battery Life. A Dream would be Bumblebee working properly and still be able to use External Monitors.

Does anyone has a similar Setup and knows how to get it to work? Or any Idea how?

I read the multi monitor Page on the Arch Wiki and 2 older sources where someone got it to work in Ubuntu before, but seems not to work anymore.

System:    Host: svenja-pc Kernel: 4.9.16-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
       Desktop: KDE Plasma 5.9.3 (Qt 5.8.0) Distro: Manjaro Linux

Machine: Device: laptop System: LENOVO product: 24476J7 v: ThinkPad W530
Mobo: LENOVO model: 24476J7
UEFI [Legacy]: LENOVO v: G5ET98WW (2.58 ) date: 04/01/2014
Battery BAT0: charge: 56.4 Wh 60.6% condition: 93.0/93.6 Wh (99%)
model: LGC 45N1011 status: Discharging
CPU: Quad core Intel Core i7-3740QM (-HT-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 21561
clock speeds: max: 3700 MHz 1: 1249 MHz 2: 1327 MHz 3: 1301 MHz 4: 1219 MHz
5: 1248 MHz 6: 1235 MHz 7: 1395 MHz 8: 1310 MHz
Graphics: Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
Card-2: NVIDIA GK107GLM [Quadro K2000M] bus-ID: 01:00.0
Display Server: X.Org 1.19.3 driver: intel Resolution: 1920x1080@60.00hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile
GLX Version: 3.0 Mesa 17.0.1 Direct Rendering: Yes
Audio: Card Intel 7 Series/C216 Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.9.16-1-MANJARO
Network: Card-1: Intel 82579LM Gigabit Network Connection
driver: e1000e v: 3.2.6-k port: 6080 bus-ID: 00:19.0
IF: enp0s25 state: down mac:
Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi bus-ID: 03:00.0
IF: wlp3s0 state: up mac:
Drives: HDD Total Size: 500.1GB (3.2% used)
ID-1: /dev/sda model: HGST_HTS725050A7 size: 500.1GB
Partition: ID-1: / size: 25G used: 8.3G (36%) fs: ext4 dev: /dev/sda5
ID-2: /home size: 122G used: 984M (1%) fs: ext4 dev: /dev/sda8
ID-3: /var size: 9.8G used: 1.7G (18%) fs: ext4 dev: /dev/sda9
ID-4: /boot size: 945M used: 47M (6%) fs: ext4 dev: /dev/sda7
ID-5: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
Sensors: System Temperatures: cpu: 45.0C mobo: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 212 Uptime: 7 min Memory: 895.6/7542.2MB
Init: systemd Gcc sys: 6.3.1 Client: Shell (bash 4.4.121) inxi: 2.3.8

Does anyone have any Idea?