[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox

update
stable

#186
   sh-4.4# mkinitcpio -k /boot/vmlinuz-4.10-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.10-x86_64.img
==> Starting build: 4.10.8-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [plymouth]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.10-x86_64.img
==> Image generation successful

#187

Correct typo /etc/mkinitcpio.conf
Other way is to reinstall kernel.


#188

Ha right sorry


#189

Thanks all. Finally, I was able to boot normally.


#190

Looks like we all independently came to the same conclusion, just in different threads :slight_smile: .

@Ank_S make sure you have more than one kernel installed, this way if the initramfs of one kernel is borked during an update you can boot into another.


#191

Update resulted in non-booting system (or, at least, not to the GUI of Manjaro KDE).
Tried everything found here in the forum, to no result.

I can login into TTY.
pacman -Syyu results in: “there is nothing to do”.

mhdw -li gives:
Installed PCI configs:
--------------------------------------------------------------------------------
NAME VERSION FREEDRIVER TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nouveau-bumblebee 2017.03.12 true PCI
video-hybrid-intel-nvidia-340xx-bumblebee 2017.03.12 false PCI

Warning: No installed USB configs!

inxi -G gives:

Graphics: Card-1:Intel Mobile 4 Series Integrated Graphics Controller
Card-2: NVIDIA G98M [GeForce 9300M GS]
Display Server: X.org 1.19.3 driver: intel tty size: 200x56  Advanced Data: N/A out of X

Also did the renaming of the .pacnew file(s) as suggested by @sueridgepipe To no avail.

Any hint and help would be much appreciated. Not a Linux geek here, please count me in as “noob”.

Also, on a side note, the laptop will not even boot into a live CD of 17.1 giving me - after a long repetition of “FAILED” messages - a popup saying “Cannot sync dbus environment”.


#192

tty login then check for error log messages

journal logs

journalctl -p err -b [-n]

where n is optional and represents the number of boot cycles to go back.

kernel log

dmesg

xorg logs

/var/log/xorg.0.log

Manjaro Live 17.1 contains the same mesa stack and libglnvd changes, maybe try an older Live image like 17.0 to boot into.


#193

Make sure the first mirror in /etc/pacman.d/mirrorlist is up to date - I had that after (for safty sake) I ran pacman -Syyu again after doing the upgrades that my mirrorlist was altered and netzspielplatz was moved down again - so I even had the message that my packets are newer


#194

This KDE install updated without issues (kernel 4.9.20).

I used -in view of the problems many reported- not octopi but switched to tty and did a sudo pacman -Syyu, accepting all suggested changes thereafter and from the tty used shutdown -r to reboot.

–> Everything seems fine.

Edit: System OK also after cold reboot.


#195

Yup, this update is really breaking linux on multiples points. I installed xfce 17.0, then synchronized repo, then decided to upgrade kernel first, so i installed kernel 4.10.8, which broke the system right away - not even terminal was able to launch, and it also removed windows from grub, so i just reinstalled manjaro again, and did full upgrade first, and then upgraded kernel, and now it works, but not for long i suspect.


#196

I checked those logs, but, tbh, they are like mandarin chinese for me. (Glad enough I managed to copy them to my other computer.) Perhaps you can have a quick look. Thanks in advance!

Output of journalctl -p err -b: https://pastebin.com/r4VMek4V
Output of dmesg: https://pastebin.com/Ps7PPPfH
Xorg.0.log: https://pastebin.com/QF5cqCh4


#197

I would say that is always the best way. Even use pacman -Syu packagename instead of just -S to make sure the system is up to date. One of important features of arch and arch based distros is that partial updates are not supported.


#198

I updated the list with pacman-mirrors. Still pacman tells me “there is nothing to do”, so I think, he is right:

##
## Manjaro Linux mirrorlist
## Generated on 03 April 2017 12:37
##
## Use pacman-mirrors to modify
##

## Country       : Germany
Server = ftp://ftp.tu-chemnitz.de/pub/linux/manjaro/stable/$repo/$arch

## Country       : Germany
Server = http://ftp.tu-chemnitz.de/pub/linux/manjaro/stable/$repo/$arch

## Country       : Germany
Server = http://mirror.ragenetwork.de/manjaro/stable/$repo/$arch

## Country       : Germany
Server = https://mirror.netcologne.de/manjaro/stable/$repo/$arch

#200

Problem following upgrade:

On resume from “Suspend to RAM” both the keyboard & mouse stop responding within a few seconds. Monitor works OK, but only option is to turn off the power.

Update was performed using:

   sudo pacman-mirrors -g -c United_Kingdom -b stable

and details from gefri:

  ctrl-alt-f2 -> root shell
  pacman -Sy manjaro-keyring
  pacman -S manjaro-system
  pacman -S lib32-mesa
  pacman -Syu mhwd

No problems were reported during the update.

System details:

Kernel 4.10.8-1-MANJARO
KDE Plasma 5.9.4
KDE Frameworks 5.32.0
Qt 5.8.0
(Only other s/w I’ve installed is Chromium)

Intel quad-core i5-2500K
16 GiB RAM (KVR1333D3N9/4G)
ASUS MoBo P8H67-M PRO (UEFI BIOS)
Logitech keyboard & mouse
Kingston SSD (SV300S37A120G) (system)
2x Seagate Barracuda HDDs (data)
Netgear Gigabit LAN card installed but using the onboard PCIe LAN
(No other special h/w installed)

I’ve also upgraded an AMD laptop, which seems to be OK so far.

Any thoughts?
sjh


#201

Why do you have both hybrid-intel-nouveau bumblebee and nvidia-340xxx drivers installed?

From your journal logs.

Apr 03 12:26:35 rom-vaio sddm-greeter[589]: Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, profile  QSurfaceFormat::OpenGLContextProfile(NoProfile))
Apr 03 12:26:35 rom-vaio systemd-coredump[626]: Process 589 (sddm-greeter) of user 995 dumped core.

Doesn’t look like GLX symlinks were created correctly.

sddm-greeter[589]: Failed to create OpenGL context

Leading to sddm segfault and coredump.

systemd-coredump[626]: Process 589 (sddm-greeter) of user 995 dumped core

What is the output of

ls -al /usr/lib | grep libGL

#202

Ok - tu-chemnitz.de is up to date for stable - was just guessing, to rule out that at least.


#203

I think the update was completed successfully, but attempting to access OpenGL libraries through xorg is causing sddm segfault.

What I don’t understand is hybrid-intel-nouveau driver installed alongside nvidia-340xx. I haven’t seen that, so don’t know if it is symptomatic of the error or not.


#204

Why do you have both hybrid-intel-nouveau bumblebee and nvidia-340xxx drivers installed?

Idk. I didn’t care about that because I knew there were two graphics adapters, so why not two drivers? (You see my “linux level” here.)

ANYHOW. Thank you very much. I uninstalled one of the drivers through mhwd and the system went up. You were right. Really appreciated!


#205

Well just updated my last two machines. On my work machine I updated from pacman everything well. It was slow but it worked I am going to update my mirrors to fix that issue. On my openrc lxqt machine I got the following error from pamac;
lib32qt4: installing mhwd breaks dependency lib32-libl I tried pacman and got the same thing then the laptop started acting odd. I couldn’t open anything so I rebooted and it got hung while booting. Rebooted again and used the advanced Grub options and add a 3 at the end of boot option to get to a terminal. I rna the following command to get rid of orphans pacman -Rns $(pacman -Qtdq)
Then I was to run pacman -Syu and do the update.Rebooted and everything was ok!


#206

Those other update notifications you saw on the forum are for the Unstable and Testing repos. You are on Stable.