[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox



Those other update notifications you saw on the forum are for the Unstable and Testing repos. You are on Stable.


I had to manually delete all .py and .pyc files in:

Only then did pacman allow me to update.


Blueberry is not longer working:

    Traceback (most recent call last):
  File "/usr/lib/blueberry/blueberry.py", line 35, in on_activate
  File "/usr/lib/blueberry/blueberry.py", line 154, in create_window
  File "/usr/lib/blueberry/blueberry.py", line 231, in get_default_adapter_name
    output = subprocess.check_output(["bt-adapter", "-i"]).strip()
  File "/usr/lib/python2.7/subprocess.py", line 212, in check_output
    process = Popen(stdout=PIPE, *popenargs, **kwargs)
  File "/usr/lib/python2.7/subprocess.py", line 390, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child
    raise child_exception
OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden


Hmmm, I wonder if that was a mistake?

Just thinking out loud here, but that kernel was from the same repository that had all the new stuff, and may have required or expected some of those packages.


I have problems with this upgrade…I have posted it in the forum, please provide me a solution.


Start reading around post number 42. It seems they solved the issue.

Strange dependency error for lib32-glu and mhwd?

try this


Well, it was first for me to have such bug, plus its not like i deleted 4.9, i just installed 4.10.8 via mhwd, and it even partially killed live session.

I see that linux is going to be user friendly very soon - any messy graphics or kernel update, and it kills your system, it kills ttys, grub update bug removes windows entry, and you are left with one hope - to have ready usb/dvd installation of linux/windows.


I got mount: error while loading shared libraries: libmount.so.1: cannot open shared object file: No such file or directory while booting and dropped into a rootfs shell where typing did not work.
I fixed that by booting in a Manjaro USB Stick and chrooted in my system. Then I did sudo pacman -S util-linux libutil-linux and mkinitcpio -P.


did “pacman -Syu”, everything seems to have gone well.
only thing is that i got:

Suche nach in Konflikt stehenden Paketen…
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: mesa wird vor seiner Abhängigkeit libglvnd installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: lib32-mesa wird vor seiner Abhängigkeit lib32-libglvnd installiert werden

figured as long as they are all installed it should be fine. trying reboot now xD
edit: no problems after reboot, glxinfo and glxinfo32 both look good :slight_smile:


Only one small problem, posted about it here -

Other things went really smooth.


I just updated this morning too. Everything froze after I closed the terminal. I did a hard reboot. Everything fine until I get the message "Cannot load (locate?) kdeinit5. I tried loading previous installs, but Manjaro will not load. Should I reinstall using the newest version?


Do you think the orphans were causing the problem, or just being careful?


Out of curiosity, why is Pacman recommend over Octopi for this update? What’s the functional difference?


Pacman is the actual package manager and Octopi is just a GUI for it. Sometimes the GUI options Pamac and Octopi just don’t manage to get it right because more detailed commands are necessary. Also pacman works from a command line, and when your system is graphically handicapped that is the only way to go.


Vmware workstation 12.5 refuses to start after this update, any ideas anyone, as I need this functionality urgently ?


A little bit of both.


I’m not sure I understand. Doesn’t Octopi just run “pacman -Syu”? How does it fall short of that?


Sure, but what if you want to run pacman -Syyu, or you want to remove multiple packages related to each other without doing so individually, what if attempting to do so breaks dependencies, if I remember correctly Octopi and Pamac wont let you do this. No work around, and most importantly how is Octopi going to work in a terminal? As noted most of the problems related to this update involve even a difficulty of getting a tty. Just a quick glance at https://wiki.archlinux.org/index.php/Pacman should make it obvious why using the cli might be better when troubleshooting not to mention what if your GUI package manager is the problem?


I had a problem because when the update manager notified me about an update (manjaro, keyring) I did it but then my mirror was not in sync so that the update manager complained about some conflicts and missing packages.

Because the first step of the update was done (removing some symlinks related to graphic stack) while the second part was not done, the system hang and I wasn’t able to log in because it continued to crash reloading the login manager (gnome - gdm).

Changed manually the mirror from TTY and then upgraded from pacman, once all updates were installed my system returned working again.

My second computer which was updated the next day had no issues, probably because the mirrors were up and synced at the time…

I think this is a common issues and is going to happen again, it would be good to implement some checkin into the update manager to make sure the mirror is synced before attempting an upgrade. Also I don’t understand why after the update my mirror list got replaced without running a new rank (pacman-mirrors), would be nice to have the original mirror preserved or some kind of hook to execute the ranking again.

Thanks :slight_smile: