[Stable Update] 2017-03-22 - Firefox, Kernels, Mate, LibreOffice, PHP

update
stable

#1

Hi community,

with this update we ship the latest Mate Desktop, Firefox, LibreOffice, Virtualbox, Xorg-Server and PHP. Marcus was working hard to add some packages without needing SystemD at all for OpenRC editions. He is currently enforcing the use of elogind. We also improved the AUR support in Pamac. Last but not least we updated again some of our kernels.

Please report any issues you may have with this update.

Kind regards,
Philip Müller and the Manjaro Development Team


Current supported Kernels

  • linux310 3.10.105
  • linux312 3.12.72
  • linux316 3.16.42
  • linux318 3.18.48 [EOL]
  • linux41 4.1.39
  • linux44 4.4.55
  • linux48 4.8.17 [EOL]
  • linux49 4.9.16
  • linux410 4.10.4
  • linux-RT-LTS 4.4.53_rt66
  • linux-RT 4.9.13_rt11

Package Updates (Mon Mar 20 07:00:06 CET 2017)

  • stable community i686: 235 new and 249 removed package(s)
  • stable community x86_64: 253 new and 268 removed package(s)
  • stable core i686: 25 new and 25 removed package(s)
  • stable core x86_64: 25 new and 25 removed package(s)
  • stable extra i686: 345 new and 340 removed package(s)
  • stable extra x86_64: 345 new and 340 removed package(s)
  • stable multilib x86_64: 2 new and 3 removed package(s)

A detailed list of all package changes can be found here.


Troubleshoot

If manjaro-system can’t handle the file conflict issue with ca-certificates-utils do the following:

# pacman -Syuw                           # download packages
# rm /etc/ssl/certs/ca-certificates.crt  # remove conflicting file
# pacman -Su                             # perform upgrade

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

Was wrong kernel update procedure fixed in this update ?

The bug is that after you install a new kernel via mhwd gui utility, then your windows installation will disappear from grub boot menu (if you had windows/linux dual boot in the first place), and manual launch of command “sudo update-grub” is needed for grub to find windows and add it to boot menu.


#3

I don’t know about this issue at all. update-grub will be called always when a kernel gets updated due hooks after the update got completed. Therefore it gets only called once and not multiple times per update.


#4

Thank you - worked perfectly well

[details=System details here] System: Host: XXXX Kernel: 4.10.3-1-MANJARO x86_64 (64 bit)
Desktop: Gnome 3.22.3 Distro: Manjaro Linux
Machine: Device: laptop System: LENOVO product: XXXXXX v: ThinkPad T450s
Mobo: LENOVO model: XXXXXX v: NO DPK
UEFI [Legacy]: LENOVO v: JBET63WW (1.27 ) date: 11/10/2016
Battery BAT0: charge: 16.6 Wh 100.2% condition: 16.6/23.2 Wh (71%)
BAT1: charge: 71.2 Wh 97.1% condition: 73.3/71.3 Wh (103%)
CPU: Dual core Intel Core i7-5600U (-HT-MCP-) cache: 4096 KB
clock speeds: max: 3200 MHz 1: 1800 MHz 2: 1840 MHz 3: 1800 MHz
4: 1800 MHz
Graphics: Card: Intel HD Graphics 5500
Display Server: X.Org 1.19.2 driver: N/A
Resolution: 1920x1080@60.02hz
GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
GLX Version: 3.0 Mesa 17.0.1
Audio: Card-1 Intel Wildcat Point-LP High Definition Audio Controller
driver: snd_hda_intel
Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.10.3-1-MANJARO
Network: Card-1: Intel Ethernet Connection (3) I218-LM driver: e1000e
IF: enp0s25 state: down mac: 50:7b:9d:7b:55:7d
Card-2: Intel Wireless 7265 driver: iwlwifi
IF: wlp3s0 state: up mac: 60:57:18:93:9a:b3
Drives: HDD Total Size: 500.1GB (36.9% used)
ID-1: /dev/sda model: Samsung_SSD_850 size: 500.1GB
Info: Processes: 203 Uptime: 1 day Memory: 1703.4/11739.6MB
Client: Shell (bash) inxi: 2.3.8[/details]
Now pacman also finds AUR packages again =D


#5

The /etc/mkinitcpio.d/<kernel>.preset files were replaced again.

I (re)moved the, 4me, absolutely useless fallback images and did sudo update-grub to fix the menu.

Updates/installation worked fine otherwise.
Pamac, since installing the certificate utils, still finds AUR items. …yaourt too.

The btrfs-scrub@.service and btrfs-scrub@timer still cannot be activated but have not rebooted the kernel yet. …perhaps afterwards, ;).
UPDATE: Not fixed; cannot start either, :frowning2:.

Thanks for the updates! :slight_smile:


#6

So now that you know about this bug, will you take a look ? I will give more info later today when i get home.


#7

I have the same issue as @babania2215


#8

I newly installed this machine and update without any issue.
I cant open AMD Catalyst Control Center I got this error on terminal (amdcccle) ==> amdcccle: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory
After installing “qt4” problem solved.

System: Host: onem-pc Kernel: 4.9.15-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Manjaro Linux
Machine: Device: desktop Mobo: Foxconn model: G31MXP/G31MXP-K v: FAB:1.0
BIOS: Phoenix v: 6.00 PG date: 04/23/2009
CPU: Dual core Intel Core2 Duo E8400 (-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 11990
clock speeds: max: 2997 MHz 1: 1998 MHz 2: 1998 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]
bus-ID: 01:00.0
Display Server: X.Org 1.17.4 driver: fglrx
Resolution: 1920x1080@60.00hz
GLX Renderer: AMD Radeon HD 5450
GLX Version: 4.5.13399 - CPC 15.201.1151 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]
driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Intel NM10/ICH7 Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.9.15-1-MANJARO
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8168 v: 8.043.02-NAPI port: ce00 bus-ID: 03:00.0
IF: enp3s0 state: down mac:
Card-2: Qualcomm Atheros AR9271 802.11n
driver: ath9k_htc usb-ID: 001-003
IF: wlp0s29f7u4 state: N/A mac: N/A
Drives: HDD Total Size: 120.0GB (38.1% used)
ID-1: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB
Partition: ID-1: / size: 103G used: 36G (37%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 7.53GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 40.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 138 Uptime: 18 min Memory: 908.8/3263.3MB
Init: systemd Gcc sys: 6.3.1
Client: Shell (bash 4.4.121) inxi: 2.3.8


#9

Also, my laptop was releasing strange loud sound every time i did restart/shutdown, the sound was like you would bump a microphone to the table, is this a new feature of manjaro ? I can only confirm that current ubuntu 17.04 build doesnt do this kind of stuff. Is this fixed in this update ?


#10

All good, KDE edition. Thanks


#11

I still have no AUR results in pamac after this update


#12

I also noticed this, both with the current and previous releses, regardless of the de. (I just ran update-grub and then kinda forgot about it).
This only happens when a new kernel is installled via MSM. The update-grub runs, but it seems that the os-prober is either not run or not correctly, because it wipes out all other grub entries. Once they are restored with running update-grub manually, updating of the given kernel works fine.


#13

Same here - unfortunately.


#14

Thanks, working great!!!


#15

I downloaded last day Manjaro-Xfce iso file and install today. There was an easy mount and unmount option in thunar for .iso files (especially for wine programs) but in this installation I cant figure out it. I install “AcetonISO” for iso files but old way was so quick and useable.


#16

Nope… Pamac ain’t finding s**t for me… yaourt now works.

EDIT: SOLVED

Okay… a short messing about later (since yaourt finally worked) … all you have to do to get AUR search working again, if it is still broken for you, in Pamac is to re-install…

  • ca-certificates
  • ca-certificates-cacert
  • ca-certificates-mozilla
  • ca-certificates-utils

I’m not entirely sure which of the four packages actually caused “AUR search” in Pamac to stop working, but after re-installing all four and re-starting Pamac it now finds packages in AUR again.

Peachy… I love fixing breakage totally not caused by myself…


#17

The update hasn’t shown up on any of my machines yet. I checked the US mirrors it looks like treir synced. Oh well I guess I wait until it comes through


#18

Hello.
Using the 4.9 kernel the Broadcom wifi card of my laptop stopped working after this update. Also I’ve noticed that bumblebee doesn’t turn off the discrete Nvidia card. I don’t have these problems with the 4.4 kernel.

update:
Nevermind, it turns out pamac didn’t installed all the updates the first time. Just updated the mirror list, installed all the updates and everything works fine now.


#19

I had the same problem with the previous update. Reinstalling the ca-certificates-utils package worked for me.


#20

In both this update and the last one I received an error in mkinitcpio that I have not been able to resolve. Luckily it has not had any effects that I can tell, but it is concerning. Here is relevant output from the error:

(2/9) Updating linux44 initcpios
==> Building image from preset: /etc/mkinitcpio.d/linux44.preset: ‘default’
-> -k /boot/vmlinuz-4.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.4-x86_64.img
==> Starting build: 4.4.55-1-MANJARO
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [autodetect]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
-> Running build hook: [encrypt]
==> ERROR: module not found: crc32' -> Running build hook: [lvm2] -> Running build hook: [plymouth] -> Running build hook: [filesystems] ==> Generating module dependencies ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.4-x86_64.img ==> WARNING: errors were encountered during the build. The image may not be complete. ==> Building image from preset: /etc/mkinitcpio.d/linux44.preset: 'fallback' -> -k /boot/vmlinuz-4.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.4-x86_64-fallback.img -S autodetect ==> Starting build: 4.4.55-1-MANJARO -> Running build hook: [base] -> Running build hook: [udev] -> Running build hook: [modconf] -> Running build hook: [block] -> Running build hook: [keyboard] -> Running build hook: [keymap] -> Running build hook: [encrypt] ==> ERROR: module not found:crc32’
-> Running build hook: [lvm2]
-> Running build hook: [plymouth]
-> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.4-x86_64-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.
error: command failed to execute correctly

My kernel is:

uname -a
Linux XXXXXX 4.4.55-1-MANJARO #1 SMP PREEMPT Sun Mar 19 07:00:14 UTC 2017 x86_64 GNU/Linux

Like I said this does boot successfully so it’s not directly impacting my work at this point, but thought I would share incase there is an issue that I am not noticing.