[Stable Update] 2017-03-20 - Deepin, KDE Framework, Haskell, Python, Kernels

update
stable

#21

I have just pushed a temporary package deepin-daemon-3.1.5-1.1 (mind the decimal version .1 at the end!), so you shouldn’t have to bother about updating your system normally.
I hope upstream will sort this out properly, soon :stuck_out_tongue:


#22

IMHO the solution described above to workaround the conflicting certificate is lacking a final solution step.

After the update command has been successful, I was not able to use git because of the missing certificate.

In order to solve it, I have had to manually link the ca-bundle.trust.crt to the expected location.

sudo ln -s /etc/ca-certificates/extracted/ca-bundle.trust.crt /etc/ssl/certs/ca-certificates.crt


#23

(1)
The update caused the fallback images to be generated in /boot and entries in GrUB to appear.

I had edited mkinitcpio.conf to remove fallback and changed the /etc/mkinitcpio.d files for all the kernels so the fallback was not listed. (then removed fallbacks and updated the initramfs).
Much to my surprise the changes I made to mkinitcpio.d/<kernel-files> were all gone. It was as if the /etc/mkinitcpio.d dir had been completely re-written.
The mkinitcpio.conf remains as I edited it.

I cannot say for certain that it was the update if there is some other mechanism that will ‘fix’ /etc/mkinitcpio.d dir in the background, without my knowledge, but since I know of none, it must have been the 3-20 update.
I suspect
[2017-03-20 02:48] [ALPM] upgraded mkinitcpio (22-1 -> 23-1)
is the culprit.


This system has no need for ‘fallback’ (or recovery items) as there are multiple installs and kernels, …etc. …
If it is the updating and/or updating of mkinitcpio, please do not do that.
The /etc/mkinitcpio.d files do not depend upon the extended versioning information so there is no reason to spend the BW ‘fixing’ what is not broken, ;).
I suppose if the files exist, a linux*.preset.new could be written for each *(kernel), though even that is not needed unless there is some significant change to the format.

(2)
There was a strange occurrence during the update. I downloaded all the updates, removed the certificate, rebooted to CLI, installed the certificate and did a pacman -Su (as root), which worked. However, during the update it tried to connect to the mirrors in pacman-mirrorlist and they all failed:

[2017-03-20 02:49] [ALPM] upgraded pacman-mirrorlist (20170212-1 -> 20170319-1)
[2017-03-20 02:49] [ALPM-SCRIPTLET] :: Querying servers, this may take some time
[2017-03-20 02:49] [ALPM-SCRIPTLET] => Testing mirrors in United_States
[2017-03-20 02:49] [ALPM-SCRIPTLET] 
[2017-03-20 02:49] [ALPM-SCRIPTLET] Error: Failed to reach server: [Errno -2] Name or service not known
[2017-03-20 02:49] [ALPM-SCRIPTLET] ==> 0.007 - http://mirror.dacentec.com/manjaro/stable/$repo/$arch
...etc.

The network was connected & working. I have no idea while it would fail to connect to all the mirrors on the list. (dunno what [Errno -2] is/means)
It did complete
[2017-03-20 02:49] [ALPM-SCRIPTLET] :: Mirrorlist generated and saved to: /etc/pacman.d/mirrorlist
And has been working since the update so, AFAIK, there was no fix needed for it.
…still it is odd that they all failed.


There may be some issues with KDE but have not seen any yet so all is good.

Thank you for the updates, :slight_smile:!


Manjaro i3 17.0.1
#24

I solved the error in mkinitcpio with a downgrade to the previous mkinitcpio version: the ==> ERROR: module not found: crc32’ disappear.


#25

For KDE, in a VM, and on two different HW installs, Octopi handled this easily. On a 32-bit Netbook Edition, I needed to:

sudo pacman -Syuw                           # download packages
sudo rm /etc/ssl/certs/ca-certificates.crt  # remove conflicting file
sudo pacman -Su                             # perform upgrade

#26

IMHO the solution described above to workaround the conflicting certificate is lacking a final solution step.

@svooo:

The update is supposed to replace the certificates after first manually removing, what error did you see with git?


#27

Pefect update on Mate.
No problems with certificates errors.

Thanks to the Team!

Quad core Intel Core i5-4570
Kernel: 4.10.3-1-MANJARO x86_64
Cedar [Radeon HD 7350/8350 / R5 220]
Display Server: X.Org 1.19.2 driver: radeon
Desktop: MATE 1.16.1 (Gtk 3.22.10)


#28

2 machines using 64 bit KDE and Octopi with no problems.


#29

Confused updated thru the Octopi notifier seem to do fine and finished with "Command finished OK"
But during the upgrade got

Arming ConditionNeedsUpdate…
Rebuilding certificate stores…
warning: lock file missing /var/lib/pacman/db.lck
warning: dependency cycle detected:
warning: kinit will be installed before its kio dependency

Am I updated or not? And what is happening with the constant issues with CA-Certs?


#30

just warnings, all is ok


#31

Had the warnings, followed what was said also my wireless cut out really badly after update for my realtek rtl8821ae card (so bad it was unusable) but I also forgot to disable the ips and fwlps when I did the install and disabled them and the wireless is back up again.
Kind of weird it worked before the update without doing that.
Probably this part of the update that did it
linux49-r8168 8.043.02-10 -> 8.043.02-12
But so far so good after disabling those two.
Other then that all is well
Sam

EDIT: alright I tested this for a bit now and looks like the wireless issues cutting in and out are still there after the update, I thought disabling those two would do it but no go, the wireless is still cutting in and out horribly, it’s not the connection, I plugged in and it’s fine, the wifes computer wireless is fine also, so it was the update that did it, is there a way to downgrade to the last one that worked?

here is my cards info

Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.043.02-NAPI port: e000 bus-ID: 02:00.1
           IF: enp2s0f1 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
           driver: rtl8821ae port: d000 bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>

I have it plugged in at the moment and Im on xfce

EDIT AGAIN: ok downgraded network manager and the adapter it seemd to help a tad but there is also nothing showing up under AUR when doing a search, I just tested that part as I seen it also happened to someone else.
Just thought I would add that in case you needed to know

Edit: Ok I did a complete reinstall from scratch, I got AUR working again but the wireless is still sketchy as heck and dropped the kernel down 4.9 to 4.4 thinking it might help a bit but not yet with the wireless.
I’ll keep digging at it


#32
System:    Host: manjaro Kernel: 4.10.3-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
           Desktop: KDE Plasma 5.9.3 (Qt 5.8.0) Distro: Manjaro Linux
Machine:   Device: desktop System: Dell product: Inspiron 560 v: 00
           Mobo: Dell model: 018D1Y v: A00 BIOS: Dell v: A06 date: 12/01/2010
CPU:       Dual core Pentium E5500 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 11176 
           clock speeds: max: 2803 MHz 1: 1203 MHz 2: 2003 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 310] bus-ID: 01:00.0
           Display Server: X.Org 1.19.2 driver: nvidia Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce 310/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.101 Direct Rendering: Yes
Audio:     Card-1 NVIDIA High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.3-1-MANJARO
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.043.02-NAPI port: e800 bus-ID: 04:00.0
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2000.4GB (31.0% used)
           ID-1: /dev/sda model: WDC_WD1001FAES size: 1000.2GB
           ID-2: /dev/sdb model: WDC_WD10EAVS size: 1000.2GB
Partition: ID-1: / size: 48G used: 13G (28%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A gpu: 0.0:59C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 140 Uptime: 3 min Memory: 853.5/3955.5MB Init: systemd Gcc sys: 6.3.1
           Client: Shell (bash 4.4.121) inxi: 2.3.8

Things look good - encountered no problems during pacman -Syyu

thanks


#33

Okay… some update from the last few days “broke” something in pamac (4.3.1-1)…

When I search for packages I no longer get results from AUR displayed, though “Search in AUR by default” is enabled. EDIT: Also, prior to THIS update I also had the issue that the update-notifier in the systray didn’t show up … it only popped into view once I had opened “Software Update” manually. /EDIT

Running Manjaro MATE 16.10 x86_64 (still waiting for 17 to hit “stable”).


#34

all smooth except that it broke my bumblebee on manjaro 17 KDE, running the 410 kernel.

$ vblank_mode=0 optirun -vv glxspheres64 -v
[ 1387.622251] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 1387.622792] [INFO]Configured driver: nvidia
[ 1387.623096] [DEBUG]optirun version 3.2.1-2017-02-27-Format:%h$ starting…
[ 1387.623123] [DEBUG]Active configuration:
[ 1387.623153] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1387.623163] [DEBUG] X display: :8
[ 1387.623173] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia
[ 1387.623183] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1387.623191] [DEBUG] Accel/display bridge: auto
[ 1387.623226] [DEBUG] VGL Compression: proxy
[ 1387.623235] [DEBUG] VGLrun extra options:
[ 1387.623244] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[ 1387.623310] [DEBUG]Using auto-detected bridge virtualgl
[ 1387.692292] [INFO]Response: No - error: Could not load GPU driver

[ 1387.692311] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 1387.692321] [DEBUG]Socket closed.
[ 1387.692338] [ERROR]Aborting because fallback start is disabled.
[ 1387.692340] [DEBUG]Killing all remaining processes.

$ modprobe nvidia
modprobe: ERROR: could not insert ‘nvidia’: Operation not permitted

Had the same error when I first installed manjaro 17 and traced it back to a conflict with TLP. Now, however, it’s not even working with disabled TLP.

related (?):

$ dmesg | grep fail
[ 1.092963] acpi PNP0A08:00: _OSC failed (AE_SUPPORT); disabling ASPM
[ 1.218310] pci 0000:01:00.0: BAR 6: failed to assign [mem size 0x00080000 pref]
[ 2.333431] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-8265-26.ucode failed with error -2
[ 2.333533] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-8265-25.ucode failed with error -2
[ 2.334421] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-8265-24.ucode failed with error -2
[ 2.334432] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-8265-23.ucode failed with error -2
[ 2.511709] thermal thermal_zone3: failed to read out thermal zone (-5)

A quick google search let me to suspect it has something to do with initframs/mkinitcpio, which apparently broke for others here (nvidia forum)

I am not quite able to put the pieces together myself, I fear. I just migrated from Ubuntu a few weeks back and am loving every bit of it, by the way :wink:

Best,
Leonard


EDIT: Disregard! Somehow only half the upgrade went through. I now upgraded the remaining packages and everything runs excellently! Great work, thanks!


#35

Sorry for the late response, but I am very buisy at the moment. No issues at all on two machines, xfce with pacman-mirrors v4. No certficate warnings, nothing, very smoorh. Thank you manjaro-team.


#36

I got this error just now when testing it.

$ git clone https://github.com/[...]/testrepo.git
Cloning into 'testrepo'...
fatal: unable to access 'https://github.com/[...]/testrepo.git/': error setting certificate verify 
locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none

#37

Git error:
error: error setting certificate verify locations:
CAfile: /etc/ssl/certs/ca-certificates.crt
CApath: none
while accessing https://github.com/

@Dillinger In order to solve it, you need to add back a symlink as described in my previous post.


#38

I too have this problem since the update. Searching aur in pamac and yaourt shows no results now.

I updated with pacman -Syyu
I checked here before updating as i usually do but don’t remember seeing any special instructions at the time.

Would the ca-certificates issue be causing this?

I had no errors show up with my update.


#39

I also had to use this solution, bower installs were failing with the same git error:

fatal: unable to access ‘https://github.com/angular/bower-angular-aria.git/’: error setting certificate verify locations:
CAfile: /etc/ssl/certs/ca-certificates.crt
CApath: none


#40

[quote=“bushblade, post:38, topic:19947, full:true”]
I too have this problem since the update. Searching aur in pamac and yaourt shows no results now.[/quote]

I just checked the historical log … last time it was still working on 16/3/2017 as I installed an update to “enpass-bin” from AUR (that was at the time the update-notifier wasn’t showing nor notifying unless manually launched).

Not entirely here … I installed the “manjaro-system” update via pamac/update-manager … and got the certificate issue displayed right after (at the “commit” of the list of updates it displayed after installing “manjaro-system”). That’s when I resorted to the Terminal to update via the commands @philm had pointed out (already in the “testing” announcement).

Same here … no errors or problems with any of the updates that rolled in since the base was updated to “17.0” (in quotation marks because strictly speaking Mjro MATE is still 16.10) … AUR just broke with this update in Pamac and yaourt … the Yoghurt is no longer strong with them (Spaceballs reference only german speaking people will get).

So … seeing the silence … any official thoughts on this? I think I already saw a couple of other posts about the same problem in the other categories (where one guy threw in the towel and installed from a 17.0 image anew … which is not an option).