[Stable Update] 2017-03-14 - Pamac, OpenRC, Firefox, Thunderbird, KDE-Apps, Virtualbox

update
stable

#25

no issues here on kde, thanks team! :slight_smile:


#26

All good, Great thanks


#27

electrum doesn’t start anymore:
Error: No module named pyaes. Try 'sudo pip install <module-name>'

Installing the module as proposed by the error message doesn’t help.

Downgrading to the previous version works.

Any ideas?


#28

I can confirm that. My sound icon is missing, though if you hover over it, a balloon text appears and the space on the dock that icon occupies is blank.

Right-clicking on the desktop causes the dock and any desktop icons to disappear.

I know this is upstream, but the weather widget in the Control Center allows you to add your city, but, the settings never “Stick”. Eventually, it reverts to “Sorry, unable to get weather”


#29

I never saw anything like this on Linux and I’m not an expert. But from my personal experience I can say that linux is very sensitive to hardware issues. For example: I have a gigabyte motherboard and I was not able to access internet using kernel 4.9 until I found the correct configuration for my bios option on iommu=soft along with appropriate config on linux startup modules.
Sorry, I don’t have solution to your problem but I could bet it’s an hardware related issue. You may try to search on google and other search sites for something similar. I found the solution to my issue on an ubuntu site. Sometimes nobody on our distro experience the same issue we have or has not solved it but may there be somebody in other distro’s sites that has.


#30

I have the same problem with the desktop interaction: clicking anywhere makes icons disappear. Same for the weather applet…


#31

electrum 2.8.1 is in Arch.
Not tested yet, but it would be great if you could push it to stable, apparently it fixes the issue I posted above (not confirmed though).


#32

A nice small and smooth as silk update. Thanks team!


#33

Update on 12 Machines without Problems.

DK3


#34

Everything went smooth on my GNOME machine with linux49 :slight_smile:
Thanks you guys.


#35

Hi:
There is a new error at boot.
After this update gpm fails to start at boot. The journal message is

Mar 16 12:04:17 ml16103 /usr/bin/gpm[777]: O0o.oops(): [daemon/old_main.c(58)]:
Mar 16 12:04:17 ml16103 /usr/bin/gpm[777]: Could not open /dev/input/mice.

I can reproduce it at every boot.
systemctl status:

$>  systemctl status gpm
● gpm.service - Virtual console mouse server
   Loaded: loaded (/usr/lib/systemd/system/gpm.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2017-03-16 12:04:17 CDT; 16min ago
  Process: 776 ExecStart=/usr/bin/gpm -m /dev/input/mice -t imps2 (code=exited, status=0/SUCCESS)
 Main PID: 777 (code=exited, status=1/FAILURE)

It will start from console once booted with sudo systemctl start gpm:

$>  systemctl status gpm
● gpm.service - Virtual console mouse server
   Loaded: loaded (/usr/lib/systemd/system/gpm.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2017-03-16 12:24:29 CDT; 25s ago
  Process: 2899 ExecStart=/usr/bin/gpm -m /dev/input/mice -t imps2 (code=exited, status=0/SUCCESS)
 Main PID: 2900 (gpm)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/gpm.service
           └─2900 /usr/bin/gpm -m /dev/input/mice -t imps2

And it does work in console(VT) after that.

The screenfetch -pn (w/o username@hostname):

*
OS: Manjaro 17.0 Gellivara
 Kernel: x86_64 Linux 4.10.1-1-MANJARO
 Uptime: 14m
 Packages: 1250
 Shell: bash 4.4.12
 Resolution: 3840x2160
 DE: KDE 5.31.0 / Plasma 5.9.3
 WM: KWin
 WM Theme: Oxygen
 GTK Theme: Dark-Aurora [GTK2/3]
 Icon Theme: oxygencolors
 CPU: Intel Xeon X5687 @ 16x 3.601GHz                                                                                                                                                         
 GPU: GeForce GTX 1060 6GB                                                                                                                                                                    
 RAM: 1691MiB / 24104MiB                                                                                                                                                                      

This is a ML 16.10.3 updated to ML 17.
The error also occurs with kernels 4.4 and 4.9.
The problem only started with the Gellivara update.
I have not found a good solution yet as I do not know why it occurs.

The excruciatingly slow grub menu display issue remains. The work-around to use 1024x768 res and no theme is tolerable but I found no solution for it either.

Otherwise, AFAICT, it was pretty smooth update, …thanks, :slight_smile:.


#36

Please, let me give some very basic suggestions:
1 - Have you tried creating a new user to find out if those bugs repeat on a clean user config? If they don’t it’s just a matter of personal config files at a desktop level and you can configure everything correctly in a new user account.
2 - If they persist, have you tried installing another desktop? For example, I use KDE and XFCE. If you have a QT based desktop and a GTK based desktop you can try one or another to see if it’s an issue related only to QT or to GTK.
3 - Have you tried booting from an up-to-date boot media? If everything works maybe a fresh install can be faster and easier to solve the problem than trying to find the reason and correcting it step-by-step.
4 - If nothing works you can try looking for hardware assistance.


#37

Of course! That was the first thing I tried to find the cause of the problem, but I get the same result…

Already done: tried GNOME, KDE, BUDGIE, Enlightenment

I disagree completely: this is not Windows where you reinstall if something goes wrong. If the problem affects even other users, finding the cause is the best thing to do…


#38
 ██████████████████  ████████     OS: Manjaro 17.0 Gellivara                                                        
 ██████████████████  ████████     Kernel: x86_64 Linux 4.10.1-1-MANJARO                                             
 ██████████████████  ████████     Uptime: 2m                                                                        
 ████████            ████████     Packages: 1278
 ████████  ████████  ████████     Shell: bash 4.4.12
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: KDE 5.31.0 / Plasma 5.9.3
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     WM Theme: Maia
 ████████  ████████  ████████     GTK Theme: Maia [GTK2/3]
 ████████  ████████  ████████     Icon Theme: maia
 ████████  ████████  ████████     Font: Noto Sans Regular
 ████████  ████████  ████████     CPU: Pentium Dual-Core E5500 @ 2x 2.803GHz
                                  GPU: GeForce 310
                                  RAM: 1167MiB / 3955MiB

All good here,
thanks


#39

100% perfect on my machine. Thanks to Phil, core team, wider testers running “Testing” & the whole community, for this magnificent, rock-like OS. I’ve been running my business on it for 4 years now & it continues to deliver.

More power to you all.

Ruziel.


#40

Haven’t logged in for a while, moved from the Netherlands to Dubai…

Powering up for the first time, I’m getting this:

(381/381) checking for file conflicts                     [###############################] 100%
error: failed to commit transaction (conflicting files)
xorg-server: /usr/lib/xorg/modules/extensions/libglx.so exists in filesystem
Errors occurred, no packages were upgraded.

I’ve got the feeling this should be solvable easily though… the question is: how?

Update: renamed the file to libglx_old.so, and now we’re rolling :slight_smile:

Update 2: Very smooth now

 ██████████████████  ████████     OS: Manjaro 17.0 Gellivara
 ██████████████████  ████████     Kernel: x86_64 Linux 4.9.13-1-MANJARO
 ██████████████████  ████████     Uptime: 2h 59m
 ████████            ████████     Packages: 1307
 ████████  ████████  ████████     Shell: bash 4.4.12
 ████████  ████████  ████████     Resolution: 1366x768
 ████████  ████████  ████████     DE: GNOME 
 ████████  ████████  ████████     WM: GNOME Shell
 ████████  ████████  ████████     WM Theme: 
 ████████  ████████  ████████     GTK Theme: Numix-Frost [GTK2/3]
 ████████  ████████  ████████     Icon Theme: Numix-Circle-Light
 ████████  ████████  ████████     Font: Cantarell 11
 ████████  ████████  ████████     CPU: Intel Core i5 M 450 @ 4x 2.4GHz [26.8°C]
                                  GPU: Gallium 0.4 on AMD CEDAR (DRM 2.48.0 / 4.9.13-1-MANJARO, LLVM 3.9.1)
                                  RAM: 1914MiB / 3819MiB

Also switched back to GDM and am giving Wayland a try…


Updating Problem "Libglx.so exists already in the datasystem"
#41

Update from me, square Selecting (drag selection) by mouse on dolphin seems laggish, and firefox seems slower .


#42

Almost everything went well in this update, however Firefox started to have a few problems like being slow, session manager having a huge number of tabs stored and the bookmark’s toolbar becoming empty. After few tests I found that the culprit was an old extension called “Work Offline”. After replacing it with a similar one (“Offline Switch”) everything returned to normal.

All the best,
Rick

Edited: fixed new extension’s name.

 ██████████████████  ████████     richard@orion-manjaro
 ██████████████████  ████████     OS: Manjaro 17.0 Gellivara
 ██████████████████  ████████     Kernel: x86_64 Linux 4.10.1-1-MANJARO
 ██████████████████  ████████     Uptime: 4h 51m
 ████████            ████████     Packages: 1743
 ████████  ████████  ████████     Shell: bash 4.4.12
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: XFCE4
 ████████  ████████  ████████     WM: Xfwm4
 ████████  ████████  ████████     WM Theme: Adwaita-Maia
 ████████  ████████  ████████     GTK Theme: Adwaita-Maia [GTK2]
 ████████  ████████  ████████     Icon Theme: Faience-Ocre
 ████████  ████████  ████████     Font: Ubuntu 14
 ████████  ████████  ████████     CPU: Intel Core i7-5500U @ 4x 3GHz [61.5°C]
                                  GPU: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) 
                                  RAM: 3510MiB / 7903MiB

#43

A post was merged into an existing topic: [Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox


#44