[Stable Update] 2017-02-17 - Kernels, Plasma5, KDE Frameworks/Apps, Libreoffice, Mozilla

update
stable

#102

Is there a new path for KDE downloads? Searching for services and widgets gives error: faild to load from http://download.kde.org/ocs/providers.xml


#103

Updated with absolutelly no issues - Gnome Edition :slight_smile:


#104

Please help, the Manjaro-settings-manager can no longer change Keyboard settings :open_mouth:
It produces “Can’t find the keyboard variant us” when I attempt to change it. !! Opened issue if you want to chat there https://github.com/manjaro/manjaro-settings-manager/issues/94 :frowning:

edit: you can use setxkbmap command in terminal to set layouts


#105

Update on 12 Machines without Problems.

DK3


#106

This update seems to have removed a split-second graphical corruption when the desktop first appears at boot.


#107

Did someone actually received this promised Thunar 1.6.11 update?


#108

You don’t need to do so. I have both KDE and XFCE running smoothly on my system. You can find tutorials of how installing more than one DE in Manjaro. But don’t do it using octopi to avoid a big mess. Use a terminal.


#109

I tried twice to use kernel 4.9. and network failed. (I installed using manjaro settings manager.)
Then I rebooted and on grub I used advanced options to go back to kernel 4.4.

So…
1 - What configs should I delete to create new ones based on hardware found? How do I do it?
2 - If I delete old configs won’t I be unable to return to the old kernel if need?


#110

KDE Edition After the upgrade and reboot my VPN will connect but not bring up any pages nor ping. I am using Unbound DNS which worked fine with the VPN before the update. I have tried removing and recreating in the Network Manager which did not help. I must admit I am a little stumped. Unbound works fine without the VPN.


#111

I also deleted and recreated my wired connection. The only advantage is that the system is not freezing anymore. But any browser is able to load only the home page. Then when I try to access any other site, the bar on the bottom says Looking up www… and never loads anything. Indeed when it loads the home page it starts a loop of loading it again and again. This happened in KDE and in XFCE, in Firefox and in Chromium, but only with kernel 4.9. When I return to kernel 4.4 everything is ok.


#112

Everything OK… I only removed .cache directory from my home before upgrading. I’m using Manjaro Linux KDE!!!


#113

That is odd. We simply had rebuilt that driver for the new kernels. Sometimes that is needed due ABI changes within the kernel releases.


#114

Everything went well! No problems! Manjaro KDE on a Lenovo ThinkPad.


#115

Is it safe to remove the whole .cache directory? There is so much information about several applications there. Won’t we loose much of our configuration doing this?


#116

You will lose some speed-up info for a multitude of applications and it will have to be rebuilt when you next use those applications. For other applications you will lose setup info and you just have to reset them up. Still others you will lose a LOT of potentially important information.

Everything in .cache is SUPPOSED to be rebuildable automatically. Sadly there are instances where this does not happen all the time. Programmers ended up storing important things in .cache. (I’m looking at you Thunderbird!!!)

And equally sadly some packages sometimes change .cache content structure on the fly.

Look, this is NOT Necessary. and I’m not sure @joshua.dunamis recommended that as the recommended option for everyone. Most often there is no problems just doing the update. 82% voted no problem, another 9% resolved the issue easily. One guy suggested deleting .cache.

I’ve never had to remove .cache ahead of time. Just do the upgrade, then, if everything is badly messed up, you can remove the .cache and see if that helps. In any event just backup all of .cache before you nuke it.

.cache builds up detritus after a while. You can tell this by looking at the date of files in there. You will find things in there you haven’t used for months.

And don’t mistake .config for .cache.


#117

intel/KDE/nVidia. 4.9.9-1-MANJARO #1 SMP PREEMPT Thu Feb 9 23:12:06 UTC 2017 x86_64 GNU/Linux

All seems to good to be true… after the upgrade end well I reboot my system twice just to be sure, then:

  • kodi upgraded: When starting It shows a message about add-on being upgraded then it closes. In the .kodi folder and rename the “addons” folder the kodi stars again and this fix it.

  • Sound problems: Playing sounds/video the audio shows crackling noises + echo; if I stop the player the sound plays for a few moments then stops. I check the system settings multimedia and try to tweak things but I can’t find how to fix this issue…

I will try running other kernel, but this seems relate to: KDE / pulseaudio?
(Oh please… I want to enjoy the weekend … I don’t want to reboot on windows just to see netfl*x :pray: )

Fixing the noise caused by (speech-dispatcher)


#118

We have around 99% chances that crackling noises + echo are related to pulseaudio and maybe KDE. It often happens to me when I launch Musescore. The simple solution I find is closing Musescore and opening it again.
After the updates the same happened to me when I tried to watch a video online with Firefox. The I closed it, opened a video on my local drive using VLC and everything became normal again both in VLC and in Firefox.


#119

I was able to update 5 machine with no problems after updating my mirrors because I think only 2 of the 5 got notifications about the update. It seemed like after updating the mirrors all of the updates went quickly. My networking machine an old Dell Latitude D630 started booting up much faster than I can remember after the updates so that was an added bonus! Good work as always


#120

Plasma. All good here. Even threw in Linux410 to see if it would break any thing.
No luck, all is still working.

cheers


#121

We have around 99% chances that crackling noises + echo are related to pulseaudio and maybe KDE…
… The simple solution I find is closing Musescore and opening it again.

I repeat using some combinations the issue remain…
I close FireFox, open SMPlayer then chrome -> noise/echo

In system settings / multimedia I change some output devices -> repeat -> noise/echo.

Then in system/multimedia, I see something new for me: “Automatically switch all running streams when a new output becomes available”… and activate the checkbox.
But now, I try something different and give it the “3 finger salute” to restart my session/plasma, then I try again: first using headphones (it uses the motherboard sound) and no crackling noise this time, I change to play sound using the nvidia card -> this time clear sound, change to headphones again -> all good, even with firefox running.

I wonder if this issue is hardware related… like a shortcut o bad voltage coming from my UPS :thinking: I remember that yesterday, before the updates I boot manjaro and it just hangs in the boot. I need to shutdown and boot again but I don’t have any other issues after the upgrade.

Seems like the weekend is saved again :hugging: Manjaro!