[Stable Update] 2017-01-30 - Kernels, Steam, Budgie, Deepin, KDE Framework, Virtualbox

update
stable

#101

I removed WebKitGTK viz. @MonkeeCat
[Stable Update] 2017-01-30 - Kernels, Steam, Budgie, Deepin, KDE Framework, Virtualbox
and the replies to this 1st. post.

That removed gufw also.
I have since reinstalled gufw and all is OK, probable,
or at least until I try to fix something else…:scream:


#102

Updated today, and just one thing is off: Mount & Blade Warband doesn’t run anymore. Trying to open it from the shortcut doesn’t produce any effect, and trying to run it from the terminal prints

./mb_warband_linux: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

Can’t find any solution to this on the internet, any advice?


#103

I installed today’s update - seems good so far. But, anyway, I would like to keep my package base clean and avoid AUR packages as much as possible so maybe someone could give me advice how to get rid of gstreamer packages and its dependencies?


#104

A question to more experienced users than me: How to remove those webkit packages without getting into “dependency - hell”?


#105

OK, I’m on it


#106

Have the same problem. Font of Chromium’s UI doesn’t look good anymore.


#107

The people in forum are commenting on the error message on having installed the packages:

upgraded webkit2gtk (2.14.2-2 -> 2.14.3-1)
upgraded webkitgtk (2.4.11-3 -> 2.4.11-4)
   > WARNING: WebKitGTK+ 2.4 is known to have many security vulnerabilities that
              will NOT be fixed. Avoid browsing with it.

When I was verifying the dependences I committed an error between the packages webkit2gtk and webkitgtk.

Sorry.


#108

No issues! Smooth update for both, Laptop and Desktop. Both KDE.


#109

With the new update and kernel 4.9.6 I keep having the same XServer crashes as with the previous stable update.

I’m trying kernel 4.4 at the moment and will see if that helps. So far (~1h uptime) no crashes…


#110

From the post of @Tids in the link:

GStreamer 0.10 has been unmaintained for quite a while, [1] and some CVEs have accumulated. [2] The last release was in 2012. Applications should use GStreamer 1 now.

With this update, my system installed the package GStreamer 0.10 from AUR:

[PACMAN] Running ‘pacman --color auto -U /tmp/yaourt-tmp-tomasfl/PKGDEST.WGf/gstreamer0.10-0.10.36-11-x86_64.pkg.tar.xz’
[ALPM] transaction started
[ALPM] upgraded gstreamer0.10 (0.10.36-4 -> 0.10.36-11)
[2017-01-31 20:13] [ALPM] transaction completed

Now i have 2 gstreamer packages:

pacman -Qi gstreamer
Nombre                    : gstreamer
Versión                   : 1.10.2-1

and

pacman -Qi gstreamer0.10
Nombre                    : gstreamer0.10
Versión                   : 0.10.36-11
Requerido por             : gstreamer0.10-base

I didn’t know what package installed gstreamer0.10. I can delete gstreamer0.10 without affect my system?
Thanks.


#111

nothing installed them from AUR. they were installed by default. and as they got removed from repositories and pacman don’t uninstall package that are removed from repositories. pamac, octopi and yaourt (if called with “a” option) think those packages comes from AUR as they got added to AUR and “updated” maybe only relative pakage number).
I removed them and did saw any problems. if you don’t have anything depending (or optionally depends) on them you can safely remove them.


#112

The updates stable now 3 times a month? Or no?




#113

sudo pacman-Syuu went smoooooth
Using kernel 4.10-rc5 nvidia virtualbox playonlinux (office 2010) and steam

Thanks !!!


#114

I run:

pacman -Rsc gstreamer0.10-base-plugins gstreamer0.10 gstreamer0.10-base
comprobando dependencias…

Paquetes (6) libkeybinder2-0.3.1-1  wxgtk2.8-2.8.12.1-4  xfce4-mixer-4.11.0-3  gstreamer0.10-0.10.36-11  gstreamer0.10-base-0.10.36-8  gstreamer0.10-base-plugins-0.10.36-8

Tamaño total quitado:  31,78 MiB

:: ¿Desea quitar estos paquetes? [S/n] 
:: Procesando los cambios de los paquetes...
(1/6) quitando xfce4-mixer
(2/6) quitando libkeybinder2
(3/6) quitando wxgtk2.8
(4/6) quitando gstreamer0.10-base-plugins
(5/6) quitando gstreamer0.10-base
(6/6) quitando gstreamer0.10
:: Ejecutando los «hooks» de posinstalación...
(1/1) Updating the desktop file MIME type cache...

I delete all packages of gstreamer0.10 version.


#115

Running Xfce & Kernel 4.9.6
Smooth update again, Thanks!
Only issue: the python update finally damaged my Qgis installation.
But no big deal, will now have to recompile.


#116

I’m having the same issue with font in the UI of Chromium. It looks like it’s DPI related possibly. But I can’t find any setting that looks like it would change it.


#117

A rather large (approx. 670 Mb) update. But it went very smooth. As I like the updates to go.

Only other thing I did was after update, I installed the 4.9 kernel and removed the 4.8.
This way I can stay ahead of the EOL.


#118

Chrome 56 looked fine before, so it might have something to do with the latest update.


#119

I don’t know what you guys did, but my refurbished former windows computer now starts even faster, was already fast (using SSD) but after last update it just felt suspiciously faster so I ran:

systemd-analyze blame

and got as last entry:

795ms dev-sda1.device

And 6 seconds for whole enchilada:

Startup finished in 3.977s (kernel) + 2.118s (userspace) = 6.096s

Good job and thanks!

<should we send @philm more often to cruise?> :laughing: :stuck_out_tongue_winking_eye:


#120

@all with chromium fonts problem.

You can try to start Chromium in Terminal with:

chromium --force-device-scale-factor=1

Maybe put the file in usr/bin/chromium.

(Dont use Chromium by my self)