[Stable Update] 2017-01-17 - Python, Xorg, Ruby, Gcc, Inkscape



I don’t have an alternative kernel, but @scachemaille provided the solution. Thank you!!!
And of course thanks @oberon for your time and tips, great work.

P.S. Your link points to testing branch, so it didn’t work, which meant yet another restart to grab the package from windows :tired_face:


Argh, sorry for that! :blush:


Hate to bother you but could you look at


As this has completely stopped manjaro-tools for me they all build but none work.


I noticed it shows up a whole bunch of times during startup. is there a way to hide it?

I’ve also seem to have caught some type of watchdog error. will try to investigate more


Large update indeed! All went fine on one i3 laptop and 2 KDE desktops.

@Oberon: 33-TerminusPcfFont.conf is already installed with the update, but it has executable permissions. All one needs to do is to change its permissions and create a link in the personal fontconfig folder.

For those who haven’t read this post and/or don’t know how to change the settings related with “Terminus” font, so it keeps the same name:

  1. Change the permissions of the installed config file: sudo chmod -x /etc/fonts/conf.avail/33-TerminusPcfFont.conf
  2. Create a link to this file in your local fontconfig folder: ln -s /etc/fonts/conf.avail/33-TerminusPcfFont.conf ~/.config/fontconfig/conf.d/ (if the folder doesn’t exist create it)


EDIT: forgot to thank Manjaro Team for the wonderful work ;), and also to all the testers making this possible for the Team (and for all of us).


I followed the instructions!!! Everything is OK. The Breath theme is ok… but I believe it should improve anymore… Thanks Team, You’re very Great!!!


“acpi watchdog failed to create platform device” i’ve been trying to track this down and what i found is kinda worrying :confused:
Will try to catch the other errors as soon as i can


Has anyone advice on ERROR: module not found: `dm_cache_smq’ when upgrading Linux 318. I’m unable to boot to GUI now. Thanks in advance. See post 156

PROBLEM SOLVED: I’ve upgraded to linux49 and the problem has gone away.

Thanks for all the work that went into this huge update. Glad to see the other side of it :smile:


First thing I want to say is that I followed all of the suggestions in the OP (@oberon) that pertained to the problems I am experiencing since updating to the latest system upgrade. Also, I tried various solutions, provided by community users in this thread, to those problems. None of them worked to a fix.

All of the following occurred after a system upgrade to my now classic, and no longer supported, Manjarobox (Openbox) install.

Oblogout-manjaro no longer works. Super+X results in oblogout-manjaro failing to launch. Using the “oblogout” command in the terminal returns: “pyGTK missing, install python-gtk2”. I rebuilt/reinstalled pygtk a couple of times and got the same results. And there is no “python-gtk2” located in the Manjaro or AUR repos.

In order to restart, I have to use the “reboot” command in the terminal. To logout of a session, I have to use the “fluxboxexit logout” command in the terminal. Surprisingly, though, i3lock does continue to work.

Icons. Like many others, the vast majority of my icons no longer work. All icons have defaulted to the standard GNOME icons that every Linux user on planet Earth is familiar with. I rebuilt/reinstalled LXAppearance / LXAppearance-obconf/ LXAppearance-GTK3/ LXAppearance-obconf-GTK3 multiple times to no avail. Also, to no avail, librsvg and qt5-svg were rebuilt/reinstalled multiple times.

Issuing the “pacman -Qo /usr/lib/python3.5/site-packages” terminal command returns: “error: No package owns /usr/lib/python3.5/site-packages”. However, found inside the /usr/lib/python3.5/site-packages directory is a LightDM directory. I have rebuilt/reinstalled lightdm-gtk-greeter/ lightdm-gtk-greeter-settings but the directory still remains; not sure that is a problem, anyway.

I have an issue with an AUR package called “Cadence”. Cadence, along with alsa-tools and jack, is audio software that allows me to use my professional RME sound card instead of my PC’s built-in sound card. No two ways about it, Cadence is necessary because RME does not make drivers for Linux. With this latest system update, Cadence crashes on launch. Attempting to launch it from the terminal returns:

“Traceback (most recent call last):
File “/usr/share/cadence/src/cadence.py”, line 24, in
from PyQt4.QtGui import QApplication, QDialogButtonBox, QLabel, QMainWindow, QSizePolicy
ImportError: /usr/lib/libharfbuzz.so.0: undefined symbol: FT_Get_Var_Blend_Coordinates”.

The fix for Cadence failing to launch has been to downgrade the latest harfbuzz/ harfbuzz-icu packages to the previous version. Rebuilding/reinstalling the latest harfbuzz/ harfbuzz-icu packages does not result in a fix. Setting my pacman.conf to ignore harfbuzz/ harfbuzz-icu, at the moment.

I don’t use Terminus nor Infinality fonts/bundles.

Additional FYI: errors in dmesg. Booting into Linux44 displays this error: “[ 8.797050] systemd[1]: Failed to start Load Kernel Modules.
[ 8.797420] systemd[1]: systemd-modules-load.service: Unit entered failed state.
[ 8.797429] systemd[1]: systemd-modules-load.service: Failed with result ‘exit-code’.” I don’t know what that means, but I was able to boot using the Linux44 kernel.

Booting into Linux49, dmesg displays these errors: “[ 0.153609] ACPI BIOS Error (bug): _SB.PCI0.USB0._PSW: Object (Integer) must be a control method with 1 arguments (20160831/nsarguments-147)
[ 0.153693] ACPI BIOS Error (bug): _SB.PCI0.USB1._PSW: Object (Integer) must be a control method with 1 arguments (20160831/nsarguments-147)
[ 0.153772] ACPI BIOS Error (bug): _SB.PCI0.USB2._PSW: Object (Integer) must be a control method with 1 arguments (20160831/nsarguments-147)”. Again, I don’t know what problems may arise from that.

This has been the first Manjaro system upgrade where I have experienced mega breakage of fundamental system functions and software tools. And I’m writing this in the 12th hour since I’ve been trying to fix things. Nothing that I have tried, in that time, has worked.


It might be related to gtk-engine-murrine package. You can try to reinstall it or maybe to downgrade it.


Thanks, I’ll try that!

Update: Nope, reinstalling didn’t work. Also, I only have a gtk-engine-murrine version from 2014, which seems to be the latest, so downgrading wasn’t possible.


It works fine in my work desktop (intel graphics) and personal laptop (nvidia optimus)


Are you using some Ubuntu freetype fix ?
Your oblogout and harfbuzz problem can comes if you don’t use freetype2 2.7.1 or an other compatible package, that provide the same changes as done in freetype2 2.7.1.
And the error is:[quote=“lightbeam, post:172, topic:15825”]
undefined symbol: FT_Get_Var_Blend_Coordinates

Look here

And here:


Thank you! Will update this post in a few.


Following the manual at the top ot the page - success. KDE

I am relieved :slight_smile:


Did you manage to solve the problem?


Hm, @lightbeam, I’ve just tried installing oblogout-manjaro on my i3-install. It works without problem. There were some more recent updates of some other python/python2 packages. Would you mind trying to switch to unstable branch and see if this fixes things for you?


Thanks I already reinstalled :slight_smile: No problem now. But I didn’t install infinality fonts now.


Were you able to fix it @Kaleb?


Hi @oberon, after installing manually the realtek module I was indeed able to upgrade my system, which solved the nvidia issue as well. Now it runs smoothly. Thanks again!