[Stable Update] 2017-01-17 - Python, Xorg, Ruby, Gcc, Inkscape

update
stable

#43

Doesn’t come back after reboot, but it is running. The icon just doesn’t show in the tray. Yes, it appears when there’s an update, but the option to hide the icon when then are no updates is disabled. As I said, it makes no sense. Anyway, I fixed it by chance, but it is strange behaviour nonetheless.


#44

Create a separate topic, please, where we can try troubleshooting your issue in depth.


#45

Does this affect KDE?
Because I didn’t change a thing, and fonts look just fine after the update.
Everything in KDE settings regarding anti-aliasing and subpixel rendering is set to system defaults. (No clue where those defaults are set).


#46

The fact is how many ubuntu and Linux Mint user knows the name Debian which their linux is made of?
I just know that without Manjaro there wouldn’t have been any Arch for me.
Sharing opinion makes me learn new things, i always appreciate that. :slight_smile:


#47

Thanks for the opinion man that is just my way of showing appreciation for manjaro.


#49

It affects users who have installed infinality-bundle from a 3rd party repo. :slight_smile: Looks like you don’t need to do anything.


#50

Synchronized the database and saw I have 212 Manjaro updates waiting plus 1 from the AUR.
Used Octopi to update and this is what I got:

Starting full system upgrade…

resolving dependencies…
looking for conflicting packages…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

Command finished with errors!

Using the CLI I get this:

$ ~ > sudo pacman -Syu
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…
:: xorg-server and xf86-input-acecad are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-acecad? [y/N]

What to do next?


#51

Yes.
Then deal with the acecad issue later IF NECESSARY.


#52

Exactly the same problem for me.


#53

I have a couple problems with the new system update…

1.) gnome-subtitle doesn’t work anymore. it gaves me this kind of error in terminal:
> $ gnome-subtitles

Got 24 languages.
Unhandled Exception:
GLib.GException: Unrecognised image file format
  at Gdk.PixbufLoader.Write (System.Byte[] buf, System.UInt64 count) [0x00033] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.PixbufLoader.Write (System.Byte[] bytes, System.UInt32 count) [0x00000] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.PixbufLoader.LoadFromStream (System.IO.Stream input) [0x00010] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.PixbufLoader.InitFromAssemblyResource (System.Reflection.Assembly assembly, System.String resource) [0x00056] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.PixbufLoader..ctor (System.Reflection.Assembly assembly, System.String resource) [0x00018] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.Pixbuf..ctor (System.Reflection.Assembly assembly, System.String resource) [0x00021] in <ab255b0323154651abfa6f07104d1d75>:0 
  at GnomeSubtitles.Ui.MainUi..ctor (GnomeSubtitles.Core.EventHandlers handlers, Glade.XML& glade) [0x0005f] in <7766a53a88574a59bd61644fddd85128>:0 
  at GnomeSubtitles.Core.Base.Init (GnomeSubtitles.Execution.ExecutionContext newExecutionContext) [0x0008e] in <7766a53a88574a59bd61644fddd85128>:0 
  at GnomeSubtitles.Core.Base.Run (GnomeSubtitles.Execution.ExecutionContext executionContext) [0x00000] in <7766a53a88574a59bd61644fddd85128>:0 
  at GnomeSubtitles.Execution.Executable.Main (System.String[] args) [0x0003f] in <7766a53a88574a59bd61644fddd85128>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: GLib.GException: Unrecognised image file format
  at Gdk.PixbufLoader.Write (System.Byte[] buf, System.UInt64 count) [0x00033] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.PixbufLoader.Write (System.Byte[] bytes, System.UInt32 count) [0x00000] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.PixbufLoader.LoadFromStream (System.IO.Stream input) [0x00010] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.PixbufLoader.InitFromAssemblyResource (System.Reflection.Assembly assembly, System.String resource) [0x00056] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.PixbufLoader..ctor (System.Reflection.Assembly assembly, System.String resource) [0x00018] in <ab255b0323154651abfa6f07104d1d75>:0 
  at Gdk.Pixbuf..ctor (System.Reflection.Assembly assembly, System.String resource) [0x00021] in <ab255b0323154651abfa6f07104d1d75>:0 
  at GnomeSubtitles.Ui.MainUi..ctor (GnomeSubtitles.Core.EventHandlers handlers, Glade.XML& glade) [0x0005f] in <7766a53a88574a59bd61644fddd85128>:0 
  at GnomeSubtitles.Core.Base.Init (GnomeSubtitles.Execution.ExecutionContext newExecutionContext) [0x0008e] in <7766a53a88574a59bd61644fddd85128>:0 
  at GnomeSubtitles.Core.Base.Run (GnomeSubtitles.Execution.ExecutionContext executionContext) [0x00000] in <7766a53a88574a59bd61644fddd85128>:0 
  at GnomeSubtitles.Execution.Executable.Main (System.String[] args) [0x0003f] in <7766a53a88574a59bd61644fddd85128>:0

1.1) I also tried to reinstall librsvg and qt5-svg but then:
> g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /usr/lib/libharfbuzz.so.0: undefined symbol: FT_Get_Var_Blend_Coordinates

2.) VLC also doesn’t work:
> $ vlc

    VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
    [0000000001d3f448] core demux error: corrupt module: /usr/lib/vlc/plugins/access/liblibbluray_plugin.so
    [0000000001c39148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [0000000001d6e1f8] core interface error: corrupt module: /usr/lib/vlc/plugins/gui/libqt4_plugin.so
    [0000000001d6e1f8] core interface error: corrupt module: /usr/lib/vlc/plugins/gui/libskins2_plugin.so
    [0000000001d6e1f8] [cli] lua interface: Listening on host "*console".
    VLC media player 2.2.4 Weatherwax
    Command Line Interface initialized. Type `help' for help.
    > ^C[0000000001d6e1f8] [cli] lua interface error: Error loading script /usr/lib/vlc/lua/intf/cli.luac: lua/intf/modules/host.lua:279: Interrupted.

How can I solve this issues? Thanks in advance!


#54

this is because you use inifinality from AUR. like as explain here

if you use infinality it affect a lot of program.


#55

Thanks. I did that and now I see this:

Total Download Size: 1742,60 MiB
Total Installed Size: 5003,98 MiB
Net Upgrade Size: 56,54 MiB
Well, I do have a 100mb/s fiberglass connection so it is not that bad, but isn’t a download of 1700MB a bit much?

Well, all done. Computer is still computing, didn’t dare to reboot yet though.
Will do that now. If I return things are all well, if not, I restore a backup of my system.
Thanks.


#56

Nope, I don’t use infinality - never did!


#57

i would check as
libharfbuzz.so.0: undefined symbol: FT_Get_Var_Blend_Coordinates
is the error when you don’t have freetype2 package from repository.


#58

I use fontconfig-ubuntu and freetype2-ubuntu (Ubuntu fonts not infinality)


#59

it’s almost the same. those package are not compatible with latest harfbuzz


#60

Okay, I could come back here so I guess things are okay for me. Although, it ain’t over till the fat lady sings.
But things look good so I think all went well.
Thank you team for yet another great (and big) update.


#61

What should I do?


#62

I don’t know from where you get them. check if thre is updates for those pacakge.
or replace them with
freetype2 and fontconfig from repository


#63

I get them from AUR but I see now that they are orphaned and deleted… So I can easily just install freetype from repo and everything should be ok??