[Stable Update] 2017-01-17 - Python, Xorg, Ruby, Gcc, Inkscape

update
stable

#22

Breath theme is super cool but black is kind a thing for a lot of people including me. In manjaro 17 can we expect a black Breath theme and icon?


#23

Indeed I am. Maybe I should try native freetype2 subpixel rendering as the OP suggests.

Update: You were right - oblogout back to normal. Thanks. :slight_smile:


#24

Today I feel like manjaro is what arch should have been. This is not an era of hustle. Linux is so flexible now. Lots of love for manjaro team, other than LTS linux no one can provide this smooth update experience but manjaro is the only exception. Today you guys are at 5 in distro watch… :heart:


#25

everything went smooth as butter. My mind is even fooling me that it’s running slightly quicker now. :joy:


#26

Hi all,
everything went fine but :

  • I had to remove the infinality bundle to get guake to work
  • some windows decoration themes don’t work (arc gtk)
  • most icons theme don’t work

#27

So far everything seems to be working but in Xfce I lost the icon theme. I get the default gnome theme. I can apply fully only the HighContrast theme. I was using the elementary before.


#28

Hi,

I have the same as @ejikVT and additional the following questions for update:

:: Starte vollständige Systemaktualisierung...
:: calligra-karbon durch extra/calligra ersetzen? [J/n] J
:: calligra-l10n-de durch extra/calligra ersetzen? [J/n] J
:: calligra-l10n-en_gb durch extra/calligra ersetzen? [J/n] J
:: calligra-libs durch extra/calligra ersetzen? [J/n] J
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: calligra und calligra-braindump stehen miteinander in Konflikt. calligra-braindump entfernen? [j/N] j
:: xorg-server und xf86-input-acecad stehen miteinander in Konflikt (X-ABI-XINPUT_VERSION). xf86-input-acecad entfernen? [j/N] j
:: xorg-server und xf86-input-joystick stehen miteinander in Konflikt (X-ABI-XINPUT_VERSION). xf86-input-joystick entfernen? [j/N] j
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: lib32-harfbuzz wird vor seiner Abhängigkeit lib32-freetype2 installiert werden

I do not use Caligra so I want to delet it. :slight_smile:


#30

Tiny thing. This always happens after an update to pamac. It won´t show in the tray anymore after login. Tried changing settings and removing pamac and its config, then reinstalling. Still no luck. It just won’t show anymore. Happens on all DE’s I’ve ever run with Manjaro: XFCE, Budgie, MATE, and now Cinnamon. Just can’t seem to figure out why this always happens and why nothing seems to fix it, not even delaying it’s start with 3 or 5 seconds. So weird.

btw, I say always because I have another machine that I test every “release” on, fresh. And always as soon as pamac gets updated, no more pamac-tray icon. Htop shows pamac-tray runs. It just isn’t in the tray any more.


#31

So am confused as mine shows 45 packages.

orbmiser@Plasma-Node667 ~]$ pacman -Qo /usr/lib/python3.5/site-packages
/usr/lib/python3.5/site-packages/ is owned by avahi 0.6.32-2
/usr/lib/python3.5/site-packages/ is owned by hplip 3.16.11-1
/usr/lib/python3.5/site-packages/ is owned by libaccounts-glib 1.23-1
/usr/lib/python3.5/site-packages/ is owned by libftdi 1.3-2
/usr/lib/python3.5/site-packages/ is owned by libixion 0.11.1-3
/usr/lib/python3.5/site-packages/ is owned by liblouis 3.0.0-2.1
/usr/lib/python3.5/site-packages/ is owned by libnewt 0.52.19-1
/usr/lib/python3.5/site-packages/ is owned by liborcus 0.11.2-3
/usr/lib/python3.5/site-packages/ is owned by libplist 1.12-4
/usr/lib/python3.5/site-packages/ is owned by libreoffice-still 5.1.6-4
/usr/lib/python3.5/site-packages/ is owned by libteam 1.23-1
/usr/lib/python3.5/site-packages/ is owned by libtorrent-rasterbar 1:1.1.1-4
/usr/lib/python3.5/site-packages/ is owned by libvoikko 4.0.2-1
/usr/lib/python3.5/site-packages/ is owned by libxml2 2.9.4+12+ge905f08-2
/usr/lib/python3.5/site-packages/ is owned by lirc 1:0.9.4.c-2
/usr/lib/python3.5/site-packages/ is owned by opencolorio 1.0.9-4
/usr/lib/python3.5/site-packages/ is owned by opencv 3.1.0-6
/usr/lib/python3.5/site-packages/ is owned by pacman-mirrorlist 20161101-1
/usr/lib/python3.5/site-packages/ is owned by python 3.5.2-3
/usr/lib/python3.5/site-packages/ is owned by python-appdirs 1.4.0-4
/usr/lib/python3.5/site-packages/ is owned by python-cairo 1.10.0-6
/usr/lib/python3.5/site-packages/ is owned by python-chardet 2.3.0-2
/usr/lib/python3.5/site-packages/ is owned by python-dbus 1.2.4-1
/usr/lib/python3.5/site-packages/ is owned by python-docopt 0.6.2-3
/usr/lib/python3.5/site-packages/ is owned by python-gobject 3.22.0-1
/usr/lib/python3.5/site-packages/ is owned by python-packaging 16.8-1
/usr/lib/python3.5/site-packages/ is owned by python-pillow 3.4.2-1
/usr/lib/python3.5/site-packages/ is owned by python-pip 9.0.1-1
/usr/lib/python3.5/site-packages/ is owned by python-pycups 1.9.73-2
/usr/lib/python3.5/site-packages/ is owned by python-pycurl 7.43.0-1
/usr/lib/python3.5/site-packages/ is owned by python-pyparsing 2.1.10-1
/usr/lib/python3.5/site-packages/ is owned by python-pyqt4 4.11.4-4
/usr/lib/python3.5/site-packages/ is owned by python-pyqt5 5.7-2
/usr/lib/python3.5/site-packages/ is owned by python-pysmbc 1.0.15.6-1
/usr/lib/python3.5/site-packages/ is owned by python-reportlab 3.3.0-1
/usr/lib/python3.5/site-packages/ is owned by python-requests 2.12.4-1
/usr/lib/python3.5/site-packages/ is owned by python-setuptools 1:32.3.1-1
/usr/lib/python3.5/site-packages/ is owned by python-sip 4.18.1-1
/usr/lib/python3.5/site-packages/ is owned by python-six 1.10.0-2
/usr/lib/python3.5/site-packages/ is owned by python-urllib3 1.19.1-1
/usr/lib/python3.5/site-packages/ is owned by python-yaml 3.12-1
/usr/lib/python3.5/site-packages/ is owned by system-config-printer 1.5.7-2
/usr/lib/python3.5/site-packages/ is owned by udiskie 1.5.1-1
/usr/lib/python3.5/site-packages/ is owned by util-linux 2.28.2-2
/usr/lib/python3.5/site-packages/ is owned by xcb-proto 1.12-2

So does that mean I have to manually update 45 packages by hand?
As some seem standard packages and even Manjaro specific pacman-mirrorlist 20161101-1


#32

Fixed my icon issues. The icons affected were svg icons. Reinstalled librsvg and qt5-svg - problem solved.


Problem mit Icons
Xfce icon theme broken
#33

Make sure to update your system first and then do this check. It will show what packages left for manual rebuild.


#34

I am on KDE/Plasma 5. I followed the update instructions, including reverting to native freetype rendering. Everything went extremely smoothly. My sardi-icon set (from AUR) is still working perfectly.
Thanks to everyone for the hard work that clearly went into making this extensive update!


#35

Makes sense thanks! Brain Dead on this End! :dizzy_face:


#36

So an even weirder solution, if I may call it that… I disabled pamac-tray from startup applications list, logged out and in again. Obviously pamac-tray wasn’t running. Then I enabled it again and after another logout/login the icon was sitting there again in my tray, comfortably. I have no idea why this made a difference or if it is reproducible (I’ll try next time pamac updates again and the icon is gone), but for some reason it worked…


#37

Please tell?


#38

Hi!!

I’ve have a loop dependencies:

What should I do?

Regards!!


#39

It’s not a problem. You can safely ignore the warning and procede with the update. Just make sure that it doesn’t get interrupted (which is always good advice anyway :wink: )


#40

Works reliably in KDE.
(Its not pamac running in the tray, its pamac-tray-appindicator).

KDE has options that move notification icos to the tray-expansion area when there are no updates pending. and thats what happens to pamac-tray-appindicator when it has has nothing to report.

Does it reappear when updated become available?
Does it come back after you reboot or do you have to manually start it again?
Do those DEs have a way to set a list of applications you want to start?


#41

Thank you very much!! :grinning:

Just one more question… This afternoon I’ve updated my stable VirtualBox machine, despite in python3.5 folder there is a lightdm entry, I could reboot and login normally. Could this affect in my real machine?

Best regards!!:grinning:


#42

3 posts were split to a new topic: “Today I feel like manjaro is what arch should have been.”


"Today I feel like manjaro is what arch should have been."
"Today I feel like manjaro is what arch should have been."