[Stable Update] 2017-01-17 - Python, Xorg, Ruby, Gcc, Inkscape



Same problem here as well.

The icon will appear though, in red, when there are updates available.


This update broke my bluetooth


I couldn’t figure that one out. Arch wiki says to add kernel parameters at the end of the line that starts with “linux”, but my grub looks like this:

menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-0a51be0f-3ec1-4b4b-a9fb-7c6f162abb36' {
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='hd3,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd3,gpt2 --hint-efi=hd3,gpt2 --hint-baremetal=ahci3,gpt2  0a51be0f-3ec1-4b4b-a9fb-7c6f162abb36
          search --no-floppy --fs-uuid --set=root 0a51be0f-3ec1-4b4b-a9fb-7c6f162abb36
        echo    'Loading Linux 4.4.41-1-MANJARO x64 ...'
        linux   /boot/vmlinuz-4.4-x86_64 root=UUID=0a51be0f-3ec1-4b4b-a9fb-7c6f162abb36 rw  quiet splash resume=UUID=e3a0c46d-9ab6-4f8a-b011-eaa577c842ee
        echo    'Loading initial ramdisk ...'
        initrd  /boot/intel-ucode.img /boot/initramfs-4.4-x86_64.img

So I again booted into a live usb and chroot’d my way into root. “pacman -Qs xorg” returns the following:

local/catalyst-input 2016.09-1 (xorg12-drivers xorg12)                                                                                                                                                                                       
    xf86-input drivers for Catalyst                                                                                                                                                                                                          
local/catalyst-server 1.17.4-3 (xorg117)                                                                                                                                                                                                     
    Xorg-Server for Catalyst                                                                                                                                                                                                                 
local/catalyst-video 2016.09-1 (xorg117-drivers xorg117)                                                                                                                                                                                     
    xf86-video drivers for Catalyst                                                                                                                                                                                                          
local/xorg-bdftopcf 1.0.5-1 (xorg xorg-apps)                                                                                                                                                                                                 
    Convert X font from Bitmap Distribution Format to Portable Compiled Format                                                                                                                                                               
local/xorg-font-util 1.3.1-1 (xorg-fonts xorg)                                                                                                                                                                                               
    X.Org font utilities                                                                                                                                                                                                                     
local/xorg-font-utils 7.6-4                                                                                                                                                                                                                  
    Transitional package depending on xorg font utilities                                                                                                                                                                                    
local/xorg-fonts-alias 1.0.3-1                                                                                                                                                                                                               
    X.org font alias files                                                                                                                                                                                                                   
local/xorg-fonts-encodings 1.0.4-4 (xorg-fonts xorg)                                                                                                                                                                                         
    X.org font encoding files                                                                                                                                                                                                                
local/xorg-fonts-misc 1.0.3-4                                                                                                                                                                                                                
    X.org misc fonts                                                                                                                                                                                                                         
local/xorg-iceauth 1.0.7-1 (xorg-apps xorg)                                                                                                                                                                                                  
    ICE authority file utility                                                                                                                                                                                                               
local/xorg-luit 1.1.1-2 (xorg xorg-apps)                                                                                                                                                                                                     
    Filter that can be run between an arbitrary application and a UTF-8 terminal emulator                                                                                                                                                    
local/xorg-mkfontdir 1.0.7-5 (xorg xorg-apps)                                                                                                                                                                                                
    Create an index of X font files in a directory                                                                                                                                                                                           
local/xorg-mkfontscale 1.1.2-1 (xorg-apps xorg)                                                                                                                                                                                              
    Create an index of scalable font files for X                                                                                                                                                                                             
local/xorg-server-utils 7.6-4                                                                                                                                                                                                                
    Transition package depending on xorg server utilities                                                                                                                                                                                    
local/xorg-sessreg 1.1.0-1 (xorg-apps xorg)                                                                                                                                                                                                  
    Register X sessions in system utmp/utmpx databases                                                                                                                                                                                       
local/xorg-setxkbmap 1.3.1-1 (xorg-apps xorg)                                                                                                                                                                                                
    Set the keyboard using the X Keyboard Extension                                                                                                                                                                                          
local/xorg-twm 1.0.9-1                                                                                                                                                                                                                       
    Tab Window Manager for the X Window System                                                                                                                                                                                               
local/xorg-util-macros 1.19.0-1                                                                                                                                                                                                              
    X.Org Autotools macros                                                                                                                                                                                                                   
local/xorg-utils 7.6-9                                                                                                                                                                                                                       
    Transition package depending on xorg utils
local/xorg-xauth 1.0.9-1 (xorg-apps xorg)
    X.Org authorization settings program
local/xorg-xbacklight 1.2.1-1 (xorg-apps xorg)
    RandR-based backlight control application
local/xorg-xcmsdb 1.0.5-1 (xorg-apps xorg)
    Device Color Characterization utility for X Color Management System
local/xorg-xdpyinfo 1.3.2-1 (xorg-apps xorg)
    Display information utility for X
local/xorg-xdriinfo 1.0.5-1 (xorg-apps xorg)
    Query configuration information of DRI drivers
local/xorg-xev 1.2.2-1 (xorg-apps xorg)
    Print contents of X events
local/xorg-xgamma 1.0.6-1 (xorg-apps xorg)
    Alter a monitor's gamma correction
local/xorg-xhost 1.0.7-1 (xorg-apps xorg)
    Server access control program for X
local/xorg-xinit 1.3.4-4
    X.Org initialisation program
local/xorg-xinput 1.6.2-1 (xorg-apps xorg)
    Small commandline tool to configure devices
local/xorg-xkbcomp 1.3.1-1 (xorg-apps xorg)
    X Keyboard description compiler
local/xorg-xlsatoms 1.1.2-1 (xorg-apps xorg)
    List interned atoms defined on server
local/xorg-xlsclients 1.1.3-1 (xorg-apps xorg)
    List client applications running on a display
local/xorg-xmessage 1.0.4-2
    Display a message or query in a window
local/xorg-xmodmap 1.0.9-1 (xorg-apps xorg)
    Utility for modifying keymaps and button mappings
local/xorg-xprop 1.2.2-1 (xorg-apps xorg)
    Property displayer for X
local/xorg-xrandr 1.5.0-1 (xorg-apps xorg)
    Primitive command line interface to RandR extension
local/xorg-xrdb 1.1.0-2 (xorg-apps xorg)
    X server resource database utility
local/xorg-xrefresh 1.0.5-1 (xorg-apps xorg)
    Refresh all or part of an X screen
local/xorg-xset 1.2.3-1 (xorg-apps xorg)
    User preference utility for X
local/xorg-xsetroot 1.1.1-2 (xorg-apps xorg)
    Classic X utility to set your root window background to a given pattern or color
local/xorg-xvinfo 1.1.3-1 (xorg-apps xorg)
    Prints out the capabilities of any video adaptors associated with the display that are accessible through the X-Video extension
local/xorg-xwininfo 1.1.3-1 (xorg-apps xorg)
    Command-line utility to print information about windows on an X server

What’s it supposed to look like?


This line

But chroot also will do. So you see that you have xorg installed. Next you should look why it doesn’t start. Maybe logs will show something? Also check your graphics driver. Since you have old catalyst driver installed, maybe that causes problems?


Yup. Still wonder why we default to suggesting “-Syu” instead of “-Syyu” . The difference is maybe 20 seconds…and if we defaulted to suggesting Syyu then we could save all the countless hours wasted on saying “oh! well we found the issue. you should update it this other way this time”. I very rarely update any other way. And for users who dont otherwise know the difference - which one is more likely to be successfull, more of the time?


Normally there is no need to rebuild the database. When there were changes, pacman will download the db. I only use yy myself when I get an error about corrupted db or when I would want to switch branches. With a slower internet connection rebuilding db is kind of annoying when you update often. But of course when you update just with a new stable update it will never hurt to use yy :thumbsup:
The thing is just: When you use -Syu for an update just once in a while, the db will have changed and will be updated anyway! :wink: So actually no difference. Honestly I don’t know how these incomplete updates are possible to happen - I believe more that either internet connections got interrupted during the update or were too slow, or that sometimes mirror syncs are even incomplete - which I think should not be possible, but I don’t know exactly how the syncing of mirrors works and if it would be possible that an update-pack is synced only partially - maybe it can happen with a huge update like this…? I wonder.



Only other time I use yy is in combination with uu, when a problematic package has been rolled back to the previous version, or when I’m moving between testing and stable repos.

I have had the odd instance where -Syu has crapped itself, then -Syyu was required.


I also wonder about this! Could it be the discard option on cheap SSD’s? Can it cause minor corruption issues which become more relevant when certain files are changed?

I only use it when I want to update the system before pacman becomes aware of it (I don’t synch daily, even-less hourly).


But pacman will automatically download and sync the database anyway if there are any changes. Delays upgrading are mirror sync related, not pacman related.


I’ve had times when an update was available, the mirrors on my country were synced and I had to force the rebuilding of the db so pacman could get the updates. I deduced this behaviour to be caused by a longer syncing period (I had had it monthly in the past, then changed to weekly, and now it is set to daily on my laptop - need to check on my desktop). Pacman just assumed the database was up to date. Maybe I deduced it wrongly, I really don’t know.

After re-reading arch wiki and the man page, I agree with you, but it occasionally happens, especially when there is an update between syncs that I want to apply.


I have no idea how I missed that. I feel dumb.

In other news: victory! ‘journalctl’ eventuallly showed me a “SDDM-helper exited with 7” error. Googling that led me to delete the sddm cache, which fixed it. Thanks, kainonergon!


When I did this update it seemed to work fine, but a couple days later my system froze out of the blue.
After that the system would load up to the login screen, and after entering my password it freeze.
After doing some retries, all with the same result, I decided, in grub screen to try to but with the previous kernel version 4.1.37-1 instead of the 4.4.41-1 the recommend.
Now, at every boot I have to stop at the grub screen and pick the older kernel version.
Have anyone experienced that?
Can you help me?


You could try installing 4.9 series and see if it works flawlessly. If it does then remove 4.4 and keep 4.1 as backup.

Alternatively wait for the next 4.4 series, currently 4.4.44 and see if that fixes it.


Thanks for the tip.
I’ve installed 4.9.2-1 using mhwd-kernel -i linux49 (as explained in the Majaro’s Wiki).
Restarted the and computer and in the GRUB screen I choose linux 4.9.2-1, but the result was the same as with version 4.4.41-1.
The system froze right after logging in.
I rebooted the computer and restarted it in the 4.1.37-1.

It is interesting because I’ve been using Manjaro for quite sometime now (since CrunchBang lost the support from the maintainer), and I’ve been using the rolling release feature since then and I have never experienced this sort of problem (a consistent system freeze).

Is there anything I can do, like collect log info or collect system configuration info, or else to help you guys, please let me know and I’ll gladly try to do it.


Libreoffice stopped working after this update (both still and fresh). The main window doesn’t show up, there is no terminal output and I couldn’t find any debug options. Debugging with GDB fails because there are no debugging symbols in the package… What has been changed in the package, where can I find a changelog of a particular Manjaro package?

edit: Looks like libreoffice packages are just taken over from Arch and in their changelog it says, that there was just a Python 3.6 rebuild. But this doesn’t really help to troubleshoot the problem.


hm. For me fresh is still working normally (on unstable though - but I never had an issue during all the updates…)


For me it also works fine but on a machine of another user (which I can only access remotely) the problem appears for some reason. It’s an older man who is quite inexperienced with computer usage so he might have done something unintentionally which is hard to track down…


Smooth update again!

Note: Rebuilt dependent packages due to Python 3.6 update.


Thank you Manjaro team for another good update.

I had a problem with powerline saying:

bash: . /usr/lib/python3.5/site-packages/powerline/bindings/bash/powerline.sh: No such file or directory

But it can be solved by editing .bashrc and replace:
. /usr/lib/python3.5/site-packages/powerline/bindings/bash/powerline.sh
. /usr/lib/python3.6/site-packages/powerline/bindings/bash/powerline.sh


One more thing mpd 0.20.1-1 causes songs to stutter when you switch between them, I had to downgrade to mpd 0.19.21-1 to get rid of the problem