[Stable Update] 2017-01-17 - Python, Xorg, Ruby, Gcc, Inkscape



Performance nothing to complain about because I am now in the test repository.
But I noticed a higher consumption of RAM that does not leave something to be desired, because running in almost 20 hours without any problem.
Kernel 4.9.4 and last update in testing repository.
Last update: yesterday

[Testing Update] 2017-01-17 - KDE Frameworks, Deepin, Kernels, Extramodules, Pacman-mirrors

@oberon @DarN, I did try that. A few times, actually, but it didn’t work on my machine. Thanks, though.


Thanks! I also got rid of infinality finally, but still miss it.


Whit this upgrade I brake my os. I don’t know what to do.My system boot but don’t enter in graphical environment.
I can log in virtual console but don’t know what to do. I have some packages in /usr/lib/python3.5/site_packages but I never install something from aur and also I don’t know how to update those packages.
Also I have nvidia gpu and use gnome with gnome edition.
I hope there is no need for reinstall. Probably my video driver tune or fix gnome to not use wayland by default.
I don’t know how to fix those things and how to extract useful info . PLS help me

  • Which ones?
  • Is your update complete? Try running sudo pacman -Syu from the console once more.
  • Try booting a different kernel if - hopefully - you have installed one …


no I don’t have I’m with 4.4 the default


Ok. How about my other suggestions?


yes that helps thanks but for some reason I should call sudo pacman -Syyu instead of sudo pacman -Syu


@kalin Make sure that the Nvidia drivers are installed correctly and that are missing xorg or some dependency.

To AUR use yaourt -Syua
To pacman search by update is sudo pacman-mirrors -g && sudo pacman -Syyu

NVIDIA - ArchWiki

To reinstall your desktop environment.


pacman -S mate mate-panel mate-extra yelp mate-themes-extra network-manager-applet

Xfce 4:

pacman -S xfce4 xfce4-goodies

Gnome 3:

pacman -S gnome-shell gnome gnome-extra


pacman -S kde kde-l10n-pt_br

I hope these instructions help you. :wink:


It maybe a stupid question but have you seen this?


Yes I have and no, that’s not activated. But even activating that option and then deactivating it doesn’t make a difference. The icon will not show up in the tray, regardless of that setting.


I had the same setuptools problem and it’s just weird

/usr/lib/python2.7/site-packages/setuptools/ is owned by python2-setuptools 1:32.3.1-1
/usr/lib/python2.7/site-packages/pkg_resources/ is owned by python2-setuptools 1:32.3.1-1

however there are a bunch of files in those folders that are not ‘owned’ by python2-setuptools 1:32.3.1-1 but conflict with python2-setuptools 1:33.0.0-1.

An old packaging mistake now fixed, @oberon?

Anyway, pacman -S --force python2-setuptools fixes it and allows the update to continue.

I also did yaourt -S --needed freetype2 fontconfig lib32-freetype2 beforehand to replace the ubuntu variants, cc @trzalica . Got a message I am saving for future reference:

Fontconfig configuration is done via /etc/fonts/conf.avail and conf.d.
Read /etc/fonts/conf.d/README for more information.
Configuration via /etc/fonts/local.conf is still possible,
but is no longer recommended for options available in conf.avail.
Main systemwide configuration should be done by symlinks
(especially for autohinting, sub-pixel and lcdfilter):

cd /etc/fonts/conf.d
ln -s ../conf.avail/XX-foo.conf

Check also https://wiki.archlinux.org/index.php/Font_Configuration
and https://wiki.archlinux.org/index.php/Fonts.

Anybody knows if leaving cairo-ubuntu is OK at this point?..


after this update, I can’t use the PS3 sixaxix controller as a mouse anymore (and I want to use it as a mouse)


Maybe you will need xf86-input-joystick - now available from the AUR



I’ve moved the discussion here I can’t control the mouse with Sixaxis anymore

where I described my problem more accurately


I’m seeing the following when I use “pacman -Syu”. Is it ok to proceed with the update?

:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…
:: xorg-server and xf86-input-acecad are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-acecad? [y/N] y
:: xorg-server and xf86-input-joystick are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-joystick? [y/N] y
warning: dependency cycle detected:
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
warning: dependency cycle detected:
warning: python2-twisted will be installed before its python2-incremental dependency


you are better off using pacman -Syyu instead. this makes sure your mirrors are up to date


No problem at all.
“dependency cycle detected:” is just a warning that pacman was not able to sort all packages in an order where the dependencies get installed before the packages depending on them - so in case the update process would get interrupted there would possibly exist packages left broken … just leave your power supply on, that will be good … :wink:


I’m running Manjaro KDE and I’m getting a black screen after the update. I installed through Octopi and it didn’t ask me any questions or give any sort of errors or warnings that I remember before completing OK. Now when I boot I get through GRUB, the Manjaro loading screen and then get a black screen about when I would see the login screen. I think there’s something going on in the background because if I leave it long enough the monitor will turn off like the computer is in power saving mode, and when I try to switch to tty with ctrl-alt-f1 the screen refreshes (backlight off and back on). I don’t believe it’s related to infinality because I don’t remember ever installing it, and just to be sure, I chroot’d in from a live usb and ran ‘pacman -Qs infinality’ with no results.

My inxi -Fxzc0 is at:


Hi. You can try to boot to tty. Just add kernel parameter “3” from grub menu. From tty you can check if xorg was not uninstalled during the update.